Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Magento Connect Manager only FTP and Local Filesystem inactive
 
Stonecold2k
Jr. Member
 
Total Posts:  7
Joined:  2011-01-03
 

Hello@all,

i have the problem that i have only FTP Deployment in my Magento Connect Manager.

The point “Local Filesystem” is inactive.

Are there any changes from Magento 1.4 -> 1.5.1?

Image Attachments
settings.png
 
Magento Community Magento Community
Magento Community
Magento Community
 
furnitureforyoultd
Enthusiast
 
Total Posts:  833
Joined:  2009-03-09
 

Local filesystem being inactive is possibly caused by a permissions error, check that your magento folder has the right permissions and owner

 
Magento Community Magento Community
Magento Community
Magento Community
 
Trenza
Member
 
Avatar
Total Posts:  57
Joined:  2010-03-11
Dhaka, Bangladesh
 

Facing same problem; can you please be more specific on folder/file permission. All files/folders have the exact write permission already.

 
Magento Community Magento Community
Magento Community
Magento Community
 
seanscullion
Jr. Member
 
Total Posts:  1
Joined:  2012-04-29
 

Do you know specifically which directories need write permission?

thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ackley
Jr. Member
 
Total Posts:  28
Joined:  2012-08-24
 

The problem is comes in checkout.xml file when you are upgrading to Magento 1.4.1 to Magento 1.5.1.This file located in app/design/frontend/base/defualt/layout/”yourththemehere”/checkout.xml. By removing this error you have a multiple option that is replace the checkout.xle file in the default theme foleder and than overwrite it in your theme.Make a point remove the Magento cache memory .The changes is done after flush the Magento Cache.

 
Magento Community Magento Community
Magento Community
Magento Community
 
lovefragrance
Jr. Member
 
Total Posts:  1
Joined:  2011-11-26
 

I just had the exact same problem. After spending two hours, I just changed permissions of the parent directories of my magento installation to 777 and now filesystem is active.

 
Magento Community Magento Community
Magento Community
Magento Community
 
bazookaab
Jr. Member
 
Avatar
Total Posts:  4
Joined:  2010-05-05
 

FYI you need to set write permissions to these directories:

app/code/community
app/etc/modules
downloader

Maybe var as well.

 
Magento Community Magento Community
Magento Community
Magento Community
 
zergussino
Jr. Member
 
Total Posts:  1
Joined:  2009-03-12
 

Magento Filesystem Permissions

If you wish to use web based downloader for installation, upgrades or MagentoConnect extensions installation, you will need to have write permissions on ALL magento files including the root Magento folder.

Files and folders will need to be returned to 655 non-writable permissions after installation.[...]

Don’t forget to do

find . -type d -exec chmod 775 {} ;
find . -type f -exec chmod 664 {} ;
after installation
 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top