Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 2 of 2
(mt) Problem Highlighted!!! READ THIS IF YOU HOST WITH (mt)
 
(mt) df
Jr. Member
 
Total Posts:  7
Joined:  2007-10-19
 

Apologies for all the troubles you’ve run into. I was able to install the latest version (0.6.13160) on my (gs) Grid-Service, without problems. It didn’t complain about using MySQL (4.1.11). Just remember to include the following in your .htaccess file. Important Note: if you enable php5 after uploading your files your .htaccess will get overwritten so keep that in mind and make sure your .htaccess looks like the one below before you try to access the install wizard.

AddHandler php5-script .php

<IfModule mod_php5.c>
    
php_flag magic_quotes_gpc off
    php_flag short_open_tag on
</IfModule>

DirectoryIndex index.php

RewriteEngine on

RewriteCond 
%{REQUEST_URI} !^/media/
RewriteCond %{REQUEST_URI} !^/skin/
RewriteCond %{REQUEST_URI} !^/js/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond 
%{REQUEST_FILENAME} !-d
RewriteCond 
%{REQUEST_FILENAME} !-l

RewriteRule 
.* index.php
 
Magento Community Magento Community
Magento Community
Magento Community
 
lotusseedsD
Mentor
 
Avatar
Total Posts:  1144
Joined:  2007-08-31
 

Hi, thanks for the info. I am curious though, did you install the light or full version?

I was able to install the light version (no complaint from mysql version either) from the previous update that was released last week, but the full version still couldn’t work. Unless someone confirms and can show a live site that all things are functional, I am very skeptical to conclude that the (mt)’s servers (gs and ds) are now compatible with Magento’s requirements. 

See my other post on the light Vs full version:
http://www.magentocommerce.com/boards/viewthread/879/

I just helped a client move away from (mt) because of this very reason. It’s very unfortunate as I really like the admin of (mt) and think the company will improves its ticket customer services and update the mysql version to accomodate Magento. The request was ignored, so I must think that (mt) has it good reason to let customers go. 

Are you from (mt)?

 
Magento Community Magento Community
Magento Community
Magento Community
 
(mt) df
Jr. Member
 
Total Posts:  7
Joined:  2007-10-19
 

I’m with (mt). I installed the light version. Until reading more threads I didn’t realize the full version was incompatible. Until MySQL is updated on the (gs) or Magento’s requirements change, or someone comes up with a workaround looks like only the light version will work for now.

 
Magento Community Magento Community
Magento Community
Magento Community
 
lotusseedsD
Mentor
 
Avatar
Total Posts:  1144
Joined:  2007-08-31
 
(mt) df - 19 October 2007 03:15 PM

I’m with (mt). I installed the light version. .

I was hoping you work for (mt) and was counting on you to convince your employer upgrade the mySQL version smile

No luck!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Deelicious
Jr. Member
 
Total Posts:  17
Joined:  2007-10-26
 

I’m attempting to install version 0.6.13160 on my Media Temple (dv) server using the instructions by Travis with no luck either.

The .htaccess file in the magento folder is now different so I popped in his suggested code in a few places, but none of the trials worked.

Sometimes when trying to access the install page, I’m asked to download “application/x-httpd-php” while other times it gives a 404 saying it can’t find the index.php page.

Any suggestions? Thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
 
lotusseedsD
Mentor
 
Avatar
Total Posts:  1144
Joined:  2007-08-31
 

Did yo change to PHP 5 from PHP 4 in your admin panel?

If I remember correctly, I think Travis mentioned in one of his post that the Magento doesn’t work (mt)’s dv that he thought it worked.

I was able to install the light version, but the full version still not working. It must be the mySQL 4.11 problem. Since that Magento clearly stated in the system requirement that mySQL 4.1.2 is needed, so unless (mt) ungrades the version, it’s likely one will encounter errors here and there. I had wasted so much time to try to get it working on my gs account, all went furtile. That being said, I think you will be better off looking for another webhost that the system is compatible with Magento’s requirement.

p/s. I was able to install the full version in my gs account using client’s database from another webhost. Not perfect and abit slow, but it allows me to test/play with the Magento demo site.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michael_1
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 
Deelicious - 26 October 2007 11:47 AM

The .htaccess file in the magento folder is now different so I popped in his suggested code in a few places, but none of the trials worked.

I’ve installed Magento on (dv) successfully. Here is my .htaccess:

<IfModule mod_php5.c>
    
php_flag magic_quotes_gpc off
    php_flag short_open_tag on
</IfModule>

Action php5-cgi /cgi-bin/php5-cgi
AddHandler php5
-cgi .php

DirectoryIndex index
.php

RewriteEngine on

#RewriteBase /

RewriteCond %{REQUEST_URI} !^/media/
RewriteCond %{REQUEST_URI} !^/skin/
RewriteCond %{REQUEST_URI} !^/js/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond 
%{REQUEST_FILENAME} !-d
RewriteCond 
%{REQUEST_FILENAME} !-l

RewriteRule 
.* index.php

My php5-cgi permissions and location:

-bash-3.00ll /var/www grep cgi-bin
drwxr
-xr-x  3 root      root 4096 Oct 26 12:25 cgi-bin
-bash-3.00ll /var/www/cgi-bin/ | grep php5
-rwxr-xr-x  1 root root 18440550 Aug 31 11:15 php5-cgi

Right now I’m preparing a step-by-step how-tos on installing Magento both on (dv) and (gs), let me know on any other issues you have.

Thank you.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michael_1
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 
chinesedream - 26 October 2007 05:02 PM

Did yo change to PHP 5 from PHP 4 in your admin panel?

I’ve not found any way to upgrade to PHP5 in Plesk admin panel on (dv).
I got a root access in order to switch to PHP5, but there’s only PHP 5.1.4 available there:

-bash-3.00$ /opt/php51/cgi-bin/php5 -v
PHP 5.1.4 
(cgi-fcgi) (builtAug 23 2006 15:59:10)
Copyright (c1997-2006 The PHP Group
Zend Engine v2.1.0
Copyright (c1998-2006 Zend Technologies
    with the ionCube PHP Loader v3.1.16
Copyright (c2002-2006by ionCube Ltd.

That’s not enough to meet Magento requirements (PHP 5.2.0 or newer). So I just followed the php5-cgi KB article and got Magento working.

chinesedream -

I was able to install the light version, but the full version still not working.

I’ve found a workaround to install a full Magento version on (gs). I’ll post it alongside with the how-tos. That is a temporary solution - we’ll include a permanent one in the following releases.

 
Magento Community Magento Community
Magento Community
Magento Community
 
lotusseedsD
Mentor
 
Avatar
Total Posts:  1144
Joined:  2007-08-31
 

Micheael, thanks for the effort. I will test it out when a how-tos is available.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Deelicious
Jr. Member
 
Total Posts:  17
Joined:  2007-10-26
 

I too was unable to successfully get Magento to work on my mt(dv), so I am eagerly awaiting the how-to. Thanks for your help Michael!

 
Magento Community Magento Community
Magento Community
Magento Community
 
RoyRubin
Enthusiast
 
Avatar
Total Posts:  968
Joined:  2007-08-07
Los Angeles, CA
 

Guides are now up

http://www.magentocommerce.com/blog/comments/media-temple-install-guides-for-dv-and-gs/

 
Magento Community Magento Community
Magento Community
Magento Community
 
gento
Jr. Member
 
Total Posts:  16
Joined:  2007-09-30
 

Has anyone been able to install on MT DV 3 with success following the new guides?

I still ended up with a server error.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 2 of 2