Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Paypal - invoice sometimes not created
 
Fittster
Jr. Member
 
Total Posts:  6
Joined:  2008-09-22
 

Hi all,

Just a bit of info on my setup first. I am using Magento v.1.4.1.1 and Paypal Website Payments Standard.

My issue is that sometimes, and I mean only about 1 in 10, when a user successfully goes through the checkout process, an invoice isn’t created in Magento, but the Order is.

So… A user buys a product. An Order is created (in Magento). The user goes through to Paypal. We recieve the money in paypal. The user is sent back to the store but the Invoice isn’t created in Magento.

Like I said, this only happens rarely. I can’t see any obvious consistent reason of why this is happening.

I’ve googled.. and googled… and did a bit more googling but can’t find any help there, even though I did come across a few other people who seemed to have the same issue.

I really need the invoice to ALWAYS be created as it is then emailed directly to our shipping people to process the order. If this doesn’t happen, we get paid but never send the order unless we manually go into the system and re-create the invoice which defeats the purpose of having this fully automated.

Any help would be greatly appreciated!

Fittster

 
Magento Community Magento Community
Magento Community
Magento Community
 
mageprofis
Jr. Member
 
Total Posts:  5
Joined:  2010-05-11
 

Any news on that? Same problem here with 1.4.1.1.

Orders geht through, IPN “Completed”, order status switches to “processing” but no invoice generated or send.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Fittster
Jr. Member
 
Total Posts:  6
Joined:  2008-09-22
 

I still don’t have an answer to this one. To make things worse, rather than it happening 1 in 10, it’s now happening 9 in 10!

I’m wondering whether an upgrade to 1.5 will fix this, but that’s so much work…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Peppermay
Sr. Member
 
Avatar
Total Posts:  111
Joined:  2008-10-18
Lille, France
 

Same issue here after upgrading to 1.4.1
Any help with this ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Peppermay
Sr. Member
 
Avatar
Total Posts:  111
Joined:  2008-10-18
Lille, France
 

Well, two different issues it seems…
First, IPN URL callback changed between 1.3.3 and 1.4.1, turning to /paypal/ipn. Paypal seller setting has to be updated.
Second, there is possibly a problem with totals (I’m on a french e-commerce site); sometimes buyer’s payment differs from Magento total about a few cents, turning IPN to be wrong.
Beside, paypal_api_debug seems not be updated anymore…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Vampal
Member
 
Avatar
Total Posts:  37
Joined:  2011-10-16
 

Any results?

Peppermay - 27 July 2011 11:02 PM

Well, two different issues it seems…
First, IPN URL callback changed between 1.3.3 and 1.4.1, turning to /paypal/ipn. Paypal seller setting has to be updated.
Second, there is possibly a problem with totals (I’m on a french e-commerce site); sometimes buyer’s payment differs from Magento total about a few cents, turning IPN to be wrong.
Beside, paypal_api_debug seems not be updated anymore…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Peppermay
Sr. Member
 
Avatar
Total Posts:  111
Joined:  2008-10-18
Lille, France
 

I just modified the ipn.php file in order to prevent a small difference between both amounts to invalidate the payment.
Not very orthodox programmaticaly- and acountingly-speaking but it works for now…

 
Magento Community Magento Community
Magento Community
Magento Community
 
JonathanJ
Member
 
Avatar
Total Posts:  60
Joined:  2008-08-27
Liege
 
Peppermay - 27 July 2011 11:02 PM

Well, two different issues it seems…
First, IPN URL callback changed between 1.3.3 and 1.4.1, turning to /paypal/ipn. Paypal seller setting has to be updated.
Second, there is possibly a problem with totals (I’m on a french e-commerce site); sometimes buyer’s payment differs from Magento total about a few cents, turning IPN to be wrong.
Beside, paypal_api_debug seems not be updated anymore…

Thank you, in fact the secand case (order amount difference) was the reason !

Thanks !

 
Magento Community Magento Community
Magento Community
Magento Community
 
Bates
Jr. Member
 
Total Posts:  17
Joined:  2011-11-20
 

Old topic I know but we are experiencing the exact same problem. It is ever so random but becoming stressful on our behalf as we are not sending customer orders out as the invoice is not generated and emailed to us until we manually enter the system and generate the invoice. Even then the order stands on pending payment and does not show in the customers dashboard until we ship the item.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top