Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Problem translating phrases with double quotes
 
Jose Dorrego
Jr. Member
 
Total Posts:  7
Joined:  2008-10-01
Barcelona, España
 

Hello all.

I’m trying to translate a phrase, for example:  Edit Product Attribute “Price”

(that’s the title in the page: index.php/admin/catalog_product_attribute/edit/attribute_id/59/?ft

Examinig the code, this title comes from the file: app/code/core/Mage/Adminhtml/Block/Catalog/Product/Attribute/Edit.php
line 64:

return Mage::helper('catalog')->__('Edit Product Attribute "%s"'$this->htmlEscape(Mage::registry('entity_attribute')->getFrontendLabel()));

And in the correspondent Mage_Catalog.csv I have these two lines:

“Edit Product Attribute","Editar el atributo del producto”
“Edit Product Attribute “"%s""","Editar el atributo del producto “"%s"""

The issue is that I don’t see why it isn’t working.  The doble quotes are escaped in the CSV file (by adding extra doble quotes for each one).

If I replace

Mage::helper('catalog')->__('Edit Product Attribute "%s"',

with

Mage::helper('catalog')->__('Edit Product Attribute',

The translation works, and because of this, I’m sure that the system is reading that CSV file, but still don’t get why won’t translate when usign double quotes.

Anyone having a similar problem?

Thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
 
wdchoi
Jr. Member
 
Total Posts:  20
Joined:  2008-11-17
 

hi jdorrego.

I think you should put this in your csv :
“Edit Product Attribute “"%s"""","Editar el atributo del producto “"%s""""

If you count how many double quotes you put, you have to get an even number !

You might even try to take out the last couple of double quotes in each sentence, that might work too.

David

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top