Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 2 of 2
Installing on 1and1 webspace
 
Solar Frenzy
Member
 
Avatar
Total Posts:  48
Joined:  2007-09-05
London
 

That’s correct.

I was in fact told to add the following to the htaccess file:

AddHandler application/x-httpd-php5 .php

 
Magento Community Magento Community
Magento Community
Magento Community
 
grevand
Jr. Member
 
Total Posts:  3
Joined:  2007-08-31
 

As the starter of this thread, I am still no closer to installing on 1and1 shared hosting. Should have said i am based in UK
Anyone help please

 
Magento Community Magento Community
Magento Community
Magento Community
 
Catia
Jr. Member
 
Total Posts:  21
Joined:  2007-08-31
 

grevand, what exactly is the problem?  It’s hard for anyone to help if you aren’t more specific…

I use 1&1;as well and I have been able to install Magento after reading this thread.

My .htaccess file is as follows (a couple very minor changes from the one iPhony posted earlier):

AddType x-mapp-php5 .php
AddHandler x
-mapp-php5 .php

#php_flag magic_quotes_gpc off
#php_flag short_open_tag on

DirectoryIndex index.php

RewriteEngine on

RewriteBase 
/magento/
RewriteRule !\.(js|ico|txt|gif|jpg|png|css)$ index.php

#RewriteCond %{REQUEST_URI} !^/media/
#RewriteCond %{REQUEST_URI} !^/skin/
#RewriteCond %{REQUEST_URI} !^/js/
#RewriteCond %{REQUEST_FILENAME} !-f
#RewriteCond %{REQUEST_FILENAME} !-d
#RewriteCond %{REQUEST_FILENAME} !-l

#RewriteRule .* index.php
 
Magento Community Magento Community
Magento Community
Magento Community
 
grevand
Jr. Member
 
Total Posts:  3
Joined:  2007-08-31
 

Your brilliant, thanks a lot for posting your htaccess file,. That did the trick

 
Magento Community Magento Community
Magento Community
Magento Community
 
logicole
Jr. Member
 
Total Posts:  3
Joined:  2007-09-20
 

Hi,

I’m attempting to install on a US 1&1;Linux account, but I am getting the Internal error.  I used the exact htaccess file posted in this thread and get the same error.

I fooled around - and when I remove the rewrite rule entirely, I get the install screen.

I also tried Iphony’s rewrite and get the Internal error.

Any suggestions?

UPDATE: This method worked out after all - checked back after a few hours and got the install page.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ncbavenew
Jr. Member
 
Total Posts:  2
Joined:  2007-12-06
 

Thank you!! especially iphony and catia. This does indeed work now on 1&1;:-)

 
Magento Community Magento Community
Magento Community
Magento Community
 
ralphie
Member
 
Total Posts:  59
Joined:  2007-12-20
London
 

has anybody magento ver. 0.7.14800 running on 1and1?

if so, how did you do it? i just dont get it to work..

either 1and1 or more likely magento must have changed something, since the fixes above in this forum don’t help any more, well at least not for me..

please anybody let me know, i just get a page w/a images and css, etc..  looks like a rewrite issue, but i didn’t figure it out yet..

 
Magento Community Magento Community
Magento Community
Magento Community
 
Zinner
Sr. Member
 
Avatar
Total Posts:  77
Joined:  2007-11-16
Germany
 

Hi,

just have a look :

http://www.magentocommerce.com/boards/viewreply/10471/

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 2 of 2