Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

admin/admin in path - want to set it back to admin/
 
alex.bsc
Guru
 
Total Posts:  340
Joined:  2008-06-06
 

I moved my magento install files from http://url/store to http://url/
i.e. i moved it back one subfolder

after much fiddling and flushing of caches i got the admin working.
however, i have noticed in that i am accessing admin via the url path http://url/index.php/admin/admin/… as opposed to http://url/index.php/admin/

how can i remove this duplicate admin entry from the url path?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Brandlive_br
Guru
 
Avatar
Total Posts:  653
Joined:  2008-05-19
Buenos Aires, Argentina
 

Check the next few things.

1) Clean your Magento cache.

2) Inthe the database, look for the core_config_data table. There you got two keys with the secure and unsecure url. Maybe that values are incorrect?

 
Magento Community Magento Community
Magento Community
Magento Community
 
alex.bsc
Guru
 
Total Posts:  340
Joined:  2008-06-06
 

nope, that’s not it.. i’ll try clearing caches again..
and nope, that did not help either.

 
Magento Community Magento Community
Magento Community
Magento Community
 
alex.bsc
Guru
 
Total Posts:  340
Joined:  2008-06-06
 

I have edited local.xml in app/etc to try and debug this to the following;

<frontName><![CDATA[ad]]></frontName>
from
<frontName><![CDATA[admin]]></frontName>

The url given is now;
http://url/index.php/admin/ad/

this is a real problem as magento 1.1.7’s googe base feed is giving me 404 errors and i have the feeling this is the cause.

the google base url follows the proper path - http://url/index.php/admin/googlebase/types/

can someone aid in debugging this?

 
Magento Community Magento Community
Magento Community
Magento Community
 
alex.bsc
Guru
 
Total Posts:  340
Joined:  2008-06-06
 

update:

when i moved the magento package back up one folder to http://url/store/, admin/admin has indeed disappeared from the path (or admin/ad - if local.xml is modded to have ‘ad’ as the admin path).

we are back to;

http://url/store/index.php/admin/dashboard/

It turns out the /admin/admin/ bug is adding a redundant /admin/ for absolutely no reason when your magento install files are moved back one directory, placed in front of the admin path found in local.xml.

 
Magento Community Magento Community
Magento Community
Magento Community
 
alex.bsc
Guru
 
Total Posts:  340
Joined:  2008-06-06
 

UPDATE:
I have enabled
Add Store Code to Urls to Yes

and it appears this bug has been around for some time;
http://www.magentocommerce.com/bug-tracking/issue?issue=1858

a related bug caused because of this bug;
http://www.magentocommerce.com/boards/viewthread/23522/

 
Magento Community Magento Community
Magento Community
Magento Community
 
Luke Berg
Jr. Member
 
Total Posts:  8
Joined:  2008-09-30
 

I’m having the same problems.. I initially installed magento on a server with multiple sites on it, and when I installed it, the DNS entry for the store couldn’t be setup yet.  So, I set the ‘base url’ in the installation to http://<ip address>/~<cpanel user>/ so I could access and start configuring the store before the DNS was set.  Once I set the DNS properly, I changed the base url of the store to http://<domain>/.  Note that I didn’t actually move any of the magento files to a different directory. 

Anyway, after switching the base url the admin section has the double /admin/admin/ in the url at all times.  It also is causing a lot of weird problems with the interface… like under ‘Catalog’ > ‘Manage Categories’ > ‘Choose Store View’.  When I change the store view, the ‘loading’ image never goes away, and eventually the page disappears.

I firebugged it, and what’s happening is the ajax request to retrieve the new store view includes the /admin/admin/ in the url.  For some reason, the request returns a 302 error but redirects to the same url, so there’s an infinite request loop, and when firefox finally gives up, the page goes blank.

There are a bunch of other weird problems with the admin interface, but I’m assuming they are all related to this.  Fortunately we are early enough on that we are going to just reinstall it, but if someone wants to try to reproduce the problem and fix it, I hope this helps.  I can give more information if needed.

 
Magento Community Magento Community
Magento Community
Magento Community
 
elvar
Member
 
Total Posts:  59
Joined:  2009-01-30
 

I have a problem with the admin/admin in the url in 1.3.1 version.

This is a history what happened:

1. I have the Magento installed on my domain in one subfolder
2. I had backup for all the files
3. my domain got infected with the gumblar.cn (more exactly Martuz.cn) virus
4. in order to be sure I check the backup for the viruses - restore it over the existing files and manually replaced all infected files with original Magento files (which I did not changed before)
5. also I did manual applying of permissions for each folder to 755 and each file to 644 (because this virus also is changing permissions and htaccess)
6. now in admin panel I have admin/admin in the path which is ending in the situation that:
- my customers cannot finish the payment with the Moneybookers
- in admin I cannot see the orders (list of orders I can but just order itself not)

Any suggestions?

 
Magento Community Magento Community
Magento Community
Magento Community
 
binclintonusa
Jr. Member
 
Total Posts:  1
Joined:  2009-06-10
 

I hope this helps.  I can give more information if needed.

pret auto

 
Magento Community Magento Community
Magento Community
Magento Community
 
Zync
Jr. Member
 
Total Posts:  1
Joined:  2009-04-20
 

We have several websites at one server, of which one is a Magento webshop.
Luckily it’s just a webshop to test Magento for future use.
But tt’s the fifth time in a few months time that it has been infected.
Is there anyone who has the same experience?

 
Magento Community Magento Community
Magento Community
Magento Community
 
elvar
Member
 
Total Posts:  59
Joined:  2009-01-30
 

Does anybody already somehow solved the problem with admin/admin in the url?

I am still having problems to load order in the admin view and to see actually what customer bought?!?

I need to use export orders in csv to actually see it....

 
Magento Community Magento Community
Magento Community
Magento Community
 
sajidhussain
Jr. Member
 
Total Posts:  1
Joined:  2009-10-29
 

Helo guys ,
I m facing same issue
any suggestion u might have to fix this or debug this . but I dint moved folder

Sajid

 
Magento Community Magento Community
Magento Community
Magento Community
 
optimumenergy
Jr. Member
 
Total Posts:  17
Joined:  2010-02-25
 

Ok, I had this bug for quite a while, but it’s not a bug actually it’s a weird and wonderful Magento oddity ....

There are a few things to check first, before the explanation:
1. Check the values in /magentofolder/app/etc/local.xml and ensure all is good. For the purposes of this, you can set the CDATA value of the admin path to “admin”
2. Log in and check the values at System > configuration > Web > Unsecure URL (and Secure URL) - make sure they are good (they should be, otherwise you’d not be able to log in very easily
3. Go to System > configuration > Advanced > Admin ... set the value of ‘use custom admin url’ to unchecked and remove any values, if any, in the URL box underneath it.

Next, for the magic ... if all these settings are correct, and you’re seeing admin/admin, then you probably have a flag at System > configuration > General > Web > URL options > Add store code to URL turned on.

What this does is on the front end it includes the store code (actually store view code) to the url for mutli-store setups, so that you can access a store like this : http://www.domain.com/store_code_1/ or http://www.domain.com/store_code_2/ ... etc. BUT - here’s the kicker, it also does it for the admin (which has store code admin) - therefore, the path to your admin is now admin/admin - the first being the store code, the second being the path to serve the application. And so, some extensions that don’t use dynamic admin url path-ing (that a word?) won’t work now - probably you’ll get a 404 where you expect your content to be in the main body of the page.

What I’ve found is that enabling the second option in that admin roll up (System > configuration > General > Web > URL options) which is called “Redirect to Base URL if requested URL doesn’t match it” fixes all of my problems. They might for you too.

Otherwise the only other option I can think of is if you turn off Add Store Code to URLs .... but if you have a multi-store site, I don’t know how your site would function. You’d have to try it.

That’s what I found. Hope it helps someone else smile

Darren.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top