Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Probleme magento 1.5 dupa instalare
 
Lucianmincu
Jr. Member
 
Total Posts:  3
Joined:  2011-04-06
 

Salutare.

Am o problema dupa instalarea de magento pe un server cu cpanel si de cateva zile incerc sa imi dau seama de la ce poate fi si tot citesc topic-urile de aici si nu gasesc nici o solutie.
Dupa instalarea standard facuta dupa tutorialul de la magento primesc aceeasi eroare (reusesc sa intru pe contul de admin dar aproape la orice optiune de modificare primesc eroarea :

“There has been an error processing your request
Exception printing is disabled by default for security reasons.

Error log record number: 1603113165” (error log number-ul variaza)

iar in error log scrie asa :

a:5:{i:0;s:71:"Could not determine temp directory, please specify a cache_dir manually";i:1;s:3810:"#0 /home/medicine/public_html/lib/Zend/Cache/Backend.php(197): Zend_Cache::throwException(’Could not deter...’)
#1 /home/medicine/public_html/lib/Zend/Cache/Backend/File.php(123): Zend_Cache_Backend->getTmpDir()
#2 /home/medicine/public_html/lib/Zend/Cache.php(153): Zend_Cache_Backend_File->__construct(Array)
#3 /home/medicine/public_html/lib/Zend/Cache.php(94): Zend_Cache::_makeBackend(’File’, Array, false, false)
#4 /home/medicine/public_html/lib/Zend/Locale/Data.php(314): Zend_Cache::factory(’Core’, ‘File’, Array, Array)
#5 /home/medicine/public_html/app/code/core/Mage/Core/Block/Html/Calendar.php(42): Zend_Locale_Data::getList(’ro_RO’, ‘days’)
#6 /home/medicine/public_html/app/code/core/Mage/Core/Block/Abstract.php(758): Mage_Core_Block_Html_Calendar->_toHtml()
#7 /home/medicine/public_html/app/code/core/Mage/Core/Block/Abstract.php(525): Mage_Core_Block_Abstract->toHtml()
#8 /home/medicine/public_html/app/code/core/Mage/Core/Block/Abstract.php(476): Mage_Core_Block_Abstract->_getChildHtml(’calendar’, true)
#9 /home/medicine/public_html/app/design/adminhtml/default/default/template/page/head.phtml(34): Mage_Core_Block_Abstract->getChildHtml(’calendar’)
#10 /home/medicine/public_html/app/code/core/Mage/Core/Block/Template.php(216): include(’/home/medicine/...’)
#11 /home/medicine/public_html/app/code/core/Mage/Core/Block/Template.php(247): Mage_Core_Block_Template->fetchView(’adminhtml/defau...’)
#12 /home/medicine/public_html/app/code/core/Mage/Core/Block/Template.php(261): Mage_Core_Block_Template->renderView()
#13 /home/medicine/public_html/app/code/core/Mage/Core/Block/Abstract.php(758): Mage_Core_Block_Template->_toHtml()
#14 /home/medicine/public_html/app/code/core/Mage/Core/Block/Abstract.php(525): Mage_Core_Block_Abstract->toHtml()
#15 /home/medicine/public_html/app/code/core/Mage/Core/Block/Abstract.php(476): Mage_Core_Block_Abstract->_getChildHtml(’head’, true)
#16 /home/medicine/public_html/app/design/adminhtml/default/default/template/page.phtml(43): Mage_Core_Block_Abstract->getChildHtml(’head’)
#17 /home/medicine/public_html/app/code/core/Mage/Core/Block/Template.php(216): include(’/home/medicine/...’)
#18 /home/medicine/public_html/app/code/core/Mage/Core/Block/Template.php(247): Mage_Core_Block_Template->fetchView(’adminhtml/defau...’)
#19 /home/medicine/public_html/app/code/core/Mage/Core/Block/Template.php(261): Mage_Core_Block_Template->renderView()
#20 /home/medicine/public_html/app/code/core/Mage/Adminhtml/Block/Template.php(81): Mage_Core_Block_Template->_toHtml()
#21 /home/medicine/public_html/app/code/core/Mage/Core/Block/Abstract.php(758): Mage_Adminhtml_Block_Template->_toHtml()
#22 /home/medicine/public_html/app/code/core/Mage/Core/Model/Layout.php(529): Mage_Core_Block_Abstract->toHtml()
#23 /home/medicine/public_html/app/code/core/Mage/Core/Controller/Varien/Action.php(389): Mage_Core_Model_Layout->getOutput()
#24 /home/medicine/public_html/app/code/core/Mage/Index/controllers/Adminhtml/ProcessController.php(55): Mage_Core_Controller_Varien_Action->renderLayout()
#25 /home/medicine/public_html/app/code/core/Mage/Core/Controller/Varien/Action.php(418): Mage_Index_Adminhtml_ProcessController->listAction()
#26 /home/medicine/public_html/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(253): Mage_Core_Controller_Varien_Action->dispatch(’list’)
#27 /home/medicine/public_html/app/code/core/Mage/Core/Controller/Varien/Front.php(176): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#28 /home/medicine/public_html/app/code/core/Mage/Core/Model/App.php(340): Mage_Core_Controller_Varien_Front->dispatch()
#29 /home/medicine/public_html/app/Mage.php(627): Mage_Core_Model_App->run(Array)
#30 /home/medicine/public_html/index.php(80): Mage::run(’’, ‘store’)
#31 {main}”;s:3:"url”;s:67:"/index.php/admin/process/list/key/7a6f95b71399256dd09c2f94950c6c16/”;s:11:"script_name”;s:10:"/index.php”;s:4:"skin”;s:5:"admin";}"

imi cer scuze pentru post-ul de mai multe caractere. astept un raspuns sau o solutie. multumesc anticipat.

 
Magento Community Magento Community
Magento Community
Magento Community
 
tzyganu
Mentor
 
Avatar
Total Posts:  2205
Joined:  2009-11-18
Bucharest, Romania
 

Salut Lucian.
Primul lucru pe care ar trebui sa il verifici e sa vezi daca exista directorul ‘var/cache’ in cadrul aplicatiei tale.
Daca nu exista creaza-l.
Daca exista asigura-te ca serverul are drepturi de scriere in el. (seteaza-l cu drepturi 777).

Posteaza aici rezultatul.

Marius.

 
Magento Community Magento Community
Magento Community
Magento Community
 
tzyganu
Mentor
 
Avatar
Total Posts:  2205
Joined:  2009-11-18
Bucharest, Romania
 

Daca nu obtii nici un rezultat din ce am scris mai sus asigura-te ca serverul (care e pe linux presupun) are un director ‘tmp’ in radacina si ca exista aceleasi drepturi de scriere in el.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Lucianmincu
Jr. Member
 
Total Posts:  3
Joined:  2011-04-06
 

Salut Marius.

Multumesc de ajutor dar din pacate e fara nici un efect.
Directorul ‘var/cache’ exista deja si avea dreptul de scriere (777) pentru ca si asta scria in tutorial sa fie setat si am facut.
Iar pentru directorul ‘tmp’ din radacina site-ului am setat tot (777) dar fara nici un efect.

multumesc inca odata si astept si alte solutii.

Lucian.

 
Magento Community Magento Community
Magento Community
Magento Community
 
tzyganu
Mentor
 
Avatar
Total Posts:  2205
Joined:  2009-11-18
Bucharest, Romania
 

Mi-a mai trecut ceva prin cap. (sper sa fie mai bine ca data trecuta)
Verifica in php.ini valoarea pentru ‘upload_tmp_dir’
Daca nu e setata sau e nula pune-i valoarea ‘/tmp’ si restarteaza serverul.

Daca nici asta nu merge o sa incetez sa mai scriu tampenii pe aici. smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
Lucianmincu
Jr. Member
 
Total Posts:  3
Joined:  2011-04-06
 

In radacina site-ului exista doar \\\’php.ini.sample\\\’ care are in continut asta :

\\\”; This file is for CGI/FastCGI installations.
; Try copying it to php5.ini, if it doesn\\\’t work

; adjust memory limit

memory_limit = 64M

max_execution_time = 18000

; disable magic quotes for php request vars

magic_quotes_gpc = off

; disable automatic session start
; before autoload was initialized

flag session.auto_start = off

; enable resulting html compression

zlib.output_compression = on

; disable user agent verification to not break multiple image upload

suhosin.session.cryptua = off

; turn off compatibility with PHP4 when dealing with objects

zend.ze1_compatibility_mode = off

; PHP for some reason ignores this setting in system php.ini
; and disables mcrypt if this line is missing in local php.ini

extension=mcrypt.so\\\”

asta ca si explicatie pentru ca nu gasesc comanda scrisa de tine. merci inca odata .

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top