Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Invalid config field backend model: adminhtml/system_config_backend_locale_timezone
 
sladegrove
Member
 
Avatar
Total Posts:  47
Joined:  2008-06-19
Phoenix, AZ
 

upgraded today from 1.5 RC1. Now when I click on System > Configuration get the following error:

Invalid config field backend model: adminhtml/system_config_backend_locale_timezone

Trace:
#0 /public_html/app/code/core/Mage/Adminhtml/Block/System/Config/Form.php(310): Mage::throwException(’Invalid config ...’)
#1 /public_html/app/code/core/Mage/Adminhtml/Block/System/Config/Form.php(204): Mage_Adminhtml_Block_System_Config_Form->initFields(Object(Varien_Data_Form_Element_Fieldset), Object(Mage_Core_Model_Config_Element), Object(Mage_Core_Model_Config_Element))
#2 /public_html/app/code/core/Mage/Adminhtml/Block/System/Config/Edit.php(92): Mage_Adminhtml_Block_System_Config_Form->initForm()
#3 /public_html/app/code/core/Mage/Adminhtml/controllers/System/ConfigController.php(77): Mage_Adminhtml_Block_System_Config_Edit->initForm()
#4 /public_html/app/code/core/Mage/Core/Controller/Varien/Action.php(420): Mage_Adminhtml_System_ConfigController->editAction()
#5 /public_html/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(253): Mage_Core_Controller_Varien_Action->dispatch(’edit’)
#6 /public_html/app/code/core/Mage/Core/Controller/Varien/Front.php(176): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#7 /public_html/app/code/core/Mage/Core/Model/App.php(340): Mage_Core_Controller_Varien_Front->dispatch()
#8 /public_html/app/Mage.php(627): Mage_Core_Model_App->run(Array)
#9 /public_html/index.php(80): Mage::run(’’, ‘store’)
#10 {main}

Any clues?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ben Marks
Guru
 
Avatar
Total Posts:  452
Joined:  2008-10-09
Charleston, SC
 

Seems like a file is missing.  That message means that a backend class has been specified but a corresponding file / class definition was not found.

That reference will likely be found in eav_attribute table for some attribute.

Find the file here; add the Locale directory and this file and you should be ok:

http://svn.magentocommerce.com/source/branches/1.5-trunk/app/code/core/Mage/Adminhtml/Model/System/Config/Backend/Locale/Timezone.php

HTH
Ben

 
Magento Community Magento Community
Magento Community
Magento Community
 
sladegrove
Member
 
Avatar
Total Posts:  47
Joined:  2008-06-19
Phoenix, AZ
 

There was an existing timezone file, however, downloaded the SVN version and placed the existing file and it’s working now.

Thank you…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Gavrisimo
Jr. Member
 
Total Posts:  2
Joined:  2010-10-19
 
blueben - 24 April 2011 03:24 AM

Seems like a file is missing.  That message means that a backend class has been specified but a corresponding file / class definition was not found.

That reference will likely be found in eav_attribute table for some attribute.

Find the file here; add the Locale directory and this file and you should be ok:

http://svn.magentocommerce.com/source/branches/1.5-trunk/app/code/core/Mage/Adminhtml/Model/System/Config/Backend/Locale/Timezone.php

HTH
Ben

Hey Ben, what if i upgraded from 1.5.0.1 to 1.5.1.0 and have that file:

app/code/core/Mage/Adminhtml/Model/System/Config/Backend/Locale/Timezone.php

The content of it is the same as in that svn.

Here is the error file im getting:

a:5:{i:0;s:83:"Invalid config field backend model: adminhtml/system_config_backend_locale_timezone";i:1;s:1420:"#0 /home/petshoponline/public_html/includes/src/Mage_Adminhtml_Block_System_Config_Form.php(310): Mage::throwException(’Invalid config ...’)
#1 /home/petshoponline/public_html/includes/src/Mage_Adminhtml_Block_System_Config_Form.php(204): Mage_Adminhtml_Block_System_Config_Form->initFields(Object(Varien_Data_Form_Element_Fieldset), Object(Mage_Core_Model_Config_Element), Object(Mage_Core_Model_Config_Element))
#2 /home/petshoponline/public_html/includes/src/Mage_Adminhtml_Block_System_Config_Edit.php(92): Mage_Adminhtml_Block_System_Config_Form->initForm()
#3 /home/petshoponline/public_html/app/code/core/Mage/Adminhtml/controllers/System/ConfigController.php(101): Mage_Adminhtml_Block_System_Config_Edit->initForm()
#4 /home/petshoponline/public_html/includes/src/__default.php(12252): Mage_Adminhtml_System_ConfigController->editAction()
#5 /home/petshoponline/public_html/includes/src/__default.php(16395): Mage_Core_Controller_Varien_Action->dispatch(’edit’)
#6 /home/petshoponline/public_html/includes/src/__default.php(15992): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#7 /home/petshoponline/public_html/includes/src/__default.php(18324): Mage_Core_Controller_Varien_Front->dispatch()
#8 /home/petshoponline/public_html/app/Mage.php(627): Mage_Core_Model_App->run(Array)
#9 /home/petshoponline/public_html/index.php(80): Mage::run(’’, ‘store’)
#10 {main}”;s:3:"url”;s:74:"/index.php/admin/system_config/index/key/f732c0b637130f28d78957d37e564998/”;s:11:"script_name”;s:10:"/index.php”;s:4:"skin”;s:5:"admin";}

 
Magento Community Magento Community
Magento Community
Magento Community
 
supergper
Member
 
Total Posts:  34
Joined:  2009-03-15
 

I’m having the exact same problem as GaVrA.  I upgraded and now can’t get in to my backend configuration or, as a customer, update my profile.

Also, I did a diff and got the md5um of my current file and the SVN file and they are the exact same.

 
Magento Community Magento Community
Magento Community
Magento Community
 
supergper
Member
 
Total Posts:  34
Joined:  2009-03-15
 

Well, I went into Magento Connect and Re-installed every single one of my packages.  Everything installed fine and now everything appears to be working. :D Must have been a corrupt file on the 1.5.0 -> 1.5.1 upgrade (which file, I have no clue).

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ben Marks
Guru
 
Avatar
Total Posts:  452
Joined:  2008-10-09
Charleston, SC
 

@GaVrA

That file of yours contains the class Mage_Adminhtml_Model_System_Config_Backend_Locale_Timezone ?  Try this in a file in your Magento root:

<?php

    
require_once('app/Mage.php');
    
Mage::app();

    
$test Mage::getModel('adminhtml/system_config_backend_locale_timezone');
    
var_dump(get_class($test));

You should see this when you hit that file from your browser:

string 'Mage_Adminhtml_Model_System_Config_Backend_Locale_Timezone' (length=58)

LMK
Ben

 
Magento Community Magento Community
Magento Community
Magento Community
 
Gavrisimo
Jr. Member
 
Total Posts:  2
Joined:  2010-10-19
 
blueben - 28 April 2011 05:17 AM

@GaVrA

That file of yours contains the class Mage_Adminhtml_Model_System_Config_Backend_Locale_Timezone ?  Try this in a file in your Magento root:

<?php

    
require_once('app/Mage.php');
    
Mage::app();

    
$test Mage::getModel('adminhtml/system_config_backend_locale_timezone');
    
var_dump(get_class($test));

You should see this when you hit that file from your browser:
string 'Mage_Adminhtml_Model_System_Config_Backend_Locale_Timezone' (length=58)

LMK
Ben

Hey Ben, thanks for reply. We got this sorted after we figured out that php was timing out, since we had 60 sec max execution time, and once we saw that we increased it to 2min. After that we ran reinstall of every module/extension(whatever it is called) in magento connect and after that everything worked… smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ben Marks
Guru
 
Avatar
Total Posts:  452
Joined:  2008-10-09
Charleston, SC
 

Ah lovely, glad to hear you got things running!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top