Magento Forum

   
Why is my Magento so slow? Any suggestions? 
 
benfrain.com
Sr. Member
 
Total Posts:  142
Joined:  2008-08-15
 

Hello,

I’m building up a site

However, it runs incredibly slowly. My question is, why?

Does anyone know what might be causing this problem?

Thanks in advance…

 
Magento Community Magento Community
Magento Community
Magento Community
 
JenniferAslan
Jr. Member
 
Avatar
Total Posts:  20
Joined:  2008-08-20
Pacific Northwest
 

What kind of server are you hosting the site on? We found that the speed of the server was the biggest factor in the speed at which the site functions. We originally had it installed on an Apple Xserve with a single G5 processor, and the bigger our database became, the slower the site ran. We moved it to a new Apple Xserve with two 2.8 GHz Quad-Core Intel Xeon processors and now it screams. You should consider moving your site to the fastest server you can find.

 
Magento Community Magento Community
Magento Community
Magento Community
 
psylvia
Jr. Member
 
Total Posts:  6
Joined:  2008-11-07
Orlando, Florida - USA
 

I am starting to believe this is an Internet Explorer issue and not necessarily Magento.  The frontend runs at a tolerable speed considering that its on a shared server however the admin section was painfully slow.  I opened up the admin in Firefox on a Windows platform and it works great now.  Just an observation.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Yudi
Member
 
Total Posts:  51
Joined:  2008-02-10
 

Check out my thread:
Does Magento ‘clog’ up bandwidth on servers?
I believe the best answer in the thread is this: http://www.magentocommerce.com/blog/comments/performance-is-key-notes-on-magentos-performance/
Keep me posted!

 
Magento Community Magento Community
Magento Community
Magento Community
 
benfrain.com
Sr. Member
 
Total Posts:  142
Joined:  2008-08-15
 
psylvia - 09 November 2008 08:00 AM

I am starting to believe this is an Internet Explorer issue and not necessarily Magento.  The frontend runs at a tolerable speed considering that its on a shared server however the admin section was painfully slow.  I opened up the admin in Firefox on a Windows platform and it works great now.  Just an observation.

Hi there, I have been testing it on Firefox primarily (front and back end) and find it terrible on both.

Is it my Admin you have been into? If so, how! ??

 
Magento Community Magento Community
Magento Community
Magento Community
 
akayani
Jr. Member
 
Total Posts:  3
Joined:  2008-10-28
 

I’m running Magento locally on XAMPP.

You would think that would be fast… NO it’s taking 15secs average per page refresh. It was taking 30 but I turned Xdebug off and followed all the optimisations I could find.

I was going to use this for Point of Sale and run a copy on a local server. At 15 seconds per page refresh that is like 5 minute to write an invoice.

My conclusion is that the Admin interface needs much more AJAX. Surely you can expect the person doing Admin to have JS turned on.

I would have thought that 2 seconds for a page refresh on a local server should be what I’m seeing not 15+.

Yani

 
Magento Community Magento Community
Magento Community
Magento Community
 
davidgrun
Sr. Member
 
Total Posts:  244
Joined:  2008-07-10
 

I have a Magento Optimized account with Hhhost http://helpinghandhost.com/optimized.php for $12.95 a month.  The speed went up like crazy since I moved from Media Temple (and I’m paying $7 less per month ).
Than, you turn your Magento Cache on (Configuration > Cache Management) and you are set with a decently fast shop.

Hope it helps wink

 
Magento Community Magento Community
Magento Community
Magento Community
 
timp
Jr. Member
 
Total Posts:  12
Joined:  2009-02-22
 

I am running Magento ver 1.2.1.2 localy on a windows Xp Sp3, Apache 2.2.11, PHP 5.2.9, MYSQL 5.1.0.22, the admin is very slow when I view Categories (sample data from magento), also when I create a categorie, it is very slow, the wheel just keeps spinning, the CPU runs at 100% with iexplorer.exe as the running process.

Has anyone got a fix or is it a bug and the Magento developers are aware of this?

 
Magento Community Magento Community
Magento Community
Magento Community
 
roblesrt
Jr. Member
 
Total Posts:  19
Joined:  2009-05-07
 

any updates? i have the same issue on IE6

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top