Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
Problem with uploading pictures…
 
chillbert
Jr. Member
 
Total Posts:  1
Joined:  2008-11-05
 

Hi guys,

I have some trouble with uploading my pictures of the items I want to sell.

When I press the “Browse Files” or “Upload Files” button, nothing happens.
I have the latest version of Adobe Flash Player and i tried it with Firefox, Internet Explorer and Safari and still nothing is popping up.

I hope you can help me.

Greets
chillbert

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

Have you tried adding the following lines into your php.ini file?

magic_quotes_gpc = off
short_open_tag = on
extension=pdo.so
extension=pdo_mysql.so

Also, what is your flash player’s version?

 
Magento Community Magento Community
Magento Community
Magento Community
 
tomlam
Jr. Member
 
Total Posts:  7
Joined:  2008-10-27
 

I’m having exactly the same problem. Fresh installation, added a few extensions such as the WYSIWYG add on.
This is my first installation so i dont know if this is a regular problem or not.

When I click on the “browse” button “upload” button while editing a product’s images, nothing happens. I’ve tried quite a lot of stuff…
I even tried adding those lines to my PHP.INF file, but to be honest i wasn’t sure what i was doing there… could have done it wrong.

here is a copy of my PHP.INF.

; This file is for CGI/FastCGI installations.
; Try copying it to php5.ini, if it doesn’t work

; adjust memory limit

memory_limit = 64M

max_execution_time = 18000

; disable magic quotes for php request vars

magic_quotes_gpc = off

; disable automatic session start
; before autoload was initialized

flag session.auto_start = off

; enable resulting html compression

zlib.output_compression = on

; disable user agent verification to not break multiple image upload

suhosin.session.cryptua = off

; turn off compatibility with PHP4 when dealing with objects

zend.ze1_compatibility_mode = off

; PHP for some reason ignores this setting in system php.ini
; and disables mcrypt if this line is missing in local php.ini

extension=mcrypt.so

magic_quotes_gpc = off
short_open_tag = on
extension=pdo.so
extension=pdo_mysql.so

THANKS for your help!

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 
tomlam - 05 November 2008 07:36 AM

I’m having exactly the same problem. Fresh installation, added a few extensions such as the WYSIWYG add on.
This is my first installation so i dont know if this is a regular problem or not.


When I click on the “browse” button “upload” button while editing a product’s images, nothing happens. I’ve tried quite a lot of stuff…
I even tried adding those lines to my PHP.INF file, but to be honest i wasn’t sure what i was doing there… could have done it wrong.

here is a copy of my PHP.INF.


; This file is for CGI/FastCGI installations.
; Try copying it to php5.ini, if it doesn’t work

; adjust memory limit

memory_limit = 64M

max_execution_time = 18000

; disable magic quotes for php request vars

magic_quotes_gpc = off

; disable automatic session start
; before autoload was initialized

flag session.auto_start = off

; enable resulting html compression

zlib.output_compression = on

; disable user agent verification to not break multiple image upload

suhosin.session.cryptua = off

; turn off compatibility with PHP4 when dealing with objects

zend.ze1_compatibility_mode = off

; PHP for some reason ignores this setting in system php.ini
; and disables mcrypt if this line is missing in local php.ini

extension=mcrypt.so


magic_quotes_gpc = off
short_open_tag = on
extension=pdo.so
extension=pdo_mysql.so

THANKS for your help!

Actually it is php.ini, not .inf.
By the way, what is your flash player’s version?

 
Magento Community Magento Community
Magento Community
Magento Community
 
tomlam
Jr. Member
 
Total Posts:  7
Joined:  2008-10-27
 

Sorry, PHP.INI.

My flash version is 10.0

I’ve tried this in internet explorer and its the same, but at the bottom left corner it says “Error on page” and then “done”

baffling.

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

You will need to downgrade your flash player to version 9 for this to work.

 
Magento Community Magento Community
Magento Community
Magento Community
 
tomlam
Jr. Member
 
Total Posts:  7
Joined:  2008-10-27
 

I only just upgraded it because it would not work on myspace.
how would I go about downgrading?

your help is much appreciated

tom

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

You will need to uninstall version 10 and install version 9 from their website.

 
Magento Community Magento Community
Magento Community
Magento Community
 
gwarriner
Jr. Member
 
Avatar
Total Posts:  2
Joined:  2008-11-03
 

Rolling back my Flash player to a previous version resolved the issue for me as well.  I found this link in another thread with the same topic (don’t recall which thread though):

http://kb.adobe.com/selfservice/viewContent.do?externalId=tn_14266

Thank you to everyone that replied in this and other threads!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Commanderbob
Member
 
Total Posts:  61
Joined:  2008-10-19
 

I have the same problem but I want to keep flash 10 because it is a lot faster on my computer. I read this was a change for a security issue where the browse dialog can only be opened with a direct click. I don’t know anything about flash but I really need this to work. I won’t be able to use Magento without it. At least can someone point me in the right direction, where is the file that has the code for the image uploading? I want to take a look at it, maybe I could come up with a solution.

Thanks,
Justin

 
Magento Community Magento Community
Magento Community
Magento Community
 
tomlam
Jr. Member
 
Total Posts:  7
Joined:  2008-10-27
 

This is a huge problem for me. I have uninstalled flash, the reinstalled flash version 9 and its now telling me that i need the latest version of flash in order to operate it.
But in any case… some websites require version 10, so why is the image uploader made in this way?

Is there something that I’m doing wrong here? Has anyone else got a version of flash working with myspace and with magento?

cheers for your help
tom

 
Magento Community Magento Community
Magento Community
Magento Community
 
Commanderbob
Member
 
Total Posts:  61
Joined:  2008-10-19
 

I am actually surprised more people have not complained yet as most people will have flash 10. How hard of a fix could this be?
Please help! This is a huge set back.

Thanks a lot,
Justin

 
Magento Community Magento Community
Magento Community
Magento Community
 
Seba G Gonnelli
Guru
 
Total Posts:  336
Joined:  2007-09-15
 

@Justin: Magento’s 1.1.7 release will be compatible with Flash 10

 
Magento Community Magento Community
Magento Community
Magento Community
 
Commanderbob
Member
 
Total Posts:  61
Joined:  2008-10-19
 

How long till 1.1.7 is out? I modified the blue theme quite a bit. Will that still be compatible with 1.1.7? I only changed the images and CSS.

Glad to here that there will be a fix soon!
Thanks,
Justin

 
Magento Community Magento Community
Magento Community
Magento Community
 
Seba G Gonnelli
Guru
 
Total Posts:  336
Joined:  2007-09-15
 

Magento v 1.1.7 will be released during this month, I wouldn’t be sure if your modifications are going to be fully compatible unless you have followed the Design Guide, in that case you should be ok smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
jackied
Member
 
Total Posts:  31
Joined:  2008-07-02
 

It doesn’t appear to be released yet. Still have a problem!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2