Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

http 500 error with default .htaccess
 
The other Jason
Jr. Member
 
Total Posts:  3
Joined:  2008-10-20
 

Hello - I am having an http 500 error once the files are uploaded - I can’t start install or anything - then when I remove the .htaccess I can run just fine.  I am hoping that someone might have a solid solution - but from what i’ve seen there are lots of tricks that work for some and not for others.  I have tried permissions, etc. and now have a fresh installation.

I pass the requirements test for Magento.  I currently have the latest full version installed.  Right now I am running with no .htaccess and that is ‘ok’, but when I try to go to the ConnectManager I get additional errors - I don’t know if that is related to the .htaccess - one problem at a time.

I’m in a shared hosting environment. and you can see the PHPINFO here: http://www.lonestarvinyl.com/magento-check.php

Thank you,
Jason

Here is my .htaccess:

<code>
############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi

# Action php5-cgi /cgi-bin/php5-cgi
# AddHandler php5-cgi .php

############################################
## GoDaddy specific options

# Options -MultiViews

## you might also need to add this line to php.ini
## cgi.fix_pathinfo = 1
## if it still doesn’t work, rename php.ini to php5.ini

############################################
## this line is specific for 1and1 hosting

#AddType x-mapp-php5 .php
#AddHandler x-mapp-php5 .php

############################################
## default index file

DirectoryIndex index.php

<IfModule mod_php5.c>

############################################
## adjust memory limit

# php_value memory_limit 64M
php_value memory_limit 128M
php_value max_execution_time 18000

############################################
## disable magic quotes for php request vars

php_flag magic_quotes_gpc off

############################################
## disable automatic session start
## before autoload was initialized

php_flag session.auto_start off

############################################
## enable resulting html compression

#php_flag zlib.output_compression on

###########################################
# disable user agent verification to not break multiple image upload

php_flag suhosin.session.cryptua off

###########################################
# turn off compatibility with PHP4 when dealing with objects

php_flag zend.ze1_compatibility_mode Off

</IfModule>

<IfModule mod_security.c>
###########################################
# disable POST processing to not break multiple image upload

SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

<IfModule mod_deflate.c>

############################################
## enable apache served files compression
## http://developer.yahoo.com/performance/rules.html#gzip

# Insert filter
#SetOutputFilter DEFLATE

# Netscape 4.x has some problems…
#BrowserMatch ^Mozilla/4 gzip-only-text/html

# Netscape 4.06-4.08 have some more problems
#BrowserMatch ^Mozilla/4\.0[678] no-gzip

# MSIE masquerades as Netscape, but it is fine
#BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
# Don’t compress images
#SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary

# Make sure proxies don’t deliver the wrong content
#Header append Vary User-Agent env=!dont-vary

</IfModule>

<IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

SSLOptions StdEnvVars

</IfModule>

<IfModule mod_rewrite.c>

############################################
## enable rewrites

Options +FollowSymLinks
RewriteEngine off

############################################
## you can put here your magento root folder
## path relative to web root

#RewriteBase /magento/

############################################
## workaround for HTTP authorization
## in CGI environment

RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## always send 404 on missing files in these folders

RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

RewriteRule .* index.php [L]

</IfModule>

############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead

AddDefaultCharset Off
#AddDefaultCharset UTF-8

<IfModule mod_expires.c>

############################################
## Add default Expires header
## http://developer.yahoo.com/performance/rules.html#expires

ExpiresDefault “access plus 1 year”

</IfModule>

############################################
## By default allow all access

Order allow,deny
Allow from all

############################################
## If running in cluster environment, uncomment this
## http://developer.yahoo.com/performance/rules.html#etags

#FileETag none
</code

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

Do you have URL rewrites configured? What is your files and folders permission for Magento?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sindre|ProperHost
Mentor
 
Avatar
Total Posts:  1158
Joined:  2008-04-24
 

Try commenting the following line, like this:

# Options +FollowSymLinks

The Options directive is often disabled on shared hosts.

If that does not help, go through each and every line and comment them to see where the problem occurs.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ynet.hk
Jr. Member
 
Total Posts:  1
Joined:  2008-11-04
 

I do have the same problem, after installed Magento 1.1.6 on Linux ISP Config Server.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sindre|ProperHost
Mentor
 
Avatar
Total Posts:  1158
Joined:  2008-04-24
 

ynet.hk: have you tried to comment out the lines in the .htaccess as described above? This would rule out whether the .htaccess is the problem. It could also be a file permission issue. If you are running suPHP, make sure no files/folders have world-writable permissions (chmod 777). Set your permissions to chmod 644 for files and 755 for directories.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Commanderbob
Member
 
Total Posts:  61
Joined:  2008-10-19
 

Same problem on 1.1.7. If I delete .htaccess it works. Any reason I should not just keep it deleted?

Commenting out that line does nothing.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top