Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

How to apply the blank theme? 
 
n20capri
Member
 
Total Posts:  44
Joined:  2008-11-01
Bensalem PA
 

How do I apply the blank theme to the entire website?

I can change a specific product category or a CMS page but with MANY categories and pages this will take too much time.  How do I globally do this? 

I followed the steps here but it doesn’t work…
http://www.magentocommerce.com/design_guide/articles/working-with-magento-themes

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
n20capri
Member
 
Total Posts:  44
Joined:  2008-11-01
Bensalem PA
 

Also installed BLUE and can’t get that to work either.

 
Magento Community Magento Community
Magento Community
Magento Community
 
retif
Sr. Member
 
Total Posts:  171
Joined:  2008-08-16
Odessa, Ukraine
 

what do you mean doesn`t work? how exactly? i am just downloaded blank theme from magento connect then delete default theme and skin and renamed blank to default and its works nice

 
Magento Community Magento Community
Magento Community
Magento Community
 
Voot
Sr. Member
 
Total Posts:  261
Joined:  2008-03-20
Long Beach, CA
 

Hi Guys,

Deleting the default theme is not the ideal solution. The recommended way to do this is to go to Admin > System > Configuration > Design and type in “blank” to the following fields: Templates, Skin, Layout and Default. If you want to activate the Blue theme then type in “blue” instead of “blank”.

Also, make sure to disable Cache Management (really important).

 
Magento Community Magento Community
Magento Community
Magento Community
 
n20capri
Member
 
Total Posts:  44
Joined:  2008-11-01
Bensalem PA
 

I can rename blue to default and it works too but that’s not the “correct” way.

I followed the instructions in the tutorial and it just doesn’t change the theme.  Cache is disabled and blue is set in all those fields.  I don’t know what else to try…

Image Attachments
blue.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
jodaki
Jr. Member
 
Total Posts:  5
Joined:  2008-11-19
 

n20capri: I have exactly the same problem. I’ve followed the instructions carefully and created a new theme (called ‘millionprisoners’) based on ‘blank’.

Vutha’s method (which is the same as that in the documentation, ie. using system->configuration->design) simply does not work. ONLY way to get my new theme to show is top rename it to ‘blank’.

Now what’s all this about then? Someone surely must know what’s going on. Goddam frustrating…

 
Magento Community Magento Community
Magento Community
Magento Community
 
jodaki
Jr. Member
 
Total Posts:  5
Joined:  2008-11-19
 

n20capri, the following procedure worked for me:

Go to CMS->’Manage Pages’

Click ‘Homepage’

Click ‘Custom Design’ on the left hand nav.

Have you got a theme, such as ‘blank’ listed in the ‘Custom Theme’ dropdown?

If so reset it back by choosing ‘Please Select’. If you haven’t got a Custom Theme selected then this solution won’t help you. If you have then it will.

Save changes.

Now go to System->Configuration->Design,

choose ‘Default Config’ in the ‘Current Configuration Scope’ drop down and write the name of your custom theme in the Templates, Skin, Layout and Default textfields.

Save changes, then change Current Configuration Scope to your website. Check the ‘Use Default’ checkboxes, then save changes,

change the Current Configuration Scope again, this time to your Store View. Check the ‘Use Website’ checkboxes, then save changes,

Reload your homepage.

Hopefully, your custom theme should appear.
Good luck.

 
Magento Community Magento Community
Magento Community
Magento Community
 
sokui
Jr. Member
 
Total Posts:  27
Joined:  2008-12-04
 

But it seems not to work either. The home page is applied by the new theme. But if we click the product, the new page is still under the old theme.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Voot
Sr. Member
 
Total Posts:  261
Joined:  2008-03-20
Long Beach, CA
 

Do you guys have multiple stores? That could be the problem. Also, I found out that the “blue” theme is just a skin, no layout changes were made which means you dont have to have a “blue” folder in the app folder. The only folder that exists for the blue theme is in the skin folder. So when applying the blue theme type in “blue” in the Skin (CSS and Images) field only. This field is located in Admin > Configuration > Design > Themes. If you guys want to PM me a temporary login for Admin, I’ll be happy to check it out.

 
Magento Community Magento Community
Magento Community
Magento Community
 
kami
Jr. Member
 
Total Posts:  3
Joined:  2008-12-25
 

I have the same problem, why does magento doesn’t support theme with preview like wordpress?

 
Magento Community Magento Community
Magento Community
Magento Community
 
sixK
Jr. Member
 
Avatar
Total Posts:  16
Joined:  2009-01-06
 

I’ve run into the same problem as the others. I installed the Blank theme through MC no problems, it shows in FTP, but when I went to change the Default value to ‘blank’ in admin, it doesn’t show up. I also filled out the other fields under ‘Themes’ and disabled the Cache Management. No beans. So I changed the name from ‘blank’ to ‘default’ and it works now.  Not sure if it’s this way with other themes (haven’t tried others), but this is what I had to do to get this one working. Not pretty, but no other choice really.

 
Magento Community Magento Community
Magento Community
Magento Community
 
TheCodePirate
Jr. Member
 
Total Posts:  3
Joined:  2009-01-06
 

Yeah, the theme system is kinda broken.  Default theme or non-default theme, only default will load on my box.  Hell if I can figure out why.

It works for development, but this is a major feature that’s pretty much crippled for me at the moment.

 
Magento Community Magento Community
Magento Community
Magento Community
 
MindMagnet
Jr. Member
 
Avatar
Total Posts:  13
Joined:  2009-02-02
Cluj-Napoca
 

I had the same problem and it turned out toat for some reason the “modern” and “blue” layouts/skins were not uploaded to the FTP server. I’m not sure how this happened, but you should make sure your files are correctly uploaded and named.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial
Enthusiast
 
Avatar
Total Posts:  770
Joined:  2007-11-07
Phoenix, AZ
 

@donarana:

Actually, the Current package name should be left as default, as that’s the name of the interface. For the Themes section, you only need to put blank for the Default field.

app/design/frontend/<interface>/<theme>
skin/frontend/<interface>/<theme>
 
Magento Community Magento Community
Magento Community
Magento Community
 
loeffel
Guru
 
Avatar
Total Posts:  427
Joined:  2009-02-03
 

donorana, if you are getting a structure like this: blank - default, that means that your folder structure will look like this: blank/default/blablabla.
You want to go for something like blank/blank/blablabla
I dont know if this helps

Has anyony tried copying the entire default folder to your blank folder and afterwards copying the files from the blank theme, overriding any duplicate file?
Also, if there is a skin\frontend\default\blue folder, maybe to be able to apply the blue theme, you will also need the blue folder in app\design\frontend\default?

I know that magento only needs files that are actually changed to be in your custom theme folder (meaning that it will load any default file unless you have one in your custom folder with same name and folder structure, nomatter what you entered in designs in the backend) but we all now thats its buggy sometimes.

Just thinking out loud..

 
Magento Community Magento Community
Magento Community
Magento Community
 
adamhw
Member
 
Total Posts:  51
Joined:  2009-12-22
 

You’ve probably found the solution by now but I’ve just worked it out - I uploaded the blank theme and was trying to figure out how to apply the theme to all pages

The way I did it was go into System - Design and then Edit the Design change there - that worked....

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top