Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Upgrade from Magento 1.3.2.3 to Magento 1.5.0.1 FAIL (upgrade using Magento Connect)
 
gari marcos
Jr. Member
 
Avatar
Total Posts:  21
Joined:  2008-10-24
 

Hello there.
I was running an upgrade from Magento Connect from Magento 1.3.2.3 to Magento 1.5.0.1 and I´ve got an error… Im stack and cant work on the store right now. Any help is more than welcmoe.
This is the whole code:

Checking dependencies of packages
Already installed
community/Interface_Install_Default 1.5.0.0skipping
Already installed
community/Mage_Downloader 1.5.0.0skipping
Already installed
community/Mage_Centinel 1.5.0.0skipping
Already installed
community/Interface_Frontend_Base_Default 1.5.0.0skipping
Already installed
community/Phoenix_Moneybookers 1.2.4skipping
Already installed
community/Find_Feed 1.0.8skipping
Already installed
community/Magento_Mobile 1.5.0.0.16skipping
Already installed
community/Lib_LinLibertineFont 2.8.14.0skipping
Already installed
community/Lib_Js_TinyMCE 3.3.7.0skipping
Already installed
community/Lib_Phpseclib 1.5.0.0skipping
Already installed
community/Mage_Locale_en_US 1.5.0.0skipping
Already installed
community/Lib_Mage 1.5.0.0skipping

CONNECT ERROR
Package â€˜Mage_All_Latest’ is invalid
‘
./pkginfo/Mage_All_Latest.txt’ already exists
Package â€˜Interface_Adminhtml_Default’ is invalid
‘
./app/design/adminhtml/default/default/layout/admin.xml’ already exists
Package â€˜Interface_Frontend_Default’ is invalid
‘
./app/design/frontend/default/default/locale/en_US/translate.csv’ already exists
Package â€˜Mage_Compiler’ is invalid
‘
./includes/config.php’ already exists
Package â€˜Mage_Core_Adminhtml’ is invalid
‘
./app/code/core/Mage/Adminhtml/Block/Abstract.php’ already exists
Package â€˜Mage_Core_Modules’ is invalid
‘
./app/code/core/Mage/Admin/Model/Acl/Assert/Ip.php’ already exists
Package â€˜Lib_Js_Ext’ is invalid
‘
./js/extjs/css/README.txt’ already exists
Package â€˜Lib_Varien’ is invalid
‘
./lib/Varien/Autoload.php’ already exists
Package â€˜Lib_Google_Checkout’ is invalid
‘
./lib/googlecheckout/googlecart.php’ already exists
Package â€˜Lib_Js_Calendar’ is invalid
‘
./js/calendar/calendar-blue.css’ already exists
Package â€˜Lib_Js_Mage’ is invalid
‘
./js/lib/boxover.js’ already exists
Package â€˜Lib_ZF’ is invalid
‘
./lib/Zend/Acl/Assert/Interface.php’ already exists
Package â€˜Lib_Js_Prototype’ is invalid
‘
./js/prototype/debug.js’ already exists
Package â€˜Lib_ZF_Locale’ is invalid
‘
./lib/Zend/Locale/Data/Translation.php’ already exists

Fatal error
Call to undefined method Mage_Core_Model_Resource_Setup::applyalldataupdates() in /Applications/XAMPP/xamppfiles/htdocs/magento_update/downloader/Maged/Controller.php on line 897
 
Magento Community Magento Community
Magento Community
Magento Community
 
gari marcos
Jr. Member
 
Avatar
Total Posts:  21
Joined:  2008-10-24
 

When trying to do the same throught Magento Connect on an online “test” folder I get this:

pear/Console_Getopt requires PEAR Installer (version >= 1.9.1), installed version is 1.7.1
pear
/PEAR requires package "pear/Console_Getopt" (recommended version 1.2.3)
magento-core/Mage_Pear_Helpers requires package "pear/PEAR" (version >= 1.6.2)
magento-core/Lib_Google_Checkout requires package "magento-core/Mage_Pear_Helpers" (version >= 1.0.18800)
magento-core/Mage_Core_Modules requires package "magento-core/Lib_Google_Checkout" (version >= 1.4.2.0version <= 1.4.3excluded versions1.4.3)
magento-core/Mage_All_Latest requires package "magento-core/Mage_Core_Modules" (version >= 1.4.2.0version <= 1.4.2.0)
magento-core/Mage_Core_Adminhtml requires package "magento-core/Mage_Core_Modules" (version >= 1.4.2.0version <= 1.4.2.0)
magento-core/Interface_Adminhtml_Default requires package "magento-core/Mage_Core_Adminhtml" (version >= 1.4.2.0version <= 1.4.3.0excluded versions1.4.3.0)
magento-core/Interface_Frontend_Default requires package "magento-core/Mage_Core_Modules" (version >= 1.4.2.0version <= 1.4.3excluded versions1.4.3)
magento-core/Interface_Install_Default requires package "magento-core/Mage_Core_Modules" (version >= 1.4.2.0version <= 1.4.3excluded versions1.4.3)
magento-core/Mage_Centinel requires package "magento-core/Mage_Core_Modules" (version >= 1.4.2.0version <= 1.4.3excluded versions1.4.3)
magento-core/Interface_Frontend_Base_Default requires package "magento-core/Mage_Core_Modules" (version >= 1.4.2.0version <= 1.4.3excluded versions1.4.3)
magento-core/Phoenix_Moneybookers requires package "magento-core/Mage_Core_Modules" (version >= 1.4.2.0version <= 1.4.3excluded versions1.4.3)
magento-core/Find_Feed requires package "magento-core/Mage_Core_Modules" (version >= 1.4.2.0version <= 1.4.3)
magento-core/Lib_Js_Calendar requires package "magento-core/Mage_Pear_Helpers" (version >= 1.0.18800)
magento-core/Lib_Js_Prototype requires package "magento-core/Mage_Pear_Helpers" (version >= 1.0.18800)
magento-core/Lib_Js_Mage requires package "magento-core/Lib_Js_Prototype" (version >= 1.6.0.3.3version <= 1.6.1excluded versions1.6.1)
magento-core/Lib_Js_Ext requires package "magento-core/Mage_Pear_Helpers" (version >= 1.0.18800version <= 1.0.18800)
magento-core/Lib_Js_TinyMCE requires package "magento-core/Mage_Pear_Helpers" (version >= 1.0.18800)
magento-core/Lib_ZF requires package "magento-core/Mage_Pear_Helpers" (version >= 1.0.18800)
magento-core/Lib_Varien requires package "magento-core/Lib_ZF" (version >= 1.10.8.0version <= 1.10.9.0excluded versions1.10.9.0)
magento-core/Lib_ZF_Locale requires package "magento-core/Mage_Pear_Helpers" (version >= 1.0.18800)
Install Errors
No valid packages found
PEAR ERROR
install failed

Im totally lost… isnt supposed to be “stable”...?

 
Magento Community Magento Community
Magento Community
Magento Community
 
krlkv
Member
 
Total Posts:  42
Joined:  2008-11-09
 

Don\’t use connect or pear to upgrade.  Especially major upgrades.  They are known to result in issues like this.

Restore 1.3.2.3 and follow this link to do the upgrade: http://www.webshopapps.com/blog/2010/08/upgrading-your-magento-site-without-downtime/

 
Magento Community Magento Community
Magento Community
Magento Community
 
gari marcos
Jr. Member
 
Avatar
Total Posts:  21
Joined:  2008-10-24
 
krlkv - 19 February 2011 06:54 AM

Don\’t use connect or pear to upgrade.  Especially major upgrades.  They are known to result in issues like this.

Restore 1.3.2.3 and follow this link to do the upgrade: http://www.webshopapps.com/blog/2010/08/upgrading-your-magento-site-without-downtime/

This is what I was trying to do and how I got the second “issue” (the first was trying to upgrade on localhost.
And by the way… following the link I only find a guide of “how to “copy/paste” your magento to a /test folder online"… as It does not say any word about upgrading… am I right?

Best,
G.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top