Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Price* field in Catalog > Manage Products > Prices gone
 
wiseacredesign
Jr. Member
 
Avatar
Total Posts:  7
Joined:  2008-04-17
Cincinnati, OH
 

I recently updated a Magento store from 1.0 to 1.1.6. Everything appeared to be working ok except now in the Admin area in Catalog > Manage Products > _Product_ > Prices—the “Price*” is gone? The prices from the old store are still there, but the the editable field is gone.

I’ve even re-uploaded the files from 1.1.6 into app > design > adminhtml > default > default > template > catalog > product ... and still no change.

Its also missing when trying to add a product. Is this an know issue?

 
Magento Community Magento Community
Magento Community
Magento Community
 
wiseacredesign
Jr. Member
 
Avatar
Total Posts:  7
Joined:  2008-04-17
Cincinnati, OH
 

Please, I’ve looked EVERYWHERE for why or how this is happening. The site is running all the most “Stable” versions of updates. I think I’ve narrowed some of it down to the Zend currency area—if I ever try to update that 1.1.6 Zend directory (app > code > core > Zend) I begin to get currency errors. But I’m not sure why this means that when editing or adding a product that the “PRICE” field is gone ...

 
Magento Community Magento Community
Magento Community
Magento Community
 
wiseacredesign
Jr. Member
 
Avatar
Total Posts:  7
Joined:  2008-04-17
Cincinnati, OH
 

Screenshot of what I see in the Admin. What files do I look at for fixing this? I’m more the competent in PHP, but I don’t know where this specific area of the admin is being pulled from the database and shown in the template, etc.

Image Attachments
magento_issue-price.png
 
Magento Community Magento Community
Magento Community
Magento Community
 
David Weingart
Jr. Member
 
Total Posts:  5
Joined:  2008-05-05
 

Recently had the same problem after upgrading.

The solution (for anyone searching) is to make sure that the price attribute is enabled for all product types.

Go to Catalog -> Attributes -> Manage Attributes, and click on “price” to edit it. Make sure the Apply To field has “All Types” selected.

That fixed it for me.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top