Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

1.4.2.0 ===> 1.5.0.1 via Magento connect - conflict
 
Ton Swart
Jr. Member
 
Total Posts:  24
Joined:  2009-05-10
 

After changing the attributes it was possible to update the connect manager and to update from 1.4.2.0 to 1.5.0.1.

Not all packages are updated due to dependencies of packages. I know there is a solution for this if you have SSH access, but I don\’t have SSH access. Does anyone know how to solve this issue without SSH access?

This is the output from the Connect Manager screen.
----------------------------------
Checking dependencies of packages

CONNECT ERROR: Package community/Lib_Google_Checkout 1.5.0.0 conflicts with: community/Mage_Core_Modules 1.4.2.0
Checking dependencies of packages

CONNECT ERROR: Package community/Lib_Mage 1.5.0.0 conflicts with: community/Mage_Core_Modules 1.4.2.0
Checking dependencies of packages

CONNECT ERROR: Package community/Mage_Locale_en_US 1.5.0.0 conflicts with: community/Mage_Core_Modules 1.4.2.0
Checking dependencies of packages

CONNECT ERROR: Package community/Lib_Varien 1.5.0.0 conflicts with: community/Mage_Core_Modules 1.4.2.0
Package community/Lib_ZF 1.11.1.0 conflicts with: community/Lib_Varien 1.4.2.0
Package community/Lib_ZF_Locale 1.11.1.0 conflicts with: community/Lib_ZF 1.10.8.0
Checking dependencies of packages

CONNECT ERROR: Package community/Lib_ZF_Locale 1.11.1.0 conflicts with: community/Lib_ZF 1.10.8.0
Checking dependencies of packages
Already installed: community/Lib_Js_Prototype 1.6.0.3.4, skipping

CONNECT ERROR: Package community/Lib_Js_Mage 1.5.0.0 conflicts with: community/Mage_Core_Modules 1.4.2.0
Checking dependencies of packages
Already installed: community/Lib_Js_Calendar 1.51.1, skipping
Already installed: community/Lib_Js_Prototype 1.6.0.3.4, skipping

CONNECT ERROR: Package community/Mage_Core_Modules 1.5.0.1 conflicts with: community/Yoast_Blank_Seo_Theme 1.4.4
Package community/Lib_Varien 1.5.0.0 conflicts with: community/Mage_Core_Modules 1.4.2.0
Package community/Lib_Google_Checkout 1.5.0.0 conflicts with: community/Mage_Core_Modules 1.4.2.0
Package community/Lib_Js_Mage 1.5.0.0 conflicts with: community/Mage_Core_Modules 1.4.2.0
Package community/Lib_Phpseclib 1.5.0.0 conflicts with: community/Mage_Core_Modules 1.4.2.0
Package community/Mage_Locale_en_US 1.5.0.0 conflicts with: community/Mage_Core_Modules 1.4.2.0
Package community/Lib_Mage 1.5.0.0 conflicts with: community/Mage_Core_Modules 1.4.2.0
Package community/Lib_ZF 1.11.1.0 conflicts with: community/Lib_Varien 1.4.2.0
Package community/Lib_ZF_Locale 1.11.1.0 conflicts with: community/Lib_ZF 1.10.8.0
Checking dependencies of packages

CONNECT ERROR: Package community/Lib_Phpseclib 1.5.0.0 conflicts with: community/Mage_Core_Modules 1.4.2.0
Checking dependencies of packages

CONNECT ERROR: Package community/Lib_ZF 1.11.1.0 conflicts with: community/Lib_Varien 1.4.2.0
Package community/Lib_ZF_Locale 1.11.1.0 conflicts with: community/Lib_ZF 1.10.8.0

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
Justin Atack
Member
 
Avatar
Total Posts:  42
Joined:  2009-01-03
Sydney, Australia
 

I had the same error messages when I was performing the upgrade via SSH I found I had to “force” the upgrade. This something I guess you can only do via SSH.

./mage upgrade-all --force

I realise this won’t help in your situation but maybe there is a way to force the download with Magento Connect?

Are you sure you can’t get SSH access? It really is a life saver when running a Magento store, you should consider moving hosts if they won’t give you access.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Justin Atack
Member
 
Avatar
Total Posts:  42
Joined:  2009-01-03
Sydney, Australia
 

I had the same error messages when I was performing the upgrade via SSH I found I had to \"force\" the upgrade. This something I guess you can only do via SSH.

./mage upgrade-all --force

I realise this won\’t help in your situation but maybe there is a way to force the download with Magento Connect?

Are you sure you can\’t get SSH access? It really is a life saver when running a Magento store, you should consider moving hosts if they won\’t give you access.

 
Magento Community Magento Community
Magento Community
Magento Community
 
oldboy
Sr. Member
 
Total Posts:  80
Joined:  2008-08-12
 
Justin Atack - 07 March 2011 07:17 PM

I had the same error messages when I was performing the upgrade via SSH I found I had to \"force\" the upgrade. This something I guess you can only do via SSH.

./mage upgrade-all --force

I realise this won\’t help in your situation but maybe there is a way to force the download with Magento Connect?

Are you sure you can\’t get SSH access? It really is a life saver when running a Magento store, you should consider moving hosts if they won\’t give you access.

I have the same problem so i tested to login via SHH, but when trying this command:

./mage upgrade-all --force
i only get

-bash: ./magePermission denied
 
Magento Community Magento Community
Magento Community
Magento Community
 
Landis
Jr. Member
 
Total Posts:  19
Joined:  2010-05-20
 

I am getting the same result (permission denied).

Downloaded via SVN (put in /magento/1.5 folder

I then moved everything out of 1.5 and onto /magento/ folder

The other issue is that Magento Connect will update extensions but it will not run magento-core/Mage_Update_All
any more.

It says it can\’t resolve host magento-core

I get the same result trying to issue ./mage commands.

Not sure how to fix.  Help would be appreciated.

running version 1.42 (though it seems I have 1.5.1 files in my folder.

Update To POST:
... result after updating Magento Connect to 1.5 from 1.4.2

For some reason Downloader has been upgraded to version 1.5 but the rest of the system is at version 1.4.2 still.

./mage update-all (or proper code for such from 2 days ago) is wanting BOTH xcache and apc.  I can’t install both, and if I remove one, it is called for, and if I remove the other it is called for.

I cannot find any reference in any php.ini files for these cache accellerators.  How to keep this from blocking upgrade to 1.5?

thank you for any help.

Landis

 
Magento Community Magento Community
Magento Community
Magento Community
 
Dorgo
Sr. Member
 
Total Posts:  127
Joined:  2008-12-16
 

I have the same problem so i tested to login via SHH, but when trying this command:

./mage upgrade-all --force
i only get

-bash: ./magePermission denied

try:

chmod 550 mage
 
Magento Community Magento Community
Magento Community
Magento Community
 
nico76
Sr. Member
 
Avatar
Total Posts:  76
Joined:  2007-09-06
Berlin
 

Hi Ton Swart,

I guess you have to deinstall Yoast_Blank_Seo_Theme 1.4.4 and try the Update again.

I just had the same Problem with yoast meta robots

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ton Swart
Jr. Member
 
Total Posts:  24
Joined:  2009-05-10
 

The problem is I can’t deinstall Yoast. I tried to remove it manually but it stays on the list in connect.

 
Magento Community Magento Community
Magento Community
Magento Community
 
grazzt
Sr. Member
 
Total Posts:  106
Joined:  2010-02-28
 
nico76 - 28 April 2011 06:59 AM

Hi Ton Swart,

I guess you have to deinstall Yoast_Blank_Seo_Theme 1.4.4 and try the Update again.

I just had the same Problem with yoast meta robots

I uninstalled yoast meta robots and the issue was resolved. Thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ton Swart
Jr. Member
 
Total Posts:  24
Joined:  2009-05-10
 

The problem is I can’t deinstall Yoast. I tried to remove it manually but it stays on the list in connect. So whatever I try it stays on the list and there no update possible all is more or like in a loop.

Think the developer has been past away in the mean time. Does somebody knows where I can I can it remove from the install list?

Thanks in advance

 
Magento Community Magento Community
Magento Community
Magento Community
 
ericscott
Member
 
Total Posts:  57
Joined:  2008-05-14
 

I have actually been through this process twice now upgrading from 1.4.2 to 1.5. Here are the steps I have taken:
1. In Magento connect, typed “magento-core/Mage_all_latest” into the extension key input… runs “successfully”
2. I get a front end error related to the wishlist, so I turn wishlist off and I’m back at an almost fully functional Magento
3. Admin still says that we’re at 1.4.2, so I check for upgrades and select all the most recent versions from the dropdowns… runs with a with errors described in the first post in this thread
4. I get a 500 Internal Server error on the front end, so I make sure htaccess and index.php both have 755 permissions. I do notice some files in the root have a different number (644 I believe?). Could that be the issue?
5. Delete all files from webroot and reupload files from a backup.

This is like Magento instance #13 or #14 that I have worked with, and never had I had this many problems with it. Do any of you know if there is another way around these issues while upgrading, besides SSH?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top