Magento Forum

   
Page 1 of 2
Magento Connect - Invalid channel.xml file problem
 
Andrew Shand
Jr. Member
 
Total Posts:  4
Joined:  2008-11-16
 

I am getting this error when using Magento Connect “Invalid channel.xml file” any ideas on how to fix this?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Rhonda_Rondeau
Enthusiast
 
Total Posts:  924
Joined:  2010-08-03
Culver City
 

what version are you on? fresh install or upgrade?

Let me know!
Rhonda

 
Magento Community Magento Community
Magento Community
Magento Community
 
Andrew Shand
Jr. Member
 
Total Posts:  4
Joined:  2008-11-16
 

Thanks Rhonda,

Its a fresh install, 1.5

 
Magento Community Magento Community
Magento Community
Magento Community
 
Rhonda_Rondeau
Enthusiast
 
Total Posts:  924
Joined:  2010-08-03
Culver City
 

I’m waiting for a test server for 1.5 because it hasn’t been created yet. Have you seen anyone else with this prob? (wondering if it’s an isolated incident or global)

 
Magento Community Magento Community
Magento Community
Magento Community
 
Andrew Shand
Jr. Member
 
Total Posts:  4
Joined:  2008-11-16
 

Hi,

Searched for hours, doesn’t look like anyone else has had the problem, using debian OS if that makes any difference

 
Magento Community Magento Community
Magento Community
Magento Community
 
Zimmer
Jr. Member
 
Total Posts:  18
Joined:  2008-06-13
 

No, I have the same problem as well. Installing any extension comes up with this problem. Which means I cannot install them.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Rhonda_Rondeau
Enthusiast
 
Total Posts:  924
Joined:  2010-08-03
Culver City
 

Can you give me an extension as an example? Also are you trying to get 1.0 or 2.0 extensions? I have a test server now wink

 
Magento Community Magento Community
Magento Community
Magento Community
 
Zimmer
Jr. Member
 
Total Posts:  18
Joined:  2008-06-13
 

Eh, Mxperts Jquery was the last one I tried…

Wait, is 1.5.0.1 running Connect v2? It wasn’t stated anywhere in the release notes, and when the last major release came out (1.4.2.0) it stated that the new Magento Connect had been excluded from that version… So I assumed it hadn’t been added in again…

I guess I’m wrong in this respect?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Rhonda_Rondeau
Enthusiast
 
Total Posts:  924
Joined:  2010-08-03
Culver City
 
Zimmer - 16 February 2011 04:41 PM

Eh, Mxperts Jquery was the last one I tried…

Wait, is 1.5.0.1 running Connect v2? It wasn’t stated anywhere in the release notes, and when the last major release came out (1.4.2.0) it stated that the new Magento Connect had been excluded from that version… So I assumed it hadn’t been added in again…

I guess I’m wrong in this respect?

It wasn’t in 2.0 stable. If I remember correctly we had it in RC1 and removed it in RC2. We had it in the release candidates only.  I am not sure why it wasn’t listed but I should probably find out. In any case, yes 1.5 is the newer connect and should be getting 2.0 extensions.

Thanks smile

Rhonda

 
Magento Community Magento Community
Magento Community
Magento Community
 
pandom
Jr. Member
 
Total Posts:  1
Joined:  2010-08-31
 

Rhonda,

I have same problem.  I’m fresh installed the 1.5.0.1 on Nginx

can not install extension.

do you have any way to solve the problems?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Rhonda_Rondeau
Enthusiast
 
Total Posts:  924
Joined:  2010-08-03
Culver City
 
pandom - 18 February 2011 10:18 AM

Rhonda,

I have same problem.  I’m fresh installed the 1.5.0.1 on Nginx

can not install extension.

do you have any way to solve the problems?

are you getting 1.0 or 2.0 extensions? if your on 1.5.x.x. you need the 2.0

Rhonda

 
Magento Community Magento Community
Magento Community
Magento Community
 
centervanliemp1
Jr. Member
 
Total Posts:  9
Joined:  2011-02-09
 

same problem

when entering magento-core/Mage_All_Latest in connectmanager 1.5.0.0

Invalid channel.xml file

trying to upgrade from 1.4.2.0 to 1.5.0.1

 
Magento Community Magento Community
Magento Community
Magento Community
 
Rhonda_Rondeau
Enthusiast
 
Total Posts:  924
Joined:  2010-08-03
Culver City
 

Yes we’re on the NEW connect now. You must get 2.0 extensions. Check out the top sticky I explained. I’ve asked to have the release notes updated it was an oversight because it was announced on rc1 but removed in rc2. We’re on a 3 day holiday weekend so it probably hasn’t been updated yet. smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
ajasin
Jr. Member
 
Total Posts:  1
Joined:  2009-07-12
 

i had this error but this gone some how by the following action

In another installation i could install extension so i verified the folder architecture. i Copied app folder to same folder and renamed as
app - Copy

now the error was gone...!!!! very new to magento so if you see any foolishness in this just forgive me.... cool smile........  i am just a fool

 
Magento Community Magento Community
Magento Community
Magento Community
 
Rhonda_Rondeau
Enthusiast
 
Total Posts:  924
Joined:  2010-08-03
Culver City
 
ajasin - 17 March 2011 08:24 PM

i had this error but this gone some how by the following action


In another installation i could install extension so i verified the folder architecture. i Copied app folder to same folder and renamed as
app - Copy


now the error was gone...!!!! very new to magento so if you see any foolishness in this just forgive me.... cool smile........  i am just a fool

There are no foolish questions, don’t worry! smile

Rhonda

 
Magento Community Magento Community
Magento Community
Magento Community
 
brandonWargo
Jr. Member
 
Total Posts:  8
Joined:  2010-12-30
 

Yes, changing the Magento Connect Version from 1.0 to 2.0 fixed this error for me as well.

Thanks, Rhonda!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top
Page 1 of 2