Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

1.4.2.0 ===> 1.5.0.1 via Magento connect or via SSH gives me various errors
 
veracious
Sr. Member
 
Total Posts:  114
Joined:  2010-09-19
 

I am trying to upgrade via magento connect 1.4.2.0 ===> 1.5.0.1.  I will do a clean install and manually bring my important data and files over but I was hoping to make sure you can upgrade via magento connect as I am going live with the site soon and would like to know the most userfriendly upgrade method is functioning. 

I got a few errors trying to upgrade:

via magento connect:

Ignoring installed package magento-core/Mage_All_Latest
Nothing to install

via ssh I got a similar error:

Attempting to discover channel "magento-core"...
unknown channel "magento-core" in "magento-core/Mage_All_Latest"
invalid package name/package file "magento-core/Mage_All_Latest"
Cannot initialize 'magento-core/Mage_All_Latest'invalid or missing package file
Package 
"magento-core/Mage_All_Latest" is not valid
install failed

In the downloader I noticed a the downloader had a version 1.5.0.0 upgrade available.  I thought maybe I needed the newest downloader before I could update all the packages.  I upgraded just the downloader to 1.5.0.0 which worked.  Then I tried the full upgrade again and now it is mega retarded with this:

Couldn't resolve host 'magento-core'

Thats cute isn’t it?  So I gave it once last whirl at the ssh console and i get this bad boy:

Attempting to discover channel "magento-core"...
Attempting fallback to https instead of http on channel "magento-core"...
unknown channel "magento-core" in "magento-core/Mage_All_Latest"
invalid package name/package file "magento-core/Mage_All_Latest"
install failed

So it can’t connect to the mage-core pear repository with the new downloader.  SWEET!  Anyone else seeing any of this?

UPDATE I DID NOT CLOSE THIS THREAD, WTF!?!  ALSO THE CAPTCHA SYSTEM GOBBLES DICK!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial
Enthusiast
 
Avatar
Total Posts:  770
Joined:  2007-11-07
Phoenix, AZ
 

Have you tried using SSH to upgrade? I just upgraded a 1.4.x store to 1.5.01 with no issues using the following command:

./pear upgrade-all

If you get version errors or anything, try this command:

./mage install http://connect20.magentocommerce.com/community Mage_All_Latest

You might have to replace mage with pear though.

You can also refer to the following:

http://www.crucialwebhost.com/kb/article/upgrading-magento-via-ssh/

 
Magento Community Magento Community
Magento Community
Magento Community
 
Turnkeye
Enthusiast
 
Avatar
Total Posts:  908
Joined:  2008-12-20
URL: turnkeye.com
 

Veracious,

Try to use:
http://connect20.magentocommerce.com/community/Mage_All_Latest

instead of:
magento-core/Mage_All_Latest

The latest version of Magento Connect (2.0 version) uses new URL format.

 
Magento Community Magento Community
Magento Community
Magento Community
 
MacPlace
Jr. Member
 
Avatar
Total Posts:  2
Joined:  2011-04-25
 
Turnkeye.com - 11 April 2011 07:15 AM

Veracious,

Try to use:
http://connect20.magentocommerce.com/community/Mage_All_Latest

instead of:
magento-core/Mage_All_Latest

The latest version of Magento Connect (2.0 version) uses new URL format.

I using this method and then appear a firefox window showing “index.php” file to download…

Any idea about error?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Turnkeye
Enthusiast
 
Avatar
Total Posts:  908
Joined:  2008-12-20
URL: turnkeye.com
 
MacPlace - 26 April 2011 03:09 PM

I using this method and then appear a firefox window showing “index.php” file to download…
Any idea about error?

You can download the index.php?

It seems that PHP engine is down, ask you hosting administrator to look into this issue.

 
Magento Community Magento Community
Magento Community
Magento Community
 
blinton
Jr. Member
 
Total Posts:  6
Joined:  2009-08-18
 

I seem to have a similar-ish problem. Right now I am using Crucial hosting.

Using Magento Connect Manager ver. 1.5.0.0 to upgrade Magento ver. 1.4.1.1 to current
I paste magento-core/Mage_All_Latest into Paste extension key to install and I receive the error: Error: Couldn’t resolve host ‘magento-core’

I tried the recommendation from crucial in this thread and used SSH and entered

./pear upgrade-all
it returned the following
Nothing to upgrade-all

I ran:

./mage install http://connect20.magentocommerce.com/community Mage_All_Latest
and I get an error that many files already existed

I ran

./pear install http://connect20.magentocommerce.com/community Mage_All_Latest
and I got
No releases available for package "pear.php.net/Mage_All_Latest"
Cannot initialize 'channel://pear.php.net/Mage_All_Latest'invalid or missing package file
Could not download from 
"http://connect20.magentocommerce.com/community" (File http://connect20.magentocommerce.com:80/community/ not valid (received: HTTP/1.1 403 Forbidden
))
Invalid or missing remote package file
Package 
"channel://pear.php.net/Mage_All_Latest" is not valid
Package 
"http://connect20.magentocommerce.com/community" is not valid
install failed

As suggested on the Crucial site I tried running:

./pear mage-setup .
./
pear install magento-core/Mage_All_Latest
rm 
-rf downloader/pearlib/cache/* downloader/pearlib/download/*//tempend ?>
and I got:
ERRORfailed to write ./lib/PEAR/HTTP/Request/.tmpListener.phpcopy(./lib/PEAR/HTTP/Request/.tmpListener.php): failed to open streamPermission denied
ERROR
failed to write ./lib/phpseclib/Crypt/.tmpAES.phpcopy(./lib/phpseclib/Crypt/.tmpAES.php): failed to open streamPermission denied
ERROR
failed to write ./lib/LinLibertineFont/.tmpBugscopy(./lib/LinLibertineFont/.tmpBugs): failed to open streamPermission denied

Not sure where to go from here on trying to update my site :(

 
Magento Community Magento Community
Magento Community
Magento Community
 
Turnkeye
Enthusiast
 
Avatar
Total Posts:  908
Joined:  2008-12-20
URL: turnkeye.com
 

You need to contact your hosting provide regarding “Permission denied” errors.

 
Magento Community Magento Community
Magento Community
Magento Community
 
xtchost
Jr. Member
 
Total Posts:  2
Joined:  2009-06-08
 

I just had a problem upgrading using pear in ssh - error -->> Error getting channel info from connect.magentocommerce.com/community: Invalid xml downloaded from “http://connect.magentocommerce.com/community/Chiara_PEAR_Server_REST/p/packages.xml”: XML Error: ‘not well-formed (invalid token)’ on line ‘231’

I also had a file permission problem using /madge

I changed the file permission on madge and upgraded using

./mage install http://connect20.magentocommerce.com/community Mage_All_Latest

All is now well...............

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top