Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 2 of 3
Certain packages wont upgrade. 
 
bluescrubbie
Jr. Member
 
Total Posts:  21
Joined:  2009-10-01
 

This worked for me to upgrade from 1.4.3.2 to 1.5.1.

BACKUP YOUR DATABASE BEFORE STARTING!!
from inside the directory you wish to install magento:

wget http://www.magentocommerce.com/downloads/assets/1.5.0.1/magento-1.5.0.1.tar.gz
tar -zxvf magento-1.5.0.1.tar.gz
mv magento/* magento/.htaccess .
chmod o+w var var/.htaccess app/etc
chmod -R o+w media
chmod o+x mage # the copy I got was not owner executable
rm -rf var/* # if it’s not empty
./mage mage-setup .
./mage install http://connect20.magentocommerce.com/community Mage_All_Latest --force # --force prevents errors
rm -rf magento/ magento-1.5.0.1.tar.gz

EDIT app/etc/local.xml before visiting a page!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Turnkeye
Moderator
 
Avatar
Total Posts:  908
Joined:  2008-12-20
URL: turnkeye.com
 

If you get this error during upgrade:

upgrade-allInvalid stability in compareStabilities argument

Try to replace this command:

./mage upgrade-all --force

With:

./mage install http://connect20.magentocommerce.com/community Mage_All_Latest --force
 
Magento Community Magento Community
Magento Community
Magento Community
 
glideranderson
Jr. Member
 
Total Posts:  18
Joined:  2011-04-08
 

when using the upgrade_all --force, it will install beta versions, however I just want to upgrade to the next stable version (like magento v.1.5.1.0). How do I do that?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ross
Guru
 
Avatar
Total Posts:  336
Joined:  2007-08-31
Scarborough, North Yorkshire, UK
 

set to stable if you don’t want ‘beta’

./mage config-set preferred_state stable
 
Magento Community Magento Community
Magento Community
Magento Community
 
Turnkeye
Moderator
 
Avatar
Total Posts:  908
Joined:  2008-12-20
URL: turnkeye.com
 

Yes, execute this command:

./mage config-set preferred_state stable

and than check if it was set successfully using this command:

./mage list-upgrades

It will show you this information if upgrade configured for 1.6

Mage_All_Latest1.4.2.1 => 1.6.0.0-rc2

if you will be upgraded to latest stable 1.5.x, you will see this:

Mage_All_Latest1.4.2.1 => 1.5.1.0.1

You can check our blog for more details:
http://turnkeye.com/blog/magento-upgrade-from-1-4-version-to-magento-1-5-magento-1-6/

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ross
Guru
 
Avatar
Total Posts:  336
Joined:  2007-08-31
Scarborough, North Yorkshire, UK
 
Turnkeye.com - 21 July 2011 11:27 PM

You can check our blog for more details:
http://turnkeye.com/blog/magento-upgrade-from-1-4-version-to-magento-1-5-magento-1-6/

@Turnkeye - Looks like a helpful guide you have done there

Is that you in the picture grin

 
Magento Community Magento Community
Magento Community
Magento Community
 
misterpatrick
Member
 
Total Posts:  74
Joined:  2010-03-30
 

I’m trying to run some package updates and like other am getting “Uri doesn’t contain host part”. Anyone figured out what is causing this?

 
Magento Community Magento Community
Magento Community
Magento Community
 
dotprkirk
Member
 
Total Posts:  50
Joined:  2008-04-22
 
misterpatrick - 03 August 2011 05:36 PM

I’m trying to run some package updates and like other am getting “Uri doesn’t contain host part”. Anyone figured out what is causing this?

That’s the exact problem I’m running into. I can’t figure it out, and there’s no real documentation regarding this.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Turnkeye
Moderator
 
Avatar
Total Posts:  908
Joined:  2008-12-20
URL: turnkeye.com
 
Ross - 21 July 2011 11:38 PM

Turnkeye.com - 21 July 2011 11:27 PM

You can check our blog for more details:
http://turnkeye.com/blog/magento-upgrade-from-1-4-version-to-magento-1-5-magento-1-6/

@Turnkeye - Looks like a helpful guide you have done there

Is that you in the picture grin

Hi Ross, thank you!

> Is that you in the picture grin

Yes wink

 
Magento Community Magento Community
Magento Community
Magento Community
 
RickKars
Jr. Member
 
Total Posts:  2
Joined:  2010-11-25
 

When I try to upgrade Magento 1.4.1 to 1.6 by following the instructions of the Turnkeye manual http://turnkeye.com/blog/magento-upgrade-from-1-4-version-to-magento-1-5-magento-1-6/ , I come across a problem.  I can manage to upgrade Magento to 1.4.2, but when I try to upgrade to 1.6 something goes wrong. At the command “ ./mage list-upgrades” I get the following error:
./mage list-upgrades
Error:
list-upgrades: Invalid stability in compareStabilities argument

The following commands don’t help either:
./mage channel-add connect20.magentocommerce.com/community
./mage channel-add connect20.magentocommerce.com/core
./mage sync

If I continue the installation with the following command:
./mage install http://connect20.magentocommerce.com/community Mage_All_Latest --force
The installation is being upgraded to Magento 1.7. There are several extensions which don’t work in Magento 1.7 & 1.6.2.
How can I carry out the upgrade to Magento 1.6.1 ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
judithrobins
Jr. Member
 
Total Posts:  3
Joined:  2012-01-19
 

I have the same problem. Any suggestions?

 
Magento Community Magento Community
Magento Community
Magento Community
 
wangel
Jr. Member
 
Total Posts:  7
Joined:  2011-03-12
 

Me also having problem with upgrades. Upgrade by ssh from 1.6.2 to 1.7 went OK, but after that cant’t upgrade extensions, getting
list-upgrades: Invalid stability in compareStabilities argument
and also, Magento connect mnager does’nt seem to read any updates available when I click on the “check for upgrades” button. When I paste an extension key to “Install New Extensions”, then I get the same message “Invalid stability in compareStabilities argument”.
Changing the “Preferred State” option in settings did’nt solve the problem.
.........................................................
Well, back here some days later. I think I found what was wrong. The problem was in downloader/lib/Mage/Connect/Validator.php and it was caused by extensions that have their stability state “dev” or Validator accepts only these values “devel”, “alpha”, “beta”, and “stable”. The workaround was to add these two lines near line 70:

if ($s1 == “dev") $s1="devel";
if ($s2 == “dev") $s2="devel";

so validator.php looks now like:

public function compareStabilities($s1$s2)
    
{
        $list 
$this->getStabilities();
        
$tmp array_combine(array_values($list),array_keys($list));
        
    if (
$s1 == "dev"{$s11="dev"$s1="devel";}   // you can erase $s11, it is here only for testing
    
if ($s2 == "dev"{$s22="dev"$s2="devel";}   // you can erase $s22, it is here only for testing
 //   echo "$s1-$s11-$tmp[$s1], $s2-$s22-$tmp[$s2]<br />\n";   // for test purpose

        
if (!isset($tmp[$s1]$tmp[$s2])) {
            
throw new Exception("Invalid stability in compareStabilities argument");
        
}
Hope this helps. Good evening !

PS : Of course you’ll do it in a local copy of Validator.php

 
Magento Community Magento Community
Magento Community
Magento Community
 
Chris_Barker
Jr. Member
 
Total Posts:  2
Joined:  2013-09-24
England
 

Will this work to upgrade from 1.4.2 also?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Jacksonpulickal
Jr. Member
 
Total Posts:  4
Joined:  2010-06-16
 

wangel : thanks for the solution.You have save my hours .I was able to upgrade 1.6 to 1.8 with your solution.This error occurs when we are having lots of extensions installed.My magento has around 50+ extensions installed.Solution Works Cheers..

 
Magento Community Magento Community
Magento Community
Magento Community
 
picablaat
Jr. Member
 
Total Posts:  9
Joined:  2010-11-22
 

Thanks!

This solution saved my downloader!
Was struggling with it not finding any updates and after this modification it works again like a charm....
You’re the man! wink

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 2 of 3