Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 3
Certain packages wont upgrade. 
 
tcdmark
Jr. Member
 
Total Posts:  7
Joined:  2010-09-27
 

Hey all. Im trying to update to the latest version of Magento and it worked, however some packages are still highlighted in yellow and say they need to be upgraded.

When i use Magento Connect to upgrade them i get the following error.

Checking dependencies of packages
Package community
/Lib_Js_Calendar failedVersion for 'Lib_Js_Calendar' was not detected
Already installed
community/Lib_Js_Prototype 1.6.0.3.4skipping

CONNECT ERROR
Package community/Mage_Core_Modules 1.5.0.1 conflicts withcommunity/Find_Feed 1.0.7
Package community
/Lib_Varien 1.5.0.0 conflicts withcommunity/Mage_Core_Modules 1.4.2.0
Package community
/Lib_Google_Checkout 1.5.0.0 conflicts withcommunity/Mage_Core_Modules 1.4.2.0
Package community
/Lib_Js_Mage 1.5.0.0 conflicts withcommunity/Mage_Core_Modules 1.4.2.0
Package community
/Lib_Phpseclib 1.5.0.0 conflicts withcommunity/Mage_Core_Modules 1.4.2.0
Package community
/Mage_Locale_en_US 1.5.0.0 conflicts withcommunity/Mage_Core_Modules 1.4.2.0
Package community
/Lib_Mage 1.5.0.0 conflicts withcommunity/Mage_Core_Modules 1.4.2.0
Package community
/Lib_ZF 1.11.1.0 conflicts withcommunity/Lib_Varien 1.4.2.0
Package community
/Lib_ZF_Locale 1.11.1.0 conflicts withcommunity/Lib_ZF 1.10.8.0

The following packages need updating but wont:

Lib_Google_Checkout 1.4.2.0 (stable) 1.5.0.0 (1.4.2.0) Google Checkout Library
Lib_Js_Mage 1.4.2.0 (stable) 1.5.0.0 (1.4.2.0) Javascript Libraries for Magento
Lib_Mage 1.4.2.0 (stable) 1.5.0.0 (1.4.2.0) Mage Library
Lib_Phpseclib 1.4.2.0 (stable) 1.5.0.0 (1.4.2.0) Phpseclib Library
Lib_Varien 1.4.2.0 (stable) 1.5.0.0 (1.4.2.0) Varien Library
Lib_ZF 1.10.8.0 (stable) 1.11.1.0 (1.10.8.0) Zend Framework
Lib_ZF_Locale 1.10.8.0 (stable) 1.11.1.0 (1.10.8.0) Zend Framework Locale
Mage_Core_Modules 1.4.2.0 (stable) 1.5.0.1 (1.4.2.0) Collection of Magento Core Modules
Mage_Locale_en_US 1.4.2.0 (stable) 1.5.0.0 (1.4.2.0) en_US locale

Any ideas?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Mattias Lyth
Jr. Member
 
Total Posts:  9
Joined:  2010-08-31
 

Same error message here,

The store is not upgraded to 1.5 but only to 1.4.2. Backend works sort of. Seems that the customers are not displaying correctly at all only addresses.

Also frontend looks like shit, probably related to that I updated my free theme in the same run.

 
Magento Community Magento Community
Magento Community
Magento Community
 
pgulikers
Jr. Member
 
Total Posts:  27
Joined:  2009-02-21
 

Please do as follows:

./pear upgrade-all
./mage sync-pear
./mage upgrade-all

if you get conflicting error, please use:
./mage upgrade-all --force

More info at: http://www.magentocommerce.com/wiki/magento_connect_manager_upgrade

 
Magento Community Magento Community
Magento Community
Magento Community
 
shadowhome
Jr. Member
 
Total Posts:  15
Joined:  2008-07-26
 

Anyone know what Im doing wrong here?

./mage upgrade-all --force
Error:
upgrade-all: Uri doesn’t contain host part
./mage upgrade-all
Error:
upgrade-all: Uri doesn’t contain host part

Thanks

Brent

Cest Chic

 
Magento Community Magento Community
Magento Community
Magento Community
 
buzbuzzer
Jr. Member
 
Total Posts:  29
Joined:  2008-11-24
 

@shadowhome: Without looking too far into it, I am assuming you tried to type those commands in Magento Connect. That would do nothing and is not the intended use of that code. It is a command if you have SSH access to your account and you send that command through a terminal like PuTTy grin

or possibly if you are in SSH, are you in the install directory?

 
Magento Community Magento Community
Magento Community
Magento Community
 
ttitan
Jr. Member
 
Total Posts:  1
Joined:  2011-02-08
 

I have the same problem:

Checking dependencies of packages
Package community
/Lib_Js_Calendar failedVersion for \'Lib_Js_Calendar\' was not detected
Already installed
community/Lib_Js_Prototype 1.6.0.3.4skipping

CONNECT ERROR
Package community/Mage_Core_Modules 1.5.0.1 conflicts withcommunity/Find_Feed 1.0.7
Package community
/Lib_Varien 1.5.0.0 conflicts withcommunity/Mage_Core_Modules 1.4.2.0
Package community
/Lib_Google_Checkout 1.5.0.0 conflicts withcommunity/Mage_Core_Modules 1.4.2.0
Package community
/Lib_Js_Mage 1.5.0.0 conflicts withcommunity/Mage_Core_Modules 1.4.2.0
Package community
/Lib_Phpseclib 1.5.0.0 conflicts withcommunity/Mage_Core_Modules 1.4.2.0
Package community
/Mage_Locale_en_US 1.5.0.0 conflicts withcommunity/Mage_Core_Modules 1.4.2.0
Package community
/Lib_Mage 1.5.0.0 conflicts withcommunity/Mage_Core_Modules 1.4.2.0
Package community
/Lib_ZF 1.11.1.0 conflicts withcommunity/Lib_Varien 1.4.2.0
Package community
/Lib_ZF_Locale 1.11.1.0 conflicts withcommunity/Lib_ZF 1.10.8.0

I haven’t got SSH access. Do you know some other solution?

 
Magento Community Magento Community
Magento Community
Magento Community
 
supergper
Member
 
Total Posts:  34
Joined:  2009-03-15
 
PGU - 10 February 2011 12:06 AM

Please do as follows:

./pear upgrade-all
./mage sync-pear
./mage upgrade-all

if you get conflicting error, please use:
./mage upgrade-all --force

More info at: http://www.magentocommerce.com/wiki/magento_connect_manager_upgrade

Well, I was having this same problem, only a few of the upgrades succeeded so I did as suggested (which I had no upgrades according to the upgrade-all) and now I no longer even have MCM at all (see attached photo).  Now when I do:

# ./mage list-channels
Available channels:

I have no channels available.  So, what channels do I need to add back in and why would they be gone.  Also, why would MCM be completely missing from my admin panel?  Wow, this upgrade is terrible.

 
Magento Community Magento Community
Magento Community
Magento Community
 
supergper
Member
 
Total Posts:  34
Joined:  2009-03-15
 

OK, well, I got upgraded to 1.5.0.1 finally.  For those that are having problems, here’s how I got it to finally work. (Done via SSH, so if you don’t have SSH access then IDK)

./mage add-channel connect20.magentocommerce.com/community
./mage add-channel connect20.magentocommerce.com/core (I don’t know if core is actually needed but I added it anyways)
./mage sync (note, not sync-pear)
./mage upgrade-all --force (I had to use --force because of all the conflicting packages like most in this thread are having)

Then I went in to the Admin panel and cleared all caches.  My site is now running on 1.5.0.1.  Good Luck all, this was surely a clusterf** of an upgrade.

Also, after upgrading everything and clearing the caches, my MCM is now back in my Admin panel.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Eric Cavalcanti
Guru
 
Avatar
Total Posts:  710
Joined:  2008-09-28
San Antonio
 

I get this:
-bash: ./mage: Permission denied

:(

 
Magento Community Magento Community
Magento Community
Magento Community
 
supergper
Member
 
Total Posts:  34
Joined:  2009-03-15
 
CajuCLC - 10 February 2011 12:51 PM

I get this:
-bash: ./mage: Permission denied

:(

You need to make sure you have execute permissions to mage.  So in the root of your store, you will need to chown it ot the correct owner adn group (assuming apache, it may be different for your setup) `chown apache:apache mage` then give group execute permissions `chmod g+x mage` and assuming your user is part of your apache group, you should now be able to run that.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Eric Cavalcanti
Guru
 
Avatar
Total Posts:  710
Joined:  2008-09-28
San Antonio
 

Ok, got it to work now. Lol
But yet 1.4.2.0

 
Magento Community Magento Community
Magento Community
Magento Community
 
Eric Cavalcanti
Guru
 
Avatar
Total Posts:  710
Joined:  2008-09-28
San Antonio
 

Ok.
I had this store running since 1.4.0.0 and it was at 1.4.2.0 now.
It did upgrade fine, thanks.
I had this other one I did install fresh using 1.4.2.0 and tried to upgrade using same thing, nothing…

Crazy....

 
Magento Community Magento Community
Magento Community
Magento Community
 
veracious
Sr. Member
 
Total Posts:  114
Joined:  2010-09-19
 

lol cajun that means you didn’t get it silly.

Thanks for the info supergper but I get an error on the last command

./mage upgrade-all --force

It gives me back this:
upgrade-all: Invalid stability in compareStabilities argument

The only reason i can think that I am getting this error is because my downloader did get upgraded last night while trying to upgrade. Mage_Downloader is 1.5.0.0 (stable) .  But nothing else is upgraded.  Also my community extensions and core extensions are now all in one list, not seperated as with the old downloader.  Is this how it should be on 1.5.x.x MC?
Read my post here to see the errors I was getting last night trying to upgrade to 1.5.0.1:
http://www.magentocommerce.com/boards/viewthread/219742/

 
Magento Community Magento Community
Magento Community
Magento Community
 
veracious
Sr. Member
 
Total Posts:  114
Joined:  2010-09-19
 

When i tried your first two commands it complained and spit back out the command usage.  It looks like it should be:
channel-add not add-channel

./mage channel-add connect20.magentocommerce.com/community 
./mage channel-add connect20.magentocommerce.com/core
./mage sync
./mage upgrade-all --force
 
Magento Community Magento Community
Magento Community
Magento Community
 
Eric Cavalcanti
Guru
 
Avatar
Total Posts:  710
Joined:  2008-09-28
San Antonio
 

Well, I tried on all stores I have since 1.4.0 and went updating and it worked fine.
This fresh 1.4.2.0 won’t update. No error, nothing!
lol

 
Magento Community Magento Community
Magento Community
Magento Community
 
radge
Member
 
Total Posts:  40
Joined:  2008-10-04
 

i have the same error… i subscribe to this post , for news…

thxs a lot

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 3