Magento Forum

?frontend= in URL
 
derbas
Jr. Member
 
Total Posts:  19
Joined:  2009-09-06
 

Hi,

I couldn’t find another topic on this issue - I hope I’m not the only one:

Speedster is installed and working on my 1.4.1.1. shop.

Viewing my website through Google Webmaster Tools (view as Google bot) every URL has an ?frontend=g54sgbku4h7rl8melpn283msl5 at the end. Letters and numbers after = are always different.

Google lists my URLs as duplicates. Does anyone have an idea where this is coming from?

Thank you for your help!

Regards

derbas

 
Magento Community Magento Community
Magento Community
Magento Community
 
FOOMAN
Guru
 
Avatar
Total Posts:  669
Joined:  2007-12-13
Auckland, New Zealand
 

Hi derbas, I am currently not sure how this could be caused by running Speedster. The urls look like the cookie or session value is appended. I suggest adding frontend to the ignored parameters in your Google Analytics Profile settings under Profile Settings > Exclude URL Query Parameters

 
Magento Community Magento Community
Magento Community
Magento Community
 
usauggs
Jr. Member
 
Total Posts:  26
Joined:  2009-08-23
 

hi there,

anybody can help?  i\’m using 1.4.1.1 and 1.4.0.1, both of them show this problem, there are ?frontend= in URLs.

Although you can ignore this parameter using google webmasters tools, but it still affect indexing of your website. i think.

Anybody can help on this. Thanks in advance.

 
Magento Community Magento Community
Magento Community
Magento Community
 
TravelSize_ie
Member
 
Total Posts:  39
Joined:  2009-10-19
 

I’ve got the same problem, with duplicate pages getting indexed with different ?frontend= parameter values.
I can get rid of the duplication with the URL parameters setting in google webmaster tools, but still have the issue of the pages being indexed with ?frontend= in the URL.

I’m also using Fooman speedster - don’t know if that’s what’s causing it though?
It’s not the session ID parameter, I have that turned off.

 
Magento Community Magento Community
Magento Community
Magento Community
 
derbas
Jr. Member
 
Total Posts:  19
Joined:  2009-09-06
 

Make sure to use URL Links in this way href="{{store url="imprint"}} or complete static url path with your domain.
Just using /imprint produces this error.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top