Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Cannot add images to products after migration
 
Fabiain
Jr. Member
 
Total Posts:  25
Joined:  2009-04-08
 

After a migation the button to add images to a product is gone.

I get this Javascript error:
Uncaught ReferenceError: id_0c3d1ce82494454dbd8af210b60d5ebf_UploaderJsObject is not defined

on this line:
var media_gallery_contentJsObject = new Product.Gallery(\’media_gallery_content\’, id_0c3d1ce82494454dbd8af210b60d5ebf_UploaderJsObject, {\"image\”:{\"label\":\"Base Image <br\\/>[STORE VIEW]\”,\"field\”:\"product[image]\"},\"small_image\”:{\"label\":\"Small Image <br\\/>[STORE VIEW]\”,\"field\”:\"product[small_image]\"},\"thumbnail\”:{\"label\":\"Thumbnail <br\\/>[STORE VIEW]\”,\"field\”:\"product[thumbnail]\"}});

Anyone know what can cause this?

Another Magento shop on the same server does not have this problem.

Update:

I found out what the problem was.

During migration/testing I had excluded the “media” folder, but instead of only excluding /siteroot/media I had also excluded a few media folders in subdirecties unknowingly by accident, one of them was ./app/design/adminhtml/default/default/template/media and without this folder the upload/images in the admin panel do not work.

 
Magento Community Magento Community
Magento Community
Magento Community
 
verveithyd
Jr. Member
 
Total Posts:  2
Joined:  2011-12-30
 

same problem......

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top