Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 4 of 4
Megento Connect Manager - Link 404
 
jjjgamer
Jr. Member
 
Total Posts:  1
Joined:  2013-08-09
 
inMotionGfx - 21 January 2013 09:23 PM

For those of you who still haven’t been able to resolve this issue after trying all of the above solutions, I thought I’d share mine with you, since it hasn’t been mentioned anywhere before as far as I know.

I tried all of the solutions above, and none helped… my permissions are right, tried accessing the correct URL directly etc.

In the end I asked my server guys to look at it, and this is what they found, and how they fixed it for me:

“There were no issues with the file itself, the problem was due to the URL being re-written incorrectly because it inherited the parent .htaccess in /shop/.

After doing some research on how to override the parent .htaccess in a subdirectory, we found the solution is just to add the following line in the sub .htaccess:

RewriteOptions inherit

The URL loads successfully now.”

For clarity, “shop” is my Magento root folder.

I appreciate all the tips from everyone, and I hope this solution helps some people.

Brendon

Bravo man, That relaxed my stretching head. cheers mate

 
Magento Community Magento Community
Magento Community
Magento Community
 
zesttech
Member
 
Total Posts:  31
Joined:  2012-04-30
London, UK
 

Please try this :
Simply change the permissions of downloader/index.php from 0666 to 0644.
After that try to logout and login. Now open your website in new browser session.

 
Magento Community Magento Community
Magento Community
Magento Community
 
digidestination
Jr. Member
 
Avatar
Total Posts:  12
Joined:  2011-08-13
Cyprus
 

Thank you, This worked for me smile

jmcneil - 21 November 2008 04:55 AM

SOLVED!

This worked for me and I hope it helps someone else. This is on version 1.1.7 so not sure if this will work on any other versions.

Directory /downloader/ set to 755
file /downloader/index.php set to 644

I use Cpanel and I had password protected the directory /Magento/ so that I wouldn’t have anyone stumbling on the site while it was being developed. I removed the password protection and the ‘Magento Connect Manager’ worked.

I figured it was something really simple but, for some reason this never occurred to me.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 4 of 4