Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

403 error - forbidden
 
potterdude
Jr. Member
 
Total Posts:  3
Joined:  2011-01-16
 

I’ve just installed Magento on a shared 1 and 1 host account. All has gone fine, except that when I go to the url of my website I get a 403 forbidden error. I can see the site fine if I go to http://mysite.com/magento and am able to login to the admin area fine too.

Would this have to do with the base url setting in the install process?

I installed or unzipped Magento to my root directory on the host, although all files exist in the Magento folder on the root. Would I need to 301 redirect to the /magento folder, or is there something simpler I am missing.

Thanks,
Greg

 
Magento Community Magento Community
Magento Community
Magento Community
 
NeilA
Moderator
 
Avatar
Total Posts:  1372
Joined:  2007-09-17
Blue Mountains, Oz
 

I would suggest that since you have only just installed Magento, it would be easier to delete it and reinstall, making sure that you specify the root and not /magento as the base URL during installation.

There are other ways around this, but for your situation, I suspect this would be easier and more successful in the long run.

Regards

 
Magento Community Magento Community
Magento Community
Magento Community
 
potterdude
Jr. Member
 
Total Posts:  3
Joined:  2011-01-16
 

Problem solved - an interesting note for anyone installing on 1and1 - there are some great threads here about installing on 1 and 1 but none mention this very important element.

After many calls to support for 1 and 1, here is what finally became the solution;
First, in the setup process I uploaded the zipped Magento file to the host, and unzipped it. This installed the Magento folder to my root dir. Next, I setup my domain with 1 and 1 to point to this Magento dir., then proceeded with the rest of the install. When it came to the Base URL setting, I was able to then (and only then) use my domain as the Base URL.

Previous install attempts (there were several) would only allow me to use http://mydomain.com/magento/ as the Base URL otherwise I would get error messages and the setup would not advance - initially at the suggestion of one support rep., I tried changing the destination of the domain (in their domain settings section of their admin panel) to this Base URL after installing Magento, but for some reason this was causing the server to respond with a 500 server error. Without changing the URL destination I would get the 403 error and I was certain it was because there was no index file in the root directory.

When they finally escalated this to a second tier support and suggested I setup the domain during install I thought they were crazy, but it worked.

Thanks and hope this helps someone else,
Greg

 
Magento Community Magento Community
Magento Community
Magento Community
 
Darsh
Member
 
Total Posts:  71
Joined:  2008-06-21
 

try replacing the .htaccess file. that fixes the error at time if you are upgrading.

 
Magento Community Magento Community
Magento Community
Magento Community
 
luciehall
Jr. Member
 
Total Posts:  11
Joined:  2010-03-25
 

Dear Potter Dude,

thank you so much for posting your solution. I *FINALLY* got a magento installation working on 1and1 shared hosting, and they told me it couldn\’t be done wink

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top