Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Problème avec le .htaccess et le 90 plan
 
DesignedIn
Jr. Member
 
Total Posts:  4
Joined:  2008-10-29
 

Bonjour,

J’essaie d’installer en vain depuis cette après midi, la dernière version de Magento (1.1.6) sur mon 90 plan (OVH)

J’ai mis en en chmod 755 les dossiers suivants
/app/etc
/var
/media
/media/import

ainsi que le fichier index.html

J’ai obtenu ce message :

Magento supports PHP 5.2.0 or newer. Find out how to install Magento using PHP-CGI as a work-around.

J’ai fais des recherches sur les différents forum Magento, et j’ai vu qu’il fallait faire une modification dans le début du fichier .htaccess

en rajoutant SetEnv PHP_VER 5

Je précise que pour faire la modification, je renomme le fichier en .htaccess en htaccess.txt fait la modification avec EditPad, et le renomme après en .htaccess, j’obtiens alors ce message :

Fatal error: Call to a member function append() on a non-object in /homez.29/mondomaine/www/monrepertoire/app/code/core/Mage/Install/controllers/WizardController.php on line 72

Je précise que je cherche à faire une installation qui n’est pas à la racine de mon hébergement mais de ce type :  www.mondomaine.com/mondossier

Est ce que quelqu’un aurait une solution cela serait vraiment très sympa

Par avance, merci

 
Magento Community Magento Community
Magento Community
Magento Community
 
fredisap
Sr. Member
 
Total Posts:  88
Joined:  2008-10-20
France
 

Bonjour,
j’ai aussi fait l’nstallation de magento sur mon 90 plan ovh aujourd’hui.
j’ai effectivement rajouté :SetEnv PHP_VER 5 dans le fichier .htaccess mais je l’ai fait sans renommer le fichier en .txt
je l’ai ouvert avec notepad ++ rajouté la ligne et puis je l’ai mis dans le fichier racine de magento tel quel. et cela fonctionne si ce n’est probleme avec SSL

Par contre toi qui le mets dans www.mondomaine.com/mondossier
je crois qu’il faut que tu décommente dans le fichier .htaccess en enlevant le # devant rewriteBase et que tu remplace magento par le nom de ton dossier ce qui ferait

RewriteBase/mondossier/

############################################
## you can put here your magento root folder
## path relative to web root

#RewriteBase /magento/

############################################

A essayer.

 
Magento Community Magento Community
Magento Community
Magento Community
 
DesignedIn
Jr. Member
 
Total Posts:  4
Joined:  2008-10-29
 

Salut,

Merci pour ta réponse,

J’ai essayé en ouvrant bien avec notepad, mais cela ne change rien et cela ne fonctionne toujours pas.

Merci

 
Magento Community Magento Community
Magento Community
Magento Community
 
SeL_
Magento Team
 
Avatar
Total Posts:  1140
Joined:  2007-10-10
Paris, France
 

Et as-tu essayé le 2ème conseil de fredisap ? RewriteBase ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
DesignedIn
Jr. Member
 
Total Posts:  4
Joined:  2008-10-29
 

Oui, j’ai essayé avec le 2ème conseil et cela n’a rien changé, toujours la même message d’erreur.

Je me suis donc lancé dans un autre essai, toujours sur OVH mais cette fois si sur un 60 GP et à la racine du site, directement dans le www

Voici le détail de mon installation :

Version de Magento : 1.1.6 téléchargée ici : http://www.magentocommerce.com/download/ (Full Release)

Hebergement : OVH 60 Gp

Mise en chmod 755 les dossiers:
/app/etc
/var
/media
/media/import

index.php en 755 et .htaccess en 644

J’obtiens toujours le message suivant :

Fatal error: Call to a member function append() on a non-object in /homez.42/xxxx/www/app/code/core/Mage/Install/controllers/WizardController.php on line 72

J’ai essayé d’aller à l’installation par plusieurs chemins
www.mondomaine.com/install.php
www.mondomane.com/index.php

à chaque fois je retombe sur le message d’erreur ci-dessus et je suis “redirectionné” sur cette page
http://www.mondomaine.com/index.php/install/

Je vous montre le contenu de mon .htaccess

J’ai également essayé sans le # OVH et sans le SetEnv REGISTER_GLOBALS 0, le résultat est identique

# OVH
SetEnv REGISTER_GLOBALS 0
SetEnv PHP_VER 5 

############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi

#    Action php5-cgi /cgi-bin/php5-cgi
#    AddHandler php5-cgi .php

############################################
## GoDaddy specific options

#   Options -MultiViews

## you might also need to add this line to php.ini
##     cgi.fix_pathinfo = 1
## if it still doesn't work, rename php.ini to php5.ini

############################################
## this line is specific for 1and1 hosting

    #AddType x-mapp-php5 .php
    #AddHandler x-mapp-php5 .php

############################################
## default index file

    
DirectoryIndex index.php

<IfModule mod_php5.c>

############################################
## adjust memory limit

#    php_value memory_limit 64M
    
php_value memory_limit 128M
    php_value max_execution_time 18000

############################################
## disable magic quotes for php request vars

    
php_flag magic_quotes_gpc off

############################################
## disable automatic session start
## before autoload was initialized

    
php_flag session.auto_start off

############################################
## enable resulting html compression

    #php_flag zlib.output_compression on

###########################################
# disable user agent verification to not break multiple image upload

    
php_flag suhosin.session.cryptua off
    
###########################################
# turn off compatibility with PHP4 when dealing with objects
    
    
php_flag zend.ze1_compatibility_mode Off

</IfModule>

<
IfModule mod_security.c>
###########################################
# disable POST processing to not break multiple image upload

    
SecFilterEngine Off
    SecFilterScanPOST Off
</IfModule>

<
IfModule mod_deflate.c>

############################################
## enable apache served files compression
## http://developer.yahoo.com/performance/rules.html#gzip

    # Insert filter
    #SetOutputFilter DEFLATE

    # Netscape 4.x has some problems...
    #BrowserMatch ^Mozilla/4 gzip-only-text/html

    # Netscape 4.06-4.08 have some more problems
    #BrowserMatch ^Mozilla/4\.0[678] no-gzip

    # MSIE masquerades as Netscape, but it is fine
    #BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
    # Don't compress images
    #SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary

    # Make sure proxies don't deliver the wrong content
    #Header append Vary User-Agent env=!dont-vary

</IfModule>

<
IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

    
SSLOptions StdEnvVars

</IfModule>

<
IfModule mod_rewrite.c>

############################################
## enable rewrites

    
Options +FollowSymLinks
    RewriteEngine on

############################################

## you can put here your magento root folder
## path relative to web root

#RewriteBase /magento/ 

############################################
## workaround for HTTP authorization
## in CGI environment

    
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## always send 404 on missing files in these folders

    
RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

    
RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond 
%{REQUEST_FILENAME} !-d
    RewriteCond 
%{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

    
RewriteRule .* index.php [L]

</IfModule>


############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead

    
AddDefaultCharset Off
    
#AddDefaultCharset UTF-8

<IfModule mod_expires.c>

############################################
## Add default Expires header
## http://developer.yahoo.com/performance/rules.html#expires

    
ExpiresDefault "access plus 1 year"

</IfModule>

############################################
## By default allow all access

    
Order allow,deny
    Allow from all

############################################
## If running in cluster environment, uncomment this
## http://developer.yahoo.com/performance/rules.html#etags

    #FileETag none

j’ai fais un autre essai en le plaçant à ce niveau la du code et la je retombe sur Magento supports PHP 5.2.0 or newer. Find out how to install Magento using PHP-CGI as a work-around.

#    Action php5-cgi /cgi-bin/php5-cgi
#    AddHandler php5-cgi .php
#    SetEnv PHP_VER 5

Merci pour votre aide

 
Magento Community Magento Community
Magento Community
Magento Community
 
fredisap
Sr. Member
 
Total Posts:  88
Joined:  2008-10-20
France
 

A piori je crois que tu n’as pas fais ce que je te disais dans mon 2eme conseil
je vois sur ton fichier .htaccess toujours

############################################

## you can put here your magento root folder
## path relative to web root

#RewriteBase /magento/ 

############################################
au lieu de :
############################################

## you can put here your magento root folder
## path relative to web root

RewriteBase /le nom de ton dossier

############################################
 
Magento Community Magento Community
Magento Community
Magento Community
 
DesignedIn
Jr. Member
 
Total Posts:  4
Joined:  2008-10-29
 

Salut,

En fait j’ai fais ta manip sur le 90 plan lorsque je tentais de l’installer dans un dossier (www.monsite/dossier)

La le fichier .htaccess est celui que j’essaie d’installer sur un 60 GP directement dans le www smile

Merci

 
Magento Community Magento Community
Magento Community
Magento Community
 
Fibo
Sr. Member
 
Avatar
Total Posts:  107
Joined:  2008-06-25
Marseille, France
 

euh… pourquoi
SetEnv REGISTER_GLOBALS 0
??
Moi je n’ai jamais mis cela et cela marche. (dire “bien” serait faire croire à des pereformances hélàs absentes)

 
Magento Community Magento Community
Magento Community
Magento Community
 
crxman
Member
 
Total Posts:  57
Joined:  2008-11-14
 

Hello Fibo, j’ai eu le meme problème c’est ton fichier .htaccess qui va pas reprend l’original, fait tes modifs pour OVH et ca va marcher.

Moi j’ai meme tout re-uploader pour etre sur.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top