Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 2 of 2
exception ‘Exception’ with message ‘PayPal IPN postback failure. See paypal_unknown_ipn.log for details.’ in /app/code/core/Mage/Paypal/Model/Ipn.php: 
 
Erfan_DHM
Jr. Member
 
Total Posts:  2
Joined:  2012-06-17
 

I’ve wrote an article about curl adding a “expect: 100” field to the postback request-header and the fix for it:

http://www.dhmedia.com.au/blog/debugging-paypal-ipn-postback-failure-magento

 
Magento Community Magento Community
Magento Community
Magento Community
 
Peppermay
Sr. Member
 
Avatar
Total Posts:  111
Joined:  2008-10-18
Lille, France
 

Great investigation Job Erfan !
If this does the trick, it’ll be a big thorn out of my foot !

 
Magento Community Magento Community
Magento Community
Magento Community
 
o0kawa0o
Jr. Member
 
Total Posts:  2
Joined:  2012-01-18
 
barnyshergold - 29 January 2013 03:37 AM

I\’ve just found out another reason why you get IPN failures on Magento 1.7+

If you are using Website Payments Standard and your site DOES NOT use SSL. Make sure the Advanced Option : Enable SSL verification is set to NO.

Barny

THANX!!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Radioguide
Member
 
Total Posts:  70
Joined:  2012-05-15
 

I\’ve just found out another reason why you get IPN failures on Magento 1.7+

If you are using Website Payments Standard and your site DOES NOT use SSL. Make sure the Advanced Option : Enable SSL verification is set to NO.

Barny

Thanks Barny, this worked for me too!  We spent HOURS troubleshooting this issue, with neither Siteground (our hosts) Paypal, or our developer finding this solution, but as soon as we applied this simple change the IPN starting working correctly!  Happy Days - until the next problem arises!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 2 of 2