Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 4
Import Field Mapping category_ids missing after upgrading to Magento
 
Darsh
Member
 
Total Posts:  71
Joined:  2008-06-21
 

I cannot map category_ids in magento import profile after upgrading to 1.4.2.0?

See attached screen shot, cannot assign categories to products during import.

Even when I try to run it in advance export. It just give a blank page with navigation bar.

I searched an search cannot find any bugs or threads in the forum.

All I found was. http://magentoexpert.com/what-happened-with-category_ids-in-magento-1-4-2/

Image Attachments
2011-01-09_1823.png
 
Magento Community Magento Community
Magento Community
Magento Community
 
Darsh
Member
 
Total Posts:  71
Joined:  2008-06-21
 

Am I the only one facing this issue ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
crxman
Member
 
Total Posts:  57
Joined:  2008-11-14
 

Got this issue also, try to do some changes in your existing categories (Catalog > Manage Categories) , in my case I get an error :

Fatal error: Call to a member function getAttributeCode() on a non-object in /home/iphigento/domains/iphigento.com/public_html/app/code/core/Mage/Adminhtml/Block/Catalog/Category/Tab/Attributes.php on line 137

 
Magento Community Magento Community
Magento Community
Magento Community
 
Darsh
Member
 
Total Posts:  71
Joined:  2008-06-21
 

I got a similar error when I tried to use magento store manager utility

Error Message “Attributes “Categories Path” were not found in attribute set Default”

Is there a way I can do a roll back to previous version ? Everything seem to be working fine until after the upgrade to 1.4.2.0

 
Magento Community Magento Community
Magento Community
Magento Community
 
Darsh
Member
 
Total Posts:  71
Joined:  2008-06-21
 
crxman - 11 January 2011 09:54 PM

Got this issue also, try to do some changes in your existing categories (Catalog > Manage Categories) , in my case I get an error :

Fatal error: Call to a member function getAttributeCode() on a non-object in /home/iphigento/domains/iphigento.com/public_html/app/code/core/Mage/Adminhtml/Block/Catalog/Category/Tab/Attributes.php on line 137

What kind of changes are your referring to ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Brent W Peterson
Moderator
 
Avatar
Total Posts:  3217
Joined:  2009-02-26
Minneapolis MN
 

What version did you upgrade from? There are significant Category differences between 1.3 and 1.4

 
Magento Community Magento Community
Magento Community
Magento Community
 
Darsh
Member
 
Total Posts:  71
Joined:  2008-06-21
 
Brent W Peterson - 12 January 2011 05:59 AM

What version did you upgrade from? There are significant Category differences between 1.3 and 1.4

I frequently upgrade when ever a notification is shown for any stable releases. Not sure but seems like i did upgrade from 1.3 to 1.4

Is there a fix that I can try ?

I am looking at the release log and i can see a quiet of issues around category_ids attribute.

Example.
Fixed Redundant catalog product attribute “category_ids” remains during upgrade from 1.3 to 1.4

But everything around categories seems to work fine > i can add remove sort. assign - un-assign products manually. (one by one)

It’s just that I cant use data-flow to assign categories to products. Which is a big inconvenience since i have a about 2000+ product scheduled to go live on the site.

Thanks for any help in advance.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Darsh
Member
 
Total Posts:  71
Joined:  2008-06-21
 

Any solutions out there ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Darsh
Member
 
Total Posts:  71
Joined:  2008-06-21
 

Magento removing the field “category_ids” from catalog_product_entity table in version 1.4

I this the reason why category_ids dont show in import/export field mapping ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Brent W Peterson
Moderator
 
Avatar
Total Posts:  3217
Joined:  2009-02-26
Minneapolis MN
 

Are you using Flat Products? I am sure the categories get exported then.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Rhonda_Rondeau
Enthusiast
 
Total Posts:  924
Joined:  2010-08-03
Culver City
 

Hi Guys,

I\’m looking into this issue as well.

Another person has confirmed that this is an issue right out of the box with 1.4.2 as well so not only upgrades are affected.

He\’s currently trying to use advance profiles for the import to see if he can work around it.

Rhonda

 
Magento Community Magento Community
Magento Community
Magento Community
 
Darsh
Member
 
Total Posts:  71
Joined:  2008-06-21
 

Finally its the weekend and now I have some time to look into this issue.

First off I tried to search the database for term “category_ids”
The only hits I got were tables named dataflow_batch*
----------------------------------------------------------------------------------------------

So I decided to do a fresh install and check if i get different results.

Also when I tried to do the fresh install using the downloader I kept on getting Pear version Errors such as
pear/Console_Getopt requires PEAR Installer (version >= 1.9.1), installed version is 1.7.1
pear/PEAR requires package “pear/Console_Getopt” (recommended version 1.2.3)

Luckily I found a solution.

For all the users having the same error you will need to update pear in the user account. If you use Cpanel and have access to ssh

go to

cd home/username/public_html

Run the following

./pear mage-setup

./pear channel-update pear.php.net
./pear upgrade --force PEAR

If fails run the above code again
after successful update run the following in ssh

./pear install magento-core/Mage_All_Latest-stable

Go back to the install URL. and proceed with the rest of the install.
You might get a permission error just navigate to the location and use chmod 777 *
------------------------------------------------------------------------

Now returning back to my issue.

After a freshinstall on a different domain, I still dont see an option to map category_ids. (screen shot attached)

Also I did a full search on the fresh install database for the term “category_ids” result was “Total: 0 match(es)”

Has Magento made a big boo boo or this was removed from import/export on purpose ? Because there is a lot of talk about how category tables have changed after 1.4.0

Anyone know the ETA on 1.5.0 release ? Is magento working on this?
I have logged a bug here. http://www.magentocommerce.com/bug-tracking/issue?issue=10662

Sorry for the long reply.

Image Attachments
category_ids_new_install.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
Darsh
Member
 
Total Posts:  71
Joined:  2008-06-21
 
rondata - 15 January 2011 07:53 AM

Hi Guys,

I\’m looking into this issue as well.

Another person has confirmed that this is an issue right out of the box with 1.4.2 as well so not only upgrades are affected.

He\’s currently trying to use advance profiles for the import to see if he can work around it.

Rhonda

I already tried that route.

I just gives a blank screen with Nav.

Image Attachments
2011-01-15_1049.png
 
Magento Community Magento Community
Magento Community
Magento Community
 
Rhonda_Rondeau
Enthusiast
 
Total Posts:  924
Joined:  2010-08-03
Culver City
 

Yes that was the results on his end as well.

Being the w/e—there’s not much I can do about this but I’ll escalate Monday AM and see what’s going on. I’m sure they’re aware of it because the issue is in the bug tracker.

Rhonda

 
Magento Community Magento Community
Magento Community
Magento Community
 
Darsh
Member
 
Total Posts:  71
Joined:  2008-06-21
 
rondata - 15 January 2011 12:58 PM

Yes that was the results on his end as well.

Being the w/e—there’s not much I can do about this but I’ll escalate Monday AM and see what’s going on. I’m sure they’re aware of it because the issue is in the bug tracker.

Rhonda

Thanks Rhonda. enjoy the weekend.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Rhonda_Rondeau
Enthusiast
 
Total Posts:  924
Joined:  2010-08-03
Culver City
 
Darsh - 15 January 2011 07:13 PM

rondata - 15 January 2011 12:58 PM
Yes that was the results on his end as well.

Being the w/e—there’s not much I can do about this but I’ll escalate Monday AM and see what’s going on. I’m sure they’re aware of it because the issue is in the bug tracker.

Rhonda

Thanks Rhonda. enjoy the weekend.

It’s all good.. smile I’ll do my best to get you info as soon as I can.
please............... feel free to contact me directly rhonda(at) magento dot com

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 4