Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Upgrade incomplete (no include_in_menu)
 
workingprocesses
Jr. Member
 
Total Posts:  8
Joined:  2009-03-31
 

After upgrading from 1.1.7 to 1.4.2.0, no categories are shown (e.g. in the main menu). After trying the ‘normal’ solutions without any success, I discovered finally that the Manage Categories screen has been changed. Included are the new 1.4.2.0 demo screen and the screen that I’m having after the upgrade.

Question: How do I upgrade to the new screen (and I guess also database files), including the ‘Choose Store View’ and ‘Include in Navigation Menu’? Moreover, the Optimization tab seems to be removed.

For the rest, the upgrade seems to work fine.

Thanks for any answer!
IJme

Image Attachments
M2.jpgM1.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
workingprocesses
Jr. Member
 
Total Posts:  8
Joined:  2009-03-31
 

Started from scratch again. Upgraded first to 1.3.2.4. No problem. Then upgraded to 1.4.1.1. Lots of problems. Manually changed a lot of sql upgrade files, because of existing or non-existing tables. And solved some other things (such as a wrong spelling of a column ‘synomim’ in one version instead of ‘synonym’.
But now everything is working fine: menu items, products, customers, sales statistics, etc. etc..
This issue can therefore be closed! grin

 
Magento Community Magento Community
Magento Community
Magento Community
 
pgulikers
Jr. Member
 
Total Posts:  27
Joined:  2009-02-21
 

I\’ve got the same issue as TS now. Upgraded from 1.3.2.4 -> 1.4.0 -> 1.4.1.1 -> 1.4.2.

The Include in Navigation menu attribute is not visible on the edit category form. I noticed that the eav_attribute was missing in table catalog_eav_attribute but manually adding the attribute didn\’t solve the problems. Every category has the attribute-value false so no nav-menu is showing at all.

I also used de DBRepair tool on a working 1.4.2 site but that didn\’t help. The structure of the DB is o.k. and at version 1.4.2.
Turned flat catalog category off but no success!

I guess some tables in the DB are missing some entries but which ones??

 
Magento Community Magento Community
Magento Community
Magento Community
 
pgulikers
Jr. Member
 
Total Posts:  27
Joined:  2009-02-21
 

SOLVED!

1. in table eav_attribute insert a new row:
attribute_id 540 <-- can be different in your setup
entity_type_id 3
attribute_code include_in_menu
attribute_model null
backend_model <empty>
backend_type int
backend_table <empty>
frontend_model <empty>
frontend_input select
frontend_label Include in Navigation Menu
frontend_class <empty>
source_model eav/entity_attribute_source_boolean
is_required 1 <-- !important
is_user_defined 0
default_value 1
is_unique 0
note <empty>

2. in table eav_entity_attribute insert a new row:
entity_attribute_id 2880 <-- can be different in your setup
entity_type_id 3
attribute_set_id 3
attribute_group_id 3
attribute_id 540 <-- can be different in your setup
sort_order 10

3. in table catalog_eav_attribute insert a new row:
attribute_id 540 <-- can be different in your setup
frontend_input_renderer <empty>
is_global 0
is_visible 1
is_searchable 0
is_filterable 0
is_comparable 0
is_visible_on_front 0
is_html_allowed_on_front 0
is_used_for_price_rules 1
is_filterable_in_search 0
used_in_product_listing 0
used_for_sort_by 0
is_configurable 1
apply_to <empty>
is_visible_in_advanced_search 0
position 0
is_wysiwyg_enabled 0
is_used_for_promo_rules 1

You should be good to go now, just remember to set the option to Yes for the categories you want to have displayed in the nav-menu! (can be done with SQL-statement UPDATE `catalog_category_flat_store_1` set `include_in_menu` = 1 if using flat_categories)

Reindex all indexers

 
Magento Community Magento Community
Magento Community
Magento Community
 
manuelopen
Jr. Member
 
Total Posts:  5
Joined:  2012-05-04
 

thanks for this great sollution. If you dont use flat tables use this mysql to Update all catagories to be active:

INSERT INTO catalog_category_entity_int SELECT NULL35400entity_id1 FROM ssh_catalog_category_entity

Like the post bevore the 540 can be different in your setup

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top