Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 16 of 16
usps api not working
 
LUKA netconsult
Member
 
Avatar
Total Posts:  40
Joined:  2008-04-29
Frankfurt am Main (DE)
 
veracious - 24 February 2011 12:03 AM

Extract and upload this patch to the root of your site: see attachment.

It seem that the zip file is broken. I’m unable to open it.
Can confirm the zip file extractable?

Could someone who has a working copy please re upload it?

Thanks in advance.

 
Magento Community Magento Community
Magento Community
Magento Community
 
b0morris
Jr. Member
 
Total Posts:  1
Joined:  2011-04-27
 

For anyone else having issues with the error: API Authorization failure. RateV3 is not a valid API name for this protocol.

I just let USPS know that I was using Magento for these calls and was getting this error and they promoted my account to production. The calls then started working against the insecure URL: http://production.shippingapis.com/ShippingAPI.dll (but not the secure one).

I guess they only have version 4 of the API on their test environment. *shrug*

 
Magento Community Magento Community
Magento Community
Magento Community
 
LUKA netconsult
Member
 
Avatar
Total Posts:  40
Joined:  2008-04-29
Frankfurt am Main (DE)
 

Since nobody responded here until now, we have implemented a hotfix module by following the community suggestions.
This was tested with Magento version 1.3.2.4.
Just extract the attached zip file to your Magento root directory.

This is implemented the upgrade save way - no core files are overwritten or modified.
To remove the module delete the folder app/code/local/LUKA/UspsHotfix and the file LUKA_UspsHotfix.xml from app/etc/modules.

File Attachments
usps-hotfix.zip  (File Size: 5KB - Downloads: 205)
 
Magento Community Magento Community
Magento Community
Magento Community
 
mrmeech
Member
 
Total Posts:  58
Joined:  2008-11-07
New York City, USA
 
b0morris - 20 June 2011 02:32 PM

For anyone else having issues with the error: API Authorization failure. RateV3 is not a valid API name for this protocol.

I just let USPS know that I was using Magento for these calls and was getting this error and they promoted my account to production. The calls then started working against the insecure URL: http://production.shippingapis.com/ShippingAPI.dll (but not the secure one).

I guess they only have version 4 of the API on their test environment. *shrug*

Was having the same issue here. I spoke with USPS today and can also confirm that v3 is NOT compatible with the secure API address ( https://secure.shippingapis.com/ShippingAPI.dll ). The lady helping me said that the nonsecure api address ( http://production.shippingapis.com/ShippingAPI.dll ) is the only one that will take V3 requests and that they do not have an alternate secure v3 address. Using the non-secure address on 1.5.1.0 is returning shipping quotes properly.

 
Magento Community Magento Community
Magento Community
Magento Community
 
webmaster22
Jr. Member
 
Total Posts:  18
Joined:  2011-07-27
 

Not sure if this fix has been posted, but I don’t want to search 16 pages to find out.

-Get username and pass from USPS.
-Immediately request access to the production server.
-If you tell them you are using magento, they will likely give you an response as follows.

1. The Production Server URL is: http://production.shippingapis.com. For APIs calling the secure server, the URL is https://secure.shippingapis.com.
2. There is a line of code that refers to “shippingapitest.dll”. You’ll need to remove the word “test”.

Bothe URL’s are incorrect, you will need a hybrid of both:

http://production.shippingapis.com/ShippingAPI.dll

After fighting this for days, this url worked like a charm.

FYI, some shipping methods will only show under specific weight limits.  I would suggest making a test product with only a 1 oz wight to verify the api is working correctly. 

Remember to use the user id in the email sent from USPS, not the one you created on the main USPS website.

 
Magento Community Magento Community
Magento Community
Magento Community
 
webmaster22
Jr. Member
 
Total Posts:  18
Joined:  2011-07-27
 

Works on 1.5.0.1

Col_Potter - 23 August 2011 01:24 PM

Not sure if this fix has been posted, but I don’t want to search 16 pages to find out.

-Get username and pass from USPS.
-Immediately request access to the production server.
-If you tell them you are using magento, they will likely give you an response as follows.

1. The Production Server URL is: http://production.shippingapis.com. For APIs calling the secure server, the URL is https://secure.shippingapis.com.
2. There is a line of code that refers to “shippingapitest.dll”. You’ll need to remove the word “test”.

Bothe URL’s are incorrect, you will need a hybrid of both:

http://production.shippingapis.com/ShippingAPI.dll

After fighting this for days, this url worked like a charm.

FYI, some shipping methods will only show under specific weight limits.  I would suggest making a test product with only a 1 oz wight to verify the api is working correctly. 

Remember to use the user id in the email sent from USPS, not the one you created on the main USPS website.

 
Magento Community Magento Community
Magento Community
Magento Community
 
fredmw
Jr. Member
 
Total Posts:  1
Joined:  2011-08-30
 

I struggled with this for some time, and finally got it to work. In ‘Shipping Settings’, MAKE SURE YOU SHIPPING ZIP CODE IS 5 DIGITS ONLY! It doesn’t work with the nine digit version!

 
Magento Community Magento Community
Magento Community
Magento Community
 
outsourcedEDM
Member
 
Total Posts:  44
Joined:  2011-06-17
 

Hi All,

Has anyone actually got this resolved on V1.5.1? I’ve got all the code mentioned in here as listed, it seems i even have the right responses back from the API - here’s the extract of the log file..

<Service ID="15">
    <
Pounds>3</Pounds>
    <
Ounces>0</Ounces>
    <
MailType>Package</MailType>
    <
Country>AUSTRALIA</Country>
    <
Postage>25.71</Postage>
    <
ValueOfContents>15.00</ValueOfContents>
    <
InsComment>SERVICE</InsComment>
    <
SvcCommitments>Varies by destination</SvcCommitments>
    <
SvcDescription>First-Class Mail&amp;lt;sup&amp;gt;&amp;amp;reg;&amp;lt;/sup&amp;gtInternational Package**</SvcDescription>
    <
MaxDimensions>Other than rollsMaxlength 24", max length, height and depth (thickness) combined 36"<br>RollsMaxlength 36". Max length and twice the diameter combined 42"</MaxDimensions>
    <
MaxWeight>4</MaxWeight>
    </
Service>
<
Service ID="14">
    <
Pounds>3</Pounds>
    <
Ounces>0</Ounces>
    <
MailType>Package</MailType>
    <
Country>AUSTRALIA</Country>
    <
Postage>25.29</Postage>
    <
ValueOfContents>15.00</ValueOfContents>
    <
InsComment>SERVICE</InsComment>
    <
SvcCommitments>Varies by destination</SvcCommitments>
    <
SvcDescription>First-Class Mail&amp;lt;sup&amp;gt;&amp;amp;reg;&amp;lt;/sup&amp;gtInternational Large Envelope**</SvcDescription>
    <
MaxDimensions>Maxlength 15", height 12" or thickness 3/4"</MaxDimensions>
    <MaxWeight>4</MaxWeight>
</Service>
but these two shipping methods don’t display anywhere on the front end? Hopefully someone’s seen this before in the (many many) quests to fix this..

adam.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 16 of 16