Magento Forum

   
Authorize.net payment enabled, not showing on checkout
 
Electronics
Jr. Member
 
Total Posts:  1
Joined:  2010-12-26
 

Hi I’m hoping someone can help me:

1. Site is configured with USD for currency
2. Enabled Authorize.net, filling out all required fields
3. One page check out is disabled, but I’ve tried both enabled and disabled
4. In checkout, Authorize.net is not an option, currently only paypal

I’ve been googling this issue and came upon this link but it’s not the same issue:
http://blog.chapagain.com.np/magento-authorize-net-not-displayed-in-payment-information-section-while-checkout/

Anyone encountered this before?

 
Magento Community Magento Community
Magento Community
Magento Community
 
orangeaura
Jr. Member
 
Avatar
Total Posts:  4
Joined:  2011-01-07
San Francisco, CA
 

So you have authorize.net enabled in System > Configuration > Payment Methods and it does not show up in checkout?

You could try going to System > Advanced > Advanced and check if all the modules that are needed are enabled.

 
Magento Community Magento Community
Magento Community
Magento Community
 
hannly
Jr. Member
 
Total Posts:  1
Joined:  2011-01-19
 

I agree with orangeaura !

 
Magento Community Magento Community
Magento Community
Magento Community
 
paddle74
Jr. Member
 
Total Posts:  28
Joined:  2008-02-28
 

Same issue.  I have tried and double checked and searched for a solution and still nothing?

I made sure everything is enabled is System >> Advanced.

Every other payment method displays fine (in the front-end) when I enable and disable.  ‘Credit Card (autherize.net) NEVER shows up as an options?

HELP and suggestions? PLEASE!!

I am pulling my hair out.

Image Attachments
Configuration  System  Magento Admin - Mozilla Firefox 7222011 112059 AM.jpgCheckout - Mozilla Firefox 7222011 111957 AM.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
PierMarketing
Sr. Member
 
Total Posts:  77
Joined:  2008-02-20
 

Did anyone figure this out?  I am having the same issue.  Please help!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Vampal
Member
 
Avatar
Total Posts:  37
Joined:  2011-10-16
 

tried but not work

orangeaura - 15 January 2011 09:35 PM

So you have authorize.net enabled in System > Configuration > Payment Methods and it does not show up in checkout?

You could try going to System > Advanced > Advanced and check if all the modules that are needed are enabled.

 
Magento Community Magento Community
Magento Community
Magento Community
 
MahdiMontgomery
Jr. Member
 
Total Posts:  21
Joined:  2011-08-17
 

Well I fixed my problem, and I feel like a proper idiot once I figured it out.

For me at least, I had to \"Disable Payment Filter Extension\” (and extension I had forgot I installed), because I never added my payment options to the customer groups. Slapped myself for that one.

 
Magento Community Magento Community
Magento Community
Magento Community
 
lugobox
Member
 
Total Posts:  61
Joined:  2010-12-14
 

Check the currency set up, on your site and on authorize.net should be the same

 
Magento Community Magento Community
Magento Community
Magento Community
 
LeroyWhite
Member
 
Total Posts:  36
Joined:  2009-02-25
 

In System > Configuration > Advanced > Advanced, make sure that BOTH Mage_Authorizenet AND Mage_Paygate are enabled. fixed it for me!

 
Magento Community Magento Community
Magento Community
Magento Community
 
CoastAMS
Member
 
Avatar
Total Posts:  57
Joined:  2011-03-24
Bath
 

Currency issue fixed it for us.

 
Magento Community Magento Community
Magento Community
Magento Community
 
gbstack
Jr. Member
 
Total Posts:  2
Joined:  2011-08-30
 

There’re mainly two reasons:
1. Mage_Payment and Mage_Authorizenet module output is disabled
2. Magento currency is not same as Authorize.net currency

Here are the concrete steps in this post: Authorize.net payment method not showing in Magento checkout page

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top