Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Blank screen when editing or creating attributes
 
Eli Van Zoeren
Jr. Member
 
Total Posts:  6
Joined:  2009-04-07
 

Since I updated our site to v1.4.2 (from 1.4.1.1) I can no longer create or edit attributes. I can see the list of attributes just fine, but when I click on one, or on the “Add New Attribute” button, I get a completely blank screen. Viewing source shows that absolutely nothing is coming through.

Any idea what would cause this or how to fix it? Is there a way to turn on error-reporting in the admin area? I have spent quite a bit of time now trying things and searching online, with no luck. Any help would be much appreciated.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ubunter
Sr. Member
 
Avatar
Total Posts:  104
Joined:  2010-05-05
Madrid
 

Permission issue, check your permissions if all it\’s ok, the system are refusing that you edit files for permission missing, and for this you get an empty page…
Regards,

Sam

 
Magento Community Magento Community
Magento Community
Magento Community
 
Eli Van Zoeren
Jr. Member
 
Total Posts:  6
Joined:  2009-04-07
 

Any idea which files would cause that? I’ve checked all the files I could find related to “attributes”, but it still doesn’t work. I’ve also reinstalled everything through Magento Connect, which I should think would fix the permissions....

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ubunter
Sr. Member
 
Avatar
Total Posts:  104
Joined:  2010-05-05
Madrid
 

Hello,
Magento Attributes are stored in the DataBase, not in files, so that you get empty could be caused by Database connection error, but in this case, you should get a php error, or that the file which should call for the DB have no permission.

So, let’s do the following.

Stop your database, and reboot entirely your server, after rebooting, check if the DB have been started correctly, just restart it.

Go to repeat what you was doing, if it’s work, ok, if not, let’s follow.

elevate the permissions to maximum, opening completely the sources security, so make chmod 777 -R entirely above your magento root directory.. then log out, and login again in your back-end, and repeat what do you was doing. It should work.

If yes, DON’T forget to fix again your permissions, files in 644 and directories in 755, it’s very important and highly risky to let your root directory in 777, we did it only for testing…

I hope it’s work, enjoy…

Regards,
Sam

 
Magento Community Magento Community
Magento Community
Magento Community
 
Eli Van Zoeren
Jr. Member
 
Total Posts:  6
Joined:  2009-04-07
 

I’ve just tried all those things, no luck. I don’t think it’s a database issue, as the rest of the site--front- and back-ends--works correctly. It’s just the Attributes creation and editing. I tried it with everything set to 777 permissions and then after reseting them to the default permissions with the Magento Cleanup Too....neither one worked.

Anyone have any other ideas? This is driving me crazy.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ubunter
Sr. Member
 
Avatar
Total Posts:  104
Joined:  2010-05-05
Madrid
 

Hi,
We’re dealing in 2 or 3 installation per day, I never heard about such as issue, unless you have a modules conflict. Do you have any module who could have relation with attributes? try to deactivate all your modules, and retry, I can’t guess another possibility unless you wait for somebody else more intelegent then us, maybe to help you..
Regards,

Sam

 
Magento Community Magento Community
Magento Community
Magento Community
 
Eli Van Zoeren
Jr. Member
 
Total Posts:  6
Joined:  2009-04-07
 

I did try disabling all my installed modules, also with no luck. I’ve never seen this before, either, and can’t find any reports of it online. I must just be especially unlucky.... :(

Thanks for all your help, maybe someone else will have another idea.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ubunter
Sr. Member
 
Avatar
Total Posts:  104
Joined:  2010-05-05
Madrid
 

The last what would I do is to reinstall the whole magento in a new directory, using fresh and genuine sources, I forgot to ask you if you install it from sources or using any cpanel, or else, reinstall flashing the DataBase, and check in the new installation if all it’s ok, but only the magento, without any module, using the old database, and compare…

Regards,

Sam.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Bit 32
Jr. Member
 
Total Posts:  16
Joined:  2010-09-23
 

having the same issue after upgrading to 1.4.2.

did you find a solution?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Bit 32
Jr. Member
 
Total Posts:  16
Joined:  2010-09-23
 

Upgraded to Magento 1.5 (done by replacing the entire file structure via ftp) and this fixed the issue for me.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ruud Schoorl
Jr. Member
 
Total Posts:  7
Joined:  2010-07-27
IJmuiden, The Netherlands
 

You don’t need to upgrade to Magento 1.5.

it seems to me that you are just missing some files. I’ve fixed the same issue a few minutes ago.
if you want some help, please contact me!

regards,
Ruud

 
Magento Community Magento Community
Magento Community
Magento Community
 
rickxxxg
Jr. Member
 
Total Posts:  1
Joined:  2011-01-15
 

on your FTP Root Folder edit the file php.ini

Increased memory_limit = 128M ----->>> was 64M

max_execution_time = 2400 ------------->>>> was 30

cool mad

 
Magento Community Magento Community
Magento Community
Magento Community
 
Josh @ WebShopApps
Jr. Member
 
Avatar
Total Posts:  17
Joined:  2010-05-28
Leigh on Sea, Essex
 

I know this is an old thread so apologies but just saw the same issue on a customer site.

There was an extension under app/code/local/MagExt/MgxTips which was rewriting the files responsible for displaying the edit attributes panel under app/code/core/Mage/Adminhtml/Block/Catalog/Product/Attribute/Edit.

Problem was the rewrite files were missing and/or corrupt. I disabled that extension and now can see the edit panel just fine.

Hope this helps someone.

 
Magento Community Magento Community
Magento Community
Magento Community
 
vtrade
Jr. Member
 
Total Posts:  1
Joined:  2011-07-27
 

This is a old thread but posting this, thinking if this could be useful for someone. I used magento 1.6 when this issue occured.

I had this issue and followed all the steps above but didnot resolve the blank screen on attribute edit page. I restored all the files from one of the backups that I had prior to installation of the extension didnot help either. This issue was caused due to one of the extensions that was installed “Customer Partner”. When I restored my backup tables specific for products, categories it fixed it.

Probably there was a conflict between “Customer Partner” extension and SEO layered navigation . 
I ended up deleting the “Customer Partner” because it made my SEO layered navigation not to work.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top