Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Modern theme, need a bit of help! 
 
QWERTY Computers
Jr. Member
 
Total Posts:  9
Joined:  2008-10-05
Halifax, West Yorkshire
 

I’ve been setting up my store for a couple of weeks, and is ready to launch later this week hopefully.

I’ve hit a problem with the main page on the modern theme. Like the default template it has 3 images (one left, two right.) (I followed this thread so it showed up on the home page: http://www.magentocommerce.com/boards/viewthread/10214/ )

I want to make the pictures clickable, so they will take people to different pages in my magento store but I cant find anything to edit so I can do this! I located the home.phtml file but there is nothing to edit.

Its probably something simple to do, but my friend who usually helps me with things like this is away on holiday so I’m stuck.

If anyone can help I’d be very grateful.

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
Voot
Sr. Member
 
Total Posts:  261
Joined:  2008-03-20
Long Beach, CA
 

Turn on template paths and it will tell you where the files to edit are located. To do this first turn off Cache, then go to System > Confniguration and change “Configuration Current Scope” to Main Website. Then scroll all the way down and click on Developer, under Debug Change Template Path Hints to Yes. Hope this helps!

 
Magento Community Magento Community
Magento Community
Magento Community
 
QWERTY Computers
Jr. Member
 
Total Posts:  9
Joined:  2008-10-05
Halifax, West Yorkshire
 

Found and sorted it now, thanks very much Vutha for the help

 
Magento Community Magento Community
Magento Community
Magento Community
 
QWERTY Computers
Jr. Member
 
Total Posts:  9
Joined:  2008-10-05
Halifax, West Yorkshire
 

Just hit a small bump, I’ve edited the home.phtml page and made 2 of the pictures clickable. It all looks good in firefox but then I open up IE to load up the page and the pictures have just disappeared.

This is what is in the home.phtml file at the moment:

<div style="width:653px; float:left;">
  <
a href="http://www.qwertypcservices.com/why-qwerty"<img src="<?php echo $this->getSkinUrl('images/media/home_co_main.jpg');?>" alt="" style="display:block;" /></a></div>
<
div style="width:280px; float:right;">
  <
img src="<?php echo $this->getSkinUrl('images/media/home_co_tr.gif');?>" alt="" style="display:block; margin-bottom:10px;" />
  <
a href="http://www.qwertypcservices.com/why-qwerty"<img src="<?php echo $this->getSkinUrl('images/media/home_co_br.gif');?>" alt="" style="display:block;" /></a>
</
div>
<
div class="clear"></div>
<
img src="<?php echo $this->getSkinUrl('images/media/home_co_bottom.gif');?>" alt="" style="margin-top:10px; display:block;" />
 
Magento Community Magento Community
Magento Community
Magento Community
 
QWERTY Computers
Jr. Member
 
Total Posts:  9
Joined:  2008-10-05
Halifax, West Yorkshire
 

Managed to solve the problem now, finally!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top