Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Cybersource Payment Extension: Unable To Process Order
 
leetaylordoes
Sr. Member
 
Total Posts:  227
Joined:  2008-02-05
San Diego, CA
 

Hi All,

We are having an urgent issue with the Cybersource extension and after having installed and configured everything correctly, we continue to get an error stating the payment is unable to get processed.

Around line 331 of SOAP.php (app/code/core/Mage/Cybersource/Model/SOAP.php) an error continues to get thrown stating:

"There is an error in processing payment. Please try again or contact us."

We look inside the Cybersource Virtual Terminal and see the transaction requests coming in but failing.

We have tested this in test mode and are using a test Security Key generated from the Test Cybersource Business Center.

This is an urgent issue for us. Can anyone with more experience on the Cybersource plugin help us troubleshoot this error?

Thanks,
Lee

 
Magento Community Magento Community
Magento Community
Magento Community
 
squiddo
Jr. Member
 
Total Posts:  1
Joined:  2008-10-29
 

Hello Lee,

I just caught this posting and thought I’d reply an try and help you out. Have you thought to reach out to CyberSource directly for support with the issue? I’ve heard that they have great customer support and this error seems fairly straight forward.

Customer Support can be reached at the below link:

http://www.cybersource.com/esupport

On that note, it’s cause could be from any number of different reasons, not all of which are client based. If I had to guess now I’d likely lean towards a configuration issue with the test “simulator” at CyberSource.

Cheers,
Squiddo

 
Magento Community Magento Community
Magento Community
Magento Community
 
leetaylordoes
Sr. Member
 
Total Posts:  227
Joined:  2008-02-05
San Diego, CA
 

Thanks @squiddo,

We’ve actually figured out the problem, and had to do a minor customization to the extension while also coming to realize about the CyberSource live and testing mode constraints. Their customer support is absolutely great - as they couldn’t find the problem due to the extension being 3rd party, but were definitely willing to help us look into it. I highly recommend them.

I’ll plan on writing a blog about it soon to help benefit the community.

I appreciate your response!
- Lee

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top