Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 4
Magento warning message
 
theodordion
Jr. Member
 
Total Posts:  1
Joined:  2010-12-19
 

Hello,

After installing magento ver 1.4.2.0 i get the following warning in the admin panel:

Your web server is configured incorrectly. As a result, configuration files with sensitive information are accessible from the outside. Please contact your hosting provider.

My server is lighttpd and i have the latest version of php / mysql.

My url is: dcarcitecture.com

 
Magento Community Magento Community
Magento Community
Magento Community
 
blubbbiz
Jr. Member
 
Total Posts:  1
Joined:  2010-12-19
 

got the same problem over here, please let me know if you find out why.

allready checked the file/dir permissions and they should be ok… think it must be something other…

thanks for help

 
Magento Community Magento Community
Magento Community
Magento Community
 
alkarim
Guru
 
Total Posts:  368
Joined:  2008-04-10
 

have the same issue,

 
Magento Community Magento Community
Magento Community
Magento Community
 
The Wizl
Jr. Member
 
Total Posts:  5
Joined:  2010-08-19
 

Same here, need som answers about it. Any Magento staff checking the forum for these kind of problems?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Turnkeye
Moderator
 
Avatar
Total Posts:  908
Joined:  2008-12-20
URL: turnkeye.com
 

Try to deactivate mod rewrites.

But it is hard to say what is wrong without direct access to the files.

 
Magento Community Magento Community
Magento Community
Magento Community
 
dreamzdb
Jr. Member
 
Total Posts:  1
Joined:  2010-11-12
 

I’m having the same issue, and I need mod-rewrites to work for SE friendly URLs. So that really isn’t a solution for me.

 
Magento Community Magento Community
Magento Community
Magento Community
 
DeDux
Jr. Member
 
Total Posts:  2
Joined:  2010-11-29
 

I have got the same warning. But can find the problem. Maybe a chmod problem?

I have tried to disable rewrite. didn’t help.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ankit_sam
Member
 
Avatar
Total Posts:  34
Joined:  2009-12-10
 

Getting same message.

Earlier was getting error:
“client denied by server configuration: app/etc/local.xml”

Hence added the line
Allow from 192.168.50.5 127.0.0.1 localhost
in /app/.htaccess

That error is gone but now getting the message “Your web server is configured incorrectly. As a result, configuration files with sensitive information are accessible from the outside. Please contact your hosting provider.”

 
Magento Community Magento Community
Magento Community
Magento Community
 
Batta
Jr. Member
 
Total Posts:  2
Joined:  2008-11-22
 

Same problem here!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
phpbussi
Jr. Member
 
Total Posts:  2
Joined:  2008-04-12
 

I had exactly the same problem with a new and clean install.

After playing arround to get rid of this problem i decided to reinstall and did it via SSH. I did the full install as per official guide. Everything is running smoothly now.

Try this way in case you have access via SSH.

rgds

 
Magento Community Magento Community
Magento Community
Magento Community
 
andrea.perego
Jr. Member
 
Total Posts:  6
Joined:  2010-12-16
 

Hi there.

I had the same problem. In my specific case, the reason was that Apache was configured to ignore directives specified in .htaccess files.

To solve the problem, you need to change Apache’s configuration accordingly---i.e., by setting to “All” the value of the “AllowOverride” directive applying to the directory where Magento has been installed.

Andrea

 
Magento Community Magento Community
Magento Community
Magento Community
 
tiberiugal
Jr. Member
 
Total Posts:  1
Joined:  2009-11-20
 

I’ve got the same message with clean install over ssh,
Fix: Edit apache configuration file ,change line
“AllowOverride None”
to
“AllowOverride All”

 
Magento Community Magento Community
Magento Community
Magento Community
 
eepsylon
Jr. Member
 
Total Posts:  3
Joined:  2010-10-21
 

Same error. The ‘AllowOverride’ suggestion did not solve the problem though. Anyone?

 
Magento Community Magento Community
Magento Community
Magento Community
 
magentoinchina
Member
 
Avatar
Total Posts:  32
Joined:  2009-07-12
 

http://127.0.0.1/magento1420/app/etc/local.xml

that is the actually problem.

 
Magento Community Magento Community
Magento Community
Magento Community
 
melanjolly
Jr. Member
 
Total Posts:  1
Joined:  2010-11-03
 

Oops! I did the same thing. How does one configure the server so that local.xml is not visible from the outside? Is it a matter of file permissions?

 
Magento Community Magento Community
Magento Community
Magento Community
 
stephanieiramire
Jr. Member
 
Avatar
Total Posts:  1
Joined:  2011-01-05
ny
 

At the top of the screen you can see the warning message. It usually appears right after the Magento installation as all Magento configuration settings are set to default.

Image Attachments
DeekshaSethInWantedMovieStills3.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 4