Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

“index.php url” problem again
 
lsga
Jr. Member
 
Avatar
Total Posts:  24
Joined:  2010-11-16
 

Hi there,

As many people, I have a problem with my url. Instead of :

http://mywebsite.com/admin/

I have:

http://mywebsite.com/index.php/admin/

So I read carefully all the post about this subject on this forum and others, I tried all the tricks (until DNS setting to get a true domain name), and nothing worked. So, I tried to make a new clean installation, with a correct domain name ; but I still have the problem. But, doing so, I realized that the installer was having the very same problem. Its url is:

http://mywebsite.com/index.php/install/wizard/administrator/

Knowing that this problem is recurrent for many users, is it officially considered as a Bug ? Is there an official and clear procedure to resolve it ?

thx

magento Magento ver. 1.4.2.0
ubuntu 10.10
Apache with mode rewrite

 
Magento Community Magento Community
Magento Community
Magento Community
 
lsga
Jr. Member
 
Avatar
Total Posts:  24
Joined:  2010-11-16
 

Ok, I just noticed that:

Mage::getBaseUrl()

give the damned “index.php”

where:

Mage::getBaseUrl('web')

give it in the right form.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top