Magento Forum

   
Page 2 of 3
Please enter a valid URL. Protocol is required (http://, https:// or ftp://)
 
RanZo
Jr. Member
 
Total Posts:  8
Joined:  2010-12-18
 

I have followed every instruction given here down to a Tee, but no joy.

I have tried and tried again every option of every advice, magento just will not get past the third step in instalation.
Tutorial on how to use wamp or xampp helps neither, tired both.
http://www.magentocommerce.com/wiki/1_-_installation_and_configuration/installing_on_windows_with_xampp_and_wamp

Any more suggestions, I will have a project coming soon but can’t even install the magento.
pls.

 
Magento Community Magento Community
Magento Community
Magento Community
 
blackpearl
Jr. Member
 
Total Posts:  2
Joined:  2011-02-01
 

Hi,

I’m very interested too, don’t know how to solve this problem.
I try to check the “Skip Base URL Validation Before the Next Step”, but nothing change :(
thanks by advance

 
Magento Community Magento Community
Magento Community
Magento Community
 
blackpearl
Jr. Member
 
Total Posts:  2
Joined:  2011-02-01
 

I solved this problem by creating a new virtualhost “magento.local”
At he begin, my url looks like http://localhost/myproject/magento/

My configuration : windows7/ firefox / wamp / magento 1.4.2.0
I add my new virtualhost in : c:\windows\System32\drivers\etc\hosts
127.0.0.1 magento.local

In wamp\bin\apache2.2.17\conf\ httpd.conf
NameVirtualHost *:80
<VirtualHost *:80>
DocumentRoot “C:\wamp\www\myproject\magento”
ServerName magento.local
ServerAlias magento
</VirtualHost>

If after this modification, you don’t have acces to your project list anymore (your http://localhost)
Add this in httpd.conf
<VirtualHost *:80>
DocumentRoot “C:\wamp\www”
ServerName localhost
ServerAlias localhost
</VirtualHost>

Don’t forget to restart your services, hope that it could help someone

 
Magento Community Magento Community
Magento Community
Magento Community
 
meetchd
Jr. Member
 
Total Posts:  1
Joined:  2009-05-17
 

Great!!! Its good reply. Working now!!!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
anjum121
Jr. Member
 
Total Posts:  1
Joined:  2011-02-11
 

Hey

I had same problem while installing magento.

I came up with this hack/fix . when u got this error msg \”Please enter a valid URL. Protocol is required (http://, https:// or ftp://)\"

Just disable your javascript using web developer toolbar in firefox

Its working like charm hope this helps some on smile

Bye

 
Magento Community Magento Community
Magento Community
Magento Community
 
drenls
Jr. Member
 
Total Posts:  1
Joined:  2011-02-23
 

anjum121
Thank you!!!!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
nicetluc
Jr. Member
 
Total Posts:  1
Joined:  2011-02-23
 

anjum121

Wow it was ease!! Many thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
nigedo
Jr. Member
 
Total Posts:  2
Joined:  2011-02-25
 
anjum121 - 12 February 2011 03:29 AM

Just disable your javascript using web developer toolbar in firefox.

Awesome dude! Such an obvious and simple solution to this stupid issue. I could kiss you. grinx

 
Magento Community Magento Community
Magento Community
Magento Community
 
andrewmiron
Jr. Member
 
Total Posts:  2
Joined:  2011-02-25
 

Hi Guys,

I have the same problem.. and I have tried almost every solution.. from changing the name from host file (I am using ubuntu 10) till disactivating the javascript on configuration page…
Nothing worked… but it has managed to iritate me a lot.

What can I do to go further?

Thank you in advance!

 
Magento Community Magento Community
Magento Community
Magento Community
 
andrewmiron
Jr. Member
 
Total Posts:  2
Joined:  2011-02-25
 

Hi Guys,

I have the same problem.. and I have tried almost every solution.. from changing the name from host file (I am using ubuntu 10) till disactivating the javascript on configuration page…
Nothing worked… but it has managed to iritate me a lot.

What can I do to go further?

Thank you in advance!

 
Magento Community Magento Community
Magento Community
Magento Community
 
airgraphics
Jr. Member
 
Total Posts:  1
Joined:  2011-01-15
 

anjum121

Bravo!! Disabling Java in Firefox worked! Such an easy solution. Thanks for the help.

 
Magento Community Magento Community
Magento Community
Magento Community
 
banditsmile
Jr. Member
 
Total Posts:  1
Joined:  2011-03-11
 

first,you should config your host file(if in windows ,the file is x:/windows/system32/drivers/etc/host)
add
127.0.0.1 www.testmagento.com
at the bottom;

then config your apache config file apache.conf or httpd-vhost.conf in apache/conf/extra dir
add
<VirtualHost *:80>
ServerAdmin example@yourmail.com
DocumentRoot “/xampp/htdocs/magento”
ServerName www.testmagento.com
ErrorLog “logs/www.testmagento.com.error.log”
CustomLog “logs/www.testmagento.com.access.log” combined
</VirtualHost>

then restart your apache server

 
Magento Community Magento Community
Magento Community
Magento Community
 
Guillermo Gallo
Jr. Member
 
Total Posts:  16
Joined:  2010-06-08
 

bandit, thanks very much!!, your help works perfect!!.

Just for everyone that is having issues like this, don’t change the file httpd.conf in wamp\bin\apache\Apache2.2.17\conf Changing that file can cause your wamp server freeze.

Kind regards.-

 
Magento Community Magento Community
Magento Community
Magento Community
 
Amjath
Jr. Member
 
Avatar
Total Posts:  19
Joined:  2008-10-15
Cochin, Kerala, India
 

There is an even more simple step.

Open \app\design\install\default\default\template\install\config.phtml and remove the class ‘validate-url’ from the base url input textbox. The textbox name is ‘config[unsecure_base_url]‘.

For more detailed information, visit our magento development blog.

www.blog.ecommercesoftwaresolutionsonline.com/archives/1014/magento-please-enter-a-valid-url-protocol-is-required-http-https-or-ftp-issue-in-magento-installation.html

Image Attachments
validURLissue2.gif
 
Magento Community Magento Community
Magento Community
Magento Community
 
titanas
Jr. Member
 
Total Posts:  8
Joined:  2009-04-12
 

1. Go to js\prototype and open the file “validation.js”. (FYI : All the validation takes place through this script on both front end and back end)

2. Find this line and remove it / Comment it

[’validate-url’, ‘Please enter a valid URL. Protocol is required (http://, https:// or ftp://)’, function (v) {
return Validation.get(’IsEmpty’).test(v) || /^(http|https|ftp):\/\/(([A-Z0-9][A-Z0-9_-]*)(\.[A-Z0-9][A-Z0-9_-]*)+)(:(\d+))?\/?/i.test(v)
}],

3. Now continue your installation it works like a cake !!!

4. After your installation, Don’t forget to add it / uncomment it for validation of URLs in future

If you have any difficulties with this kindly let me know !!!

THX haljerome it works!!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top
Page 2 of 3