Magento Forum

   
Magento 1.4.1.1 + Magento_mobile kills frontend
 
jjem
Jr. Member
 
Total Posts:  15
Joined:  2008-11-14
 

Just bought the activation key and tried to install the Magento_Mobile extension. First I had to upgrade the PEAR (http://www.magentocommerce.com/bug-tracking/issue?issue=10495). Then it installed well.

But somehow it upgrades all the files below to 1.4.2 and the frontend of my store gives the error message: “There has been an error processing your request”

Does this mean that magento mobile is not 1.4.1.1 compatible? I hope I can get my money back somehow..... or then help to put this correctly. Finally Magento is selling this extension…

Lib_Google_Checkout 1.4.2.0 (stable) Google Checkout Library
Lib_Js_Calendar 1.51.1 (stable) Javascript Calendar for Magento
Lib_Js_Mage 1.4.2.0 (stable) Javascript Libraries for Magento
Lib_Js_Prototype 1.6.0.3.3 (stable) Prototype and Scriptaculous Javascript Libraries for Magento
Lib_Mage 1.4.2.0 (stable) Mage Library
Lib_PEAR 1.4.0.0 (stable) PEAR Library
Lib_Phpseclib 1.4.2.0 (stable) Phpseclib Library
Lib_Varien 1.4.2.0 (stable) Varien Library
Lib_ZF 1.10.8.0 (stable) Zend Framework
Lib_ZF_Locale 1.10.8.0 (stable) Zend Framework Locale
Mage_Core_Modules 1.4.2.0 (stable) Collection of Magento Core Modules
Mage_Locale_en_US 1.4.2.0 (stable) en_US locale
Magento_Mobile 1.4.2.0 (stable) Magento Mobile Xml Interface

 
Magento Community Magento Community
Magento Community
Magento Community
 
LindyKyaw
Sr. Member
 
Avatar
Total Posts:  138
Joined:  2008-01-02
Los Angeles
 

If you go to mobile-extension-package-release, you can see the Magento mobile extension with version compatible.

If you installed magento-core/Magento_Mobile without choosing the version, some dependent module will be updated during the installation.

If you can post what is the detail error from var/report/{report number}, it will be helpful for us to help you solve the issue.

We tried on our testing environment and got the following error message:

a:5:{i:0;s:69:\"Invalid method Mage_Wishlist_Block_Links::addWishlistLink(Array
(
)
)\"
;i:1;s:2271:\"#0 [internal function]: Varien_Object->__call(\'addWishlistLink\', Array)
#1 [internal function]: Mage_Wishlist_Block_Links->addWishlistLink()
We commented out the following codes from app/design/frontend/base/default/layout/wishlist.xml
<reference name=\"top.links\">
            <!--
block type=\"wishlist/links\" name=\"wishlist_link\">
                <
action method=\"addWishlistLink\"></action>
            </
block-->
</
reference>
After changing the code and refresh cache, the application is back.

 
Magento Community Magento Community
Magento Community
Magento Community
 
jjem
Jr. Member
 
Total Posts:  15
Joined:  2008-11-14
 

OK, I git your correct extension key: magento-core/Magento_Mobile-1.4.1.0

Here is what it installs (without errors) when I first run this:

Lib_PEAR 1.4.0.0 (stable) PEAR Library
Lib_Phpseclib 1.4.1.0 (stable) Phpseclib Library
Mage_Locale_en_US 1.4.1.1 (stable) en_US locale

So the actual extension doesn’t install. When I try to run the install a second time it gets wrong:

magento-core/Mage_Pear_Helpers requires package “pear/PEAR” (version >= 1.6.2)
magento-core/Lib_Google_Checkout requires package “magento-core/Mage_Pear_Helpers” (version >= 1.0.18800)
magento-core/Mage_Core_Modules requires package “magento-core/Lib_Google_Checkout” (version >= 1.4.0.0, version <= 1.4.1, excluded versions: 1.4.1)
magento-core/Magento_Mobile requires package “magento-core/Mage_Core_Modules” (version >= 1.4.1.0, version <= 1.4.2, excluded versions: 1.4.2)
magento-core/Lib_Js_Calendar requires package “magento-core/Mage_Pear_Helpers” (version >= 1.0.18800)
magento-core/Lib_Js_Prototype requires package “magento-core/Mage_Pear_Helpers” (version >= 1.0.18800)
magento-core/Lib_Js_Mage requires package “magento-core/Lib_Js_Prototype” (version >= 1.6.0.3.0, version <= 1.6.1, excluded versions: 1.6.1)
magento-core/Lib_ZF requires package “magento-core/Mage_Pear_Helpers” (version >= 1.0.18800)
magento-core/Lib_Varien requires package “magento-core/Lib_ZF” (version >= 1.9.6.0, version <= 1.9.7.0, excluded versions: 1.9.7.0)
magento-core/Lib_ZF_Locale requires package “magento-core/Mage_Pear_Helpers” (version >= 1.0.18800)
Install Errors
No valid packages found
PEAR ERROR: install failed

I unfortunately do not have a report number as I had to restore my entire store.... when it crashed.... we are live!

www.editions-bim.com/store/

 
Magento Community Magento Community
Magento Community
Magento Community
 
karthickmeiyappan
Jr. Member
 
Total Posts:  4
Joined:  2010-12-08
 

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@appztiger.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Hi the error cames at the time of i installed magento in live ftp. Whats this error....Please reply me how to clear this error......

 
Magento Community Magento Community
Magento Community
Magento Community
 
LindyKyaw
Sr. Member
 
Avatar
Total Posts:  138
Joined:  2008-01-02
Los Angeles
 

@karthickmeiyappan, are you trying to install Magento or Magento Mobile Extension?
If you are trying to install Magento Mobile extension, what is your Magento version?
If you are trying to install Magento, please post the issue on Installation Issue Forum

 
Magento Community Magento Community
Magento Community
Magento Community
 
iamcortez
Jr. Member
 
Total Posts:  27
Joined:  2010-05-28
 

Hi,

I’m having the same issue described by jjes - I’m running Magento 1.4.1.1.

If I try to install “magento-core/Magento_Mobile-1.4.1.0”, then as described by jjes,

Lib_PEAR 1.4.0.0 (stable) PEAR Library
Lib_Phpseclib 1.4.1.0 (stable) Phpseclib Library
Mage_Locale_en_US 1.4.1.1 (stable) en_US locale

Get installed, but not the Mobile module.

Trying a second time to install Mobile, I get:

pear/Console_Getopt requires PEAR Installer (version >= 1.8.0), installed version is 1.7.1
pear/PEAR requires package “pear/Console_Getopt” (recommended version 1.2.3)
magento-core/Mage_Pear_Helpers requires package “pear/PEAR” (version >= 1.6.2)
magento-core/Lib_Google_Checkout requires package “magento-core/Mage_Pear_Helpers” (version >= 1.0.18800)
magento-core/Mage_Core_Modules requires package “magento-core/Lib_Google_Checkout” (version >= 1.4.0.0, version <= 1.4.1, excluded versions: 1.4.1)
magento-core/Magento_Mobile requires package “magento-core/Mage_Core_Modules” (recommended version 1.4.1.0)
magento-core/Lib_Js_Calendar requires package “magento-core/Mage_Pear_Helpers” (version >= 1.0.18800)
magento-core/Lib_Js_Prototype requires package “magento-core/Mage_Pear_Helpers” (version >= 1.0.18800)
magento-core/Lib_Js_Mage requires package “magento-core/Lib_Js_Prototype” (version >= 1.6.0.3.0, version <= 1.6.1, excluded versions: 1.6.1)
magento-core/Lib_ZF requires package “magento-core/Mage_Pear_Helpers” (version >= 1.0.18800)
magento-core/Lib_Varien requires package “magento-core/Lib_ZF” (version >= 1.9.6.0, version <= 1.9.7.0, excluded versions: 1.9.7.0)
magento-core/Lib_ZF_Locale requires package “magento-core/Mage_Pear_Helpers” (version >= 1.0.18800)
Install Errors
No valid packages found
PEAR ERROR: install failed

Thanks

Steve

 
Magento Community Magento Community
Magento Community
Magento Community
 
Enase
Jr. Member
 
Total Posts:  19
Joined:  2010-05-11
 

If you can’t install it by pear, try to use direct package, just unpack it to magento.
Links and manual you can find here:
http://www.magentocommerce.com/magento-connect/Magento+Core/extension/4457/magento_mobile

for 1.4.1.1 you can use this one:
http://www.magentocommerce.com/magento_mobile/062111_rev_111730/Mage_XmlConnect-1.4.1.0.21.0.tgz

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top