Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Problem mit Ordner-Struktur
 
tease
Sr. Member
 
Total Posts:  115
Joined:  2010-10-06
 

Hallo zusammen,

nachdem ich meine erste Magento-Installation lokal betrieben habe und ganz gut damit zurecht kam, habe ich nun auf meinem Webspace ein ganz frisches System aufgesetzt und nochmal bei Null angefangen. Doch leider habe ich damit große Probleme, die ich zuvor nicht hatte. Mein Magento-Buch von Galileo ist mir da auch keine Hilfe.

Ich fürchte, bei mir stimmt schon was bei meine Magento Ordnerstruktur was nicht. Ich bemerke nämlich immer wieder, dass mir bestimmte Ordner einfach fehlen, und zudem habe ich sehr viele Probleme, die vielleicht darauf zurückzuführen sind.
Die Frage ist jetzt, wie ich dieses Problem löse.

Vielleicht kurz, welche Probleme mein Magento (Vers.1.4.1.1.) macht:

Nachdem ich Magento installiert habe und die Sample-Datas wieder gelöscht habe, habe ich zuerst ein paar Extensions installiert, die nun aber alle irgendwelche Probleme machen.

1.Extension war Market Ready Germany: Installation war scheinbar okay, kam keine Fehlermeldung. Aber wenn ich nun einen Test-Kauf im Frontend mache, erscheinen nirgends AGBs oder das Widerrufsrecht oder ähnliches. Auch im Backend finde ich nix, was auf MRG schließen lässt.

2.Video-Modul (von AheadWorks) funktioniert nicht. Im Backend in der “Video"-Kategorie habe ich eine http Adresse angegeben, aber im Frontend wird nichts dargestellt. Ãœbrigens fehlt im Frontend die gesamte Kategorie “Beschreibung”.

3. Es ist im Frontend kein File-Upload möglich. Man kann ein File aussuchen und dann z.B. auf “Warenkorb” kllicken, aber dann kommt weder Fehler- noch Erfolgsmeldung. Man sieht auch nirgends welches File upgeloaded wurde.
Daraufhin fand ich online einen Thread, in dem beschrieben wurde welche Datei man dazu ändern müsste, aber diese Datei, bzw. die angegebenen Ordner gibt es bei mir gar nicht.
Zum Beispiel war die Rede von einem “app/code/local/mage/catalog"-Ordner, worin nochmal einige andere Ordner sind, bei mir gibt es diesen catalog aber gar nicht!

Jetzt meine Frage (endlich): kann ich irgendwo meine Ordner-Struktur überprüfen und gegebenenfalls fehlende Ordner hinzufügen oder muss ich Magento komplett neu installieren? S’Problem ist, dass ich fast 2 Wochen brauchte um Magento zu installieren, weil es täglich neue Problem gab und ich mir sicher bin, dass es bei einer Neu-Installation wieder zu Problemen kommen wird.

Oder weiß jemand Hilfe für meine Probleme?

Bin um jede Hilfe dankbar, da ich langsam echt am verzweifeln bin!

 
Magento Community Magento Community
Magento Community
Magento Community
 
jan212
Guru
 
Avatar
Total Posts:  407
Joined:  2008-01-03
 

-Wie hast du Magento installiert?
-Hast du SSH Zugriff?
-Kurze Info über deinen Webspace…

 
Magento Community Magento Community
Magento Community
Magento Community
 
tease
Sr. Member
 
Total Posts:  115
Joined:  2010-10-06
 
jan212 - 13 December 2010 11:05 PM

-Wie hast du Magento installiert?
-Hast du SSH Zugriff?
-Kurze Info über deinen Webspace…

Ich habe die FullRelease Version installiert. Mein Webspace ist bei Campusspeicher. Laut Magento-Check sind alle Voraussetzungen erfüllt. Schreibrechte müssten auch passen, Safe-Mode hab ich deaktivieren lassen, InnoDB wurde installiert.
Da ich nicht mal weiß, was SSH ist, kann ich nicht sagen, ob ich das hab. Kann ich da irgendwo nachsehen?

Im Grunde hat die Installation ja funktioniert. Ich kann Produkte verwalten, Themes ändern etc, aber ein paar KLeinigkeiten scheinen halt zu fehlen oder falsch aufgesetzt worden zu sein.

Ich hoffe, das hilft etwas weiter. Danke für die Hilfe!

 
Magento Community Magento Community
Magento Community
Magento Community
 
ds_1984
Mentor
 
Avatar
Total Posts:  3116
Joined:  2008-12-09
Potsdam, Germany
 

Zu 1. - dir fehlen offenbar Schreibrechte auf deine Datenbank, wäre das nicht so hättest du die AGB & Wiederrufsbelehrung standardmäßig nach der Installation von Marked Ready im letzten Betell Schritt & müsstest diese bestätigen.

In jedem Fall mal Caches & Indexe neu aufbauen - dann weißt du mehr. Wenn du dann System->Konfiguration aufrufst, sollte dich eine Marked Ready Germany Info begrüßen.

Zu 2. - Es ist auch möglich das du entweder vom Browser aus, oder vom eingesetzten AntiViren Programm dieses Video blockst - da es als Werbebanner gewertet wird - hatte ich schon oft. Ansonsten eben auf ausreichende Schreib und Leserechte prüfen, bei Bildern ist es auch so das sie nicht angezeigt werden wenn die Rechte nicht stimmen.

Das mit der Kategoriebeschreibung ist komisch, ist mir unbekannt das Problem.

Zu 3. - Ja das mit dem Upload Verhalten im Frontend ist normal, es ist ja technisch gesehen ein HTML Formular was da deine Datei hochlädt, und der “in den Warenkorb” Button fungiert in dem Sinne als “Submit” Knopf - klar kann man das besser lösen, ist aber eben so von der Stange.

Ich mache es in meinen Shops so das ich bei den Frontend Datei Uploads eine zusätzliche Info für den Besucher innerhalb der Artikeldaten oder eben der Optionsbeschreibung platziere.

Das du nicht nachvollziehen kannst wo die Datei ist liegt daran das es zum einen aus meiner Sicht ein Bug ist und zum anderen werden viele Ordner innerhalb von Magento, insbesondere wie hier Temporärordner erst bei erstmaliger Verwendung erstellt.

Bei den Designs verhällt es sich anders - wenn dir dort was fehlt was hier oder sonst wo beschrieben wird, dann bitte erst mit Magento Theme Design beschäftigen.

Es läuft aber darauf hinaus das mit z.B. “app/design/frontend/default/mein_theme/template/catalog/product/view.phtml” gemeint ist das man ein eigenes Theme mit dem Namen “mein_theme” angelegt hat & die Datei “view.phtml” aus dem Ordner “app/design/frontend/base/default/template/catalog/product/” kopiert wurde um es unabhängig von Magento Updates sicher & individuell bearbeiten zu können.

Was in deinem Theme Ordner nicht gefunden wird stellt Magento bereit aus “app/design/frontend/base/” - somit kannst du auf Basis vom default Theme auch mit nur 2 veränderten Dateien oder so großes bewirken.

Es ist also möglich das auch in nachinstallierten Themes oder so Dateien & Verzeichnisse fehlen die aber jemand irgendwo beschrieben hat, diese müssen dann eben auf Basis des Base Ordners (inkl. Unterordner) angelegt werden in deinem Theme

Hier noch der Link zum Beistrag wo ich einen Patch bereit stelle für dieses Upload Problem - wenn es korrekt verwendet wird, dann kommst du im Warenkorb, Kundenbereich und auch über die Bestellverwaltung in verlinkter Form an die Datei.
http://www.magentocommerce.com/boards/viewthread/57202/

Liebe Grüße - Daniel

 
Magento Community Magento Community
Magento Community
Magento Community
 
tease
Sr. Member
 
Total Posts:  115
Joined:  2010-10-06
 
ds_1984 - 13 December 2010 11:54 PM

Zu 1. - dir fehlen offenbar Schreibrechte auf deine Datenbank, wäre das nicht so hättest du die AGB & Wiederrufsbelehrung standardmäßig nach der Installation von Marked Ready im letzten Betell Schritt & müsstest diese bestätigen.

In jedem Fall mal Caches & Indexe neu aufbauen - dann weißt du mehr. Wenn du dann System->Konfiguration aufrufst, sollte dich eine Marked Ready Germany Info begrüßen.

Zuerst einmal vielen, herzlichen Dank für deine ausführliche Antwort. Das nenn ich mal Einsatz! :-)

Ich habe auf alle Vezeichnisse Schreibrechte mit 755 angewendet. Zuerst hatte ich alle mit 777 ausgeführt, aber nachdem ich wegen “internal Server Error” meine Seite nicht mehr aufrufen konnte, meinte mein Provider, dass sie nur 755 zulassen. Grund hierfür war glaube ich irgendwas mit cgi-sonstwas - ich kenn mich da leider nicht allzu gut aus.
Ist das ein Problem, oder sollte es auch mit 755 möglich sein?

ds_1984 - 13 December 2010 11:54 PM

Zu 3. - Ja das mit dem Upload Verhalten im Frontend ist normal, es ist ja technisch gesehen ein HTML Formular was da deine Datei hochlädt, und der “in den Warenkorb” Button fungiert in dem Sinne als “Submit” Knopf - klar kann man das besser lösen, ist aber eben so von der Stange.

Ich mache es in meinen Shops so das ich bei den Frontend Datei Uploads eine zusätzliche Info für den Besucher innerhalb der Artikeldaten oder eben der Optionsbeschreibung platziere.

Aber bei mir passiert nix, wenn ich auf den als “in den Warenkorb” getarnten Submit Button klicke. Momentan verstehe ich auch nicht, wie du das mit der Zusatz-Info für Besucher meinst, aber vielleicht wird mir das klar, sobald ich den Patch aus deinem Link mal ausprobiere. Konnte ich bis jetzt noch nicht machen, da ich erstmal das mit den Themes checken muss, um dann diese mir fehlenden Ordner, die du angegeben hast, anzulegen.

ds_1984 - 13 December 2010 11:54 PM

Bei den Designs verhällt es sich anders - wenn dir dort was fehlt was hier oder sonst wo beschrieben wird, dann bitte erst mit Magento Theme Design beschäftigen.

Es läuft aber darauf hinaus das mit z.B. “app/design/frontend/default/mein_theme/template/catalog/product/view.phtml” gemeint ist das man ein eigenes Theme mit dem Namen “mein_theme” angelegt hat & die Datei “view.phtml” aus dem Ordner “app/design/frontend/base/default/template/catalog/product/” kopiert wurde um es unabhängig von Magento Updates sicher & individuell bearbeiten zu können.

Was in deinem Theme Ordner nicht gefunden wird stellt Magento bereit aus “app/design/frontend/base/” - somit kannst du auf Basis vom default Theme auch mit nur 2 veränderten Dateien oder so großes bewirken.

Es ist also möglich das auch in nachinstallierten Themes oder so Dateien & Verzeichnisse fehlen die aber jemand irgendwo beschrieben hat, diese müssen dann eben auf Basis des Base Ordners (inkl. Unterordner) angelegt werden in deinem Theme

Aha, jetzt wird mir so einiges klarer. Vielen Dank für den Tipp. Habe mir gerade mal das über Theme Design im Designers Guide durchgelesen und denke, dass das der Grund ist, wieso mir so viele Ordner “fehlen”. Ist ja beruhigend, dann liegts wenigstens ausschließlich an mir und meinem fehlenden Wissen und nicht an ner fehlerhaften Installation, die eine Neuinstallation zur Folge hätte. In diesem Fall, kann ich das Problem ja selber beheben, indem ich mich in die Materie einarbeite.
Kannst du mir dazu irgendwas empfehlen? Hab das Galileo-Buch durchgearbeitet, aber das hat mir nicht wirklich weitergeholfen (wie man sieht). Reicht es den Designers Guide durchzulesen, oder sollte ich gleich den Magento User Guide kaufen? Oder irgend ein anderes Buch? Gibts die beiden Magento-Guides eigentlich auch auf Deutsch? Englisch geht auch, dauert aber länger. ;-)

Wie gesagt, vielen Dank, dass du dir so viel Zeit genommen hast!
Ich weiß es zu schätzen!

LG

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top