Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

change http: to https: 
 
bfly03
Member
 
Total Posts:  59
Joined:  2010-06-14
 

I set up my site originally with http: and now I have bought a SSL certificate and need to change everything over to https:.
Is there a quick way of doing this? I could not find anything on the forum boards about it.

Thanks,

 
Magento Community Magento Community
Magento Community
Magento Community
 
chiefair
Mentor
 
Avatar
Total Posts:  1848
Joined:  2009-06-04
 

The usual method is to go change your secure_base_url from http://www.yourwebsite.com/ to https://www.yourwebsite.com/ and then drop down to the two checkboxes, one is something along the lines of “Use Secure in Frontend” and save the configuration. Don’t get all trigger happy and change “Use Secure for Admin” yet as you can lock yourself out.

Go log yourself into one of your test user accounts on the front end and you should see your secure access indicators turn on in the web browser of your choice. Same thing after you reach a certain point in the checkout process, after viewing your cart and then telling Magento you want to Check Out, it should once again switch into secure mode.

Once you have this occurring, then go back into your system config and check the “Use Secure for Admin” checkbox and you will now have secured access to your Admin panel.

 
Magento Community Magento Community
Magento Community
Magento Community
 
bfly03
Member
 
Total Posts:  59
Joined:  2010-06-14
 

ok, so i went in and changed what you said and i am still getting an error with the ssl. I talked to my host and they said it was because I had code calling http: as well as https:

The only code that is calling http: is

<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
.
Do I need to change this? Or do you have any ideas?

Thank you.

 
Magento Community Magento Community
Magento Community
Magento Community
 
chiefair
Mentor
 
Avatar
Total Posts:  1848
Joined:  2009-06-04
 

No, that tag needs to read that way. It is a Document Type Definition.

Are you by any chance referring to a mixed security message that comes up in Internet Explorer? That is caused by you serving out images, javascript objects and CSS via HTTP on an SSL Secured web page.

 
Magento Community Magento Community
Magento Community
Magento Community
 
bfly03
Member
 
Total Posts:  59
Joined:  2010-06-14
 
chiefair - 13 December 2010 01:10 PM

No, that tag needs to read that way. It is a Document Type Definition.

Are you by any chance referring to a mixed security message that comes up in Internet Explorer? That is caused by you serving out images, javascript objects and CSS via HTTP on an SSL Secured web page.

Yes, after googling the error it seems it is exactly what you are talking about.
Everything I have is pointed towards https except for my facebook like button and tweet button.

any ideas?

 
Magento Community Magento Community
Magento Community
Magento Community
 
bfly03
Member
 
Total Posts:  59
Joined:  2010-06-14
 

i figured it out. it was the tweet button. the quick javascript button can not be used on https pages, it is not supported yet. but you can build your own: http://dev.twitter.com/pages/tweet_button

Thanks for the help!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top