Magento Forum

   
Magento 1.4.2 Update - Customer Attribute Bug
 
@miral
Jr. Member
 
Total Posts:  5
Joined:  2007-09-04
Germany, Duesseldorf
 

Besten Dank für den Tipp! ...hat mir menge Zeit gespart! smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
Quaeso
Guru
 
Avatar
Total Posts:  334
Joined:  2010-04-03
 
robin2160 - 10 January 2011 03:42 AM

.....


Für customer_address_payone_credit_rating_score und .....

WIrd bei mir nicht gefunden. Siehe Anhang
Bin ich die einzige?

SORRY ANHANG WIRD NICHT ANGENOMMEN

 
Magento Community Magento Community
Magento Community
Magento Community
 
novalis
Moderator
 
Avatar
Total Posts:  266
Joined:  2007-10-13
Berlin, Germany
 

Danke für den Fix @Robin… und das Ganze in SQL (damit geht’s noch schneller):

UPDATE `eav_attributeSET `frontend_input` = 'date' WHERE `eav_attribute`.`attribute_idIN ('customer_address_payone_credit_rating_date');

UPDATE `eav_attributeSET `frontend_input` = 'text' WHERE `eav_attribute`.`attribute_idIN ('customer_address_payone_credit_rating_score''customer_address_payone_credit_rating_secscore');

 
Magento Community Magento Community
Magento Community
Magento Community
 
former
Jr. Member
 
Total Posts:  11
Joined:  2009-02-25
 

Prima!

Stafans Lösungsansatz funktioniert auch bei mir einwandfrei.

Vielen Dank dafür!

 
Magento Community Magento Community
Magento Community
Magento Community
 
tber
Sr. Member
 
Avatar
Total Posts:  80
Joined:  2010-02-18
 

okay, hat über den ersten Fehler hinweg geholfen, bin jetzt ganz schön vorsichtig mit den updates, obwohl sie doch eigentlich helfen sollten wink

Eine Frage bleibt, vielleicht kann mir jemand “schnell” helfen: der onepage checkout kommt jetzt nicht mehr über die Versandart hinweg hmmm

Version 1.4.2
Bezahlarten aus Testgründen alle aktiviert
Versandarten auch, können gewählt werden (wobei meine Tablerates nicht mehr angezogen werden ???)

bin für jeden kleinen Hinweis dankbar!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Nico2601
Jr. Member
 
Total Posts:  4
Joined:  2009-03-12
 

Ich habe das Problem leider auch, allerdings bringt die Payone-Lösung mich nicht weiter. Die Einträge sind in der DB nicht vorhanden. Hat jemand eine Idee? Bin allmählich ratlos. Market Ready germany ist installiert.

Danke Nico

 
Magento Community Magento Community
Magento Community
Magento Community
 
tber
Sr. Member
 
Avatar
Total Posts:  80
Joined:  2010-02-18
 
Nico2601 - 29 March 2011 11:40 PM

Ich habe das Problem leider auch, allerdings bringt die Payone-Lösung mich nicht weiter. Die Einträge sind in der DB nicht vorhanden. Hat jemand eine Idee? Bin allmählich ratlos. Market Ready germany ist installiert.

Danke Nico

Hallo,

bin erst letzte Woche wieder zu diesem Thema kontaktiert worden, allerdings war es kein Systemproblem, sondern ein Einstellungsthema. Schau mal bitte genau in deinen Einstellungen, ob alle logischen Verbindungen zwischen PAYMENT FILTER, ZAHLARTEN und GRUPPENBERECHTIGUNGEN noch vorhanden sind. Das war zumindest in dem letzten Fall die Ursache.

Bevor du dich jetzt mit dem Quellcode herumprügelst wink

lg,

Thorsten

 
Magento Community Magento Community
Magento Community
Magento Community
 
Nico2601
Jr. Member
 
Total Posts:  4
Joined:  2009-03-12
 
Nico2601 - 29 March 2011 11:40 PM

Ich habe das Problem leider auch, allerdings bringt die Payone-Lösung mich nicht weiter. Die Einträge sind in der DB nicht vorhanden. Hat jemand eine Idee? Bin allmählich ratlos. Market Ready germany ist installiert.

Danke Nico

Hab den Fehler gefunden:

Es lag am Eos-Payment-Modul in der Tabelle eav_attribute gibt es 2 Einträge dazu, nach Entfernen dieser, Fehler verschwunden.

Gruß Nico

 
Magento Community Magento Community
Magento Community
Magento Community
 
andi
Member
 
Avatar
Total Posts:  54
Joined:  2007-09-19
Munich
 

Vielen Dank robin2160 der Tipp hat mir gerade sehr geholfen grin

 
Magento Community Magento Community
Magento Community
Magento Community
 
fatsche
Sr. Member
 
Total Posts:  79
Joined:  2009-08-07
 

@robin2160: Vielen herzlichen Dank für die Anleitung! Hat mir eine Menge Arbeit erspart, zumal ich sowie so nie auf die Ursache gekommen wäre wink

LG
fatsche

 
Magento Community Magento Community
Magento Community
Magento Community
 
nebukatnezer
Jr. Member
 
Total Posts:  23
Joined:  2007-09-09
 
robin2160 - 15 December 2010 03:03 AM

Wie schon bekannt ist der Verursacher dieser Fehlermeldung das Payone-Modul das derzeit in veralterter Version von MRG mit installiert wird. Aber auch ein Reinstall auf die aktuelle Version 2.3.1.4 bringt nicht den gewünschten Erfolg.
Also mußte ich mal schauen wo denn der Fehler liegen könnte.
Es ist ein customer Attribute, soweit die Fehlermeldung.

Payone installaliert 3 Customer Attribute:
customer_address_payone_credit_rating_date
customer_address_payone_credit_rating_score
customer_address_payone_credit_rating_secscore

Diese mal in der eav_attribute angeschaut fällt auf, das sie ein mir derzeit unbekannten frontend_input verwenden.
Dort steht überall label.

Wenn man nun die frontend_inputs so abändert das auch magento sie versteht

customer_address_payone_credit_rating_date = date
customer_address_payone_credit_rating_score = text
customer_address_payone_credit_rating_secscore = text

sind die Fehlermeldungen im Admin und im Checkout weg und die Funktionen wieder vorhanden.


VG Stefan

@ robin2160: Ein dickes Dankeschön an dich! Du hast mir gerade den Tag/Abend gerettet mit dem Tipp. Bei mir ist das Problem erstaunlicherweise erst beim Update auf Magento 1.6.0.0 aufgetaucht. Die vorigen Updates haben das so hingenommen.

Gruß marc aurel

 
Magento Community Magento Community
Magento Community
Magento Community
 
oxamo
Jr. Member
 
Total Posts:  30
Joined:  2010-05-12
 

Hallo

Nach dem Update auf 1.6.1.0 rc1 bekomme ich wieder diesen Fehler beim Benutzerkonto anlegen.

Fatal errorCall to a member function setAttribute() on a non-object in /home/xxxxxx/public_html/xxxx/app/code/core/Mage/Eav/Model/Attribute/Data.php on line 80

In den frontend_inputs ist aber folgendes eingetragen.(hat unter 1.6.0.0 auch funktioniert)

customer_address_payone_credit_rating_date = date
customer_address_payone_credit_rating_score = text
customer_address_payone_credit_rating_secscore = text

@Nico
wo finde ich diesen Eintrag?

 
Magento Community Magento Community
Magento Community
Magento Community
 
ds_1984
Mentor
 
Avatar
Total Posts:  3116
Joined:  2008-12-09
Potsdam, Germany
 

Wer macht den ein Upgrade auf einen Releasekandidaten???

Möglich das du den Patch in der Datenbank nochmals anwenden musst,
da die Werte während des Upgrades wieder überschrieben wurden vom
Magento Setup.

LG - Daniel

 
Magento Community Magento Community
Magento Community
Magento Community
 
freebreaker
Jr. Member
 
Total Posts:  5
Joined:  2010-03-03
 

Guten Morgen,

nach langem Suchen habe ich diesen netten “Fred” gefunden, und denke auch, dass es mein Problem lösen würde…

aber nach ausgiebigen Suchen in der DB konnte ich die drei genannten Einträge

customer_address_payone_credit_rating_date
customer_address_payone_credit_rating_score
customer_address_payone_credit_rating_secscore

nicht finden.

Kann mir jemand helfen, diese in die DB wieder einzufügen?
Habe es schon versucht, manuell zu machen in PHPmyadmin… aber er bringt mir immer fehler…

Danke im Voraus und beste Grüße!

 
Magento Community Magento Community
Magento Community
Magento Community
 
demonkoryu
Guru
 
Avatar
Total Posts:  328
Joined:  2008-11-26
Dortmund, Germany
 

Danke robin2160, der Tipp mit den Payone-Attributen hat mich weitergebracht.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top