Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

1.4.2.0 upgrade broken payment module
 
rbostan
Jr. Member
 
Total Posts:  25
Joined:  2007-09-12
Istanbul - Turkey
 

hi,
i have upgraded to 1.4.2 yesterday and payment module broken. Issue with Varien_Http_Client encoding. When i got response from gateway request, result seems below:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd"��[��XY���F�F�S��G�FVfV�B&W7;��6RFV��FRf�"vV#��F�F�S���V@(ñ‰½‘䁉��������������=�1����=�1���ٕ�Р�숀�(�ɴ�����ô‰‘½Ý¹ï¿½ï¿½ï¿½ï¿½ï¿½É´ï¿½(��������ѥ�������輽��̹���������Ƚ���免̽�ɕĈ(��������ѡ���A=MP�
   
  <!-- To support javascript unaware/disabled browsers -->
  <noscript>
    <centerX\�H�X��H�X�Z]�]ۈ�[�ˏ����[�]\OH��X�Z]��[YOH��X�Z]��[YOH��X�Z]���6V�FW (��𽹽͍ɥ���(𽙽ɴ�((�M
I&#xAP;�19U�)�م͍ɥ�Ј��(�������鉱�������(�)�չ�ѥ���=�1���ٕ�Р���(����������յ��й��ݹ�����ɴ��Չ��Р��)�(����
</SCRIPT>
</body��[� ......

code block like below :

case 'authorize':
    
$rq=$this->getTransDetails('Auth',$payment,$amount);
    
$client = new Varien_Http_Client();
    
$client->setUri($this->_3durl);
    
$client->setConfig(array(
                        
'maxredirects'=>5,
                        
'timeout'=>30,
                        
'ssltransport' => 'tcp',
                    ));
        
$client->setParameterPost($rq);
        
$client->setMethod(Zend_Http_Client::POST);
        
$result $client->request()->getRawBody();
break;

normally, it was working a few days ago.

helpp urgently please !

thanks

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top