Magento Forum

   
Top-menu not displaying with hellowired template
 
Framar
Jr. Member
 
Total Posts:  9
Joined:  2010-12-05
 

Hello,

It’s the firts time that I work with Magento.

I dont understand because the top-menu not worked with Hellowired template http://www.hellothemes.com/demo/?theme=hellowired

I show the code of top.phtml and header.phtml if can help.

top.phtml

<?php
/**
 * Top menu for store
 *
 * @see Mage_Catalog_Block_Navigation
 */
?>
<?php $_menu 
''?>
<?php 
foreach ($this->getStoreCategories() as $_category): ?>
    <?php $_menu 
.= $this->drawItem($_category?>
<?php 
endforeach ?>
<?php 
if ($_menu): ?>
<div class="nav-container">
    <
ul id="nav">

        
<?php $_anyActive false; foreach ($this->getStoreCategories() as $_category{ $_anyActive $_anyActive || $this->isCategoryActive($_category); } ?>
         
<li class="home <?php echo !$_anyActive ? 'active' : '' ?>"><a href="<?php echo $this->getUrl('')?>"><span><?php echo $this->__('Home'?></span></a></li
         
        
<?php echo $_menu?>
        
    
</ul>
</
div>
<?php endif; ?>

header.phtml

<div class="header-container">
    <
div class="header">
        
<?php if ($this->getIsHomePage()):?>
        
<h1 class="logo"><strong><?php echo $this->getLogoAlt() ?></strong><a href="<?php echo $this->getUrl('') ?>" title="<?php echo $this->getLogoAlt() ?>" class="logo"><img src="<?php echo $this->getLogoSrc() ?>" alt="<?php echo $this->getLogoAlt() ?>" /></a></h1>
        
<?php else:?>
        
<a href="<?php echo $this->getUrl('') ?>" title="<?php echo $this->getLogoAlt() ?>" class="logo"><strong><?php echo $this->getLogoAlt() ?></strong><img src="<?php echo $this->getLogoSrc() ?>" alt="<?php echo $this->getLogoAlt() ?>" /></a>
        
<?php endif?>
    
    
<div class="cms-links">
    <
ul>
    <
li class="welcome">
    
<?php echo $this->getWelcome()?></li<?php echo $this->getChildHtml('topSearch'?>
  <?php 
echo $this->getLayout()->createBlock('cms/block')->setBlockId('toplinks')->toHtml() ?>
    
</ul>
    </
div>
       
       <
div class="access">
          
<?php echo $this->getChildHtml('topLinks'?>
       
</div>
    </
div>
    <
div id="navigation">
    
<?php echo $this->getChildHtml('topMenu'?>
    <?php 
//echo $this->getChildHtml('connect') ?>
    
<div class="clearfix"></div>
    </
div>
    <!-- <
div class="quick-access">
        
<?php echo $this->getChildHtml('store_language'?>
        
<class="welcome-msg"></p>
     
    </
div> -->
    
<?php echo $this->getChildHtml('topBar'?>
    <?php 
//echo $this->getChildHtml('topContainer'); ?>
</div>

What block must I create for showing the top menu?

How I do to find the block’s “identifier”?

I hope that you can help me!

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
eloyvieira
Jr. Member
 
Total Posts:  1
Joined:  2010-12-22
 

the same problem =(

 
Magento Community Magento Community
Magento Community
Magento Community
 
LewisSellers
Member
 
Total Posts:  33
Joined:  2009-06-02
 

Has anyone found a solution to this problem yet?

Kind Regards
Lewis

 
Magento Community Magento Community
Magento Community
Magento Community
 
agalpin
Jr. Member
 
Total Posts:  8
Joined:  2010-10-29
 

Make sure that your categories of your products are linked to your default category and that will make it visible. grin

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top