Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

upgrade from 1.4.2 RC1 to RC2 error with Magento connect
 
gfxguru
Sr. Member
 
Total Posts:  186
Joined:  2008-11-20
 

I’ve upgraded a database and connected to site, attributes, products, categories all good but when I goto Magento connect I get:

Warning: require_once(lib/Mage/Autoload/Simple.php) [function.require-once]: failed to open stream: No such file or directory in C:\www\domain.net\wwwroot\downloader\index.php on line 32

Fatal error: require_once() [function.require]: Failed opening required ‘lib/Mage/Autoload/Simple.php’ (include_path=’.;\xampp\php\PEAR’) in C:\www\domain.net\wwwroot\downloader\index.php on line 32

any ideas on how to fix? I notied completely new folder extensions in diff. I’m assuming it’s looking for extensions I had installed? I had about 4 installed for 1.4.2 rc1. All working fine.

Upgrade seems to have gone fine though all products, categories, settings etc. all look good. Copied over theme and media and everything came up perfectly with session/cache clear. Just can figure out do I need to copy over modules then try or does rc2 require install for new extensions capabilities?

 
Magento Community Magento Community
Magento Community
Magento Community
 
gfxguru
Sr. Member
 
Total Posts:  186
Joined:  2008-11-20
 

ok actually I got the same error in a fresh install. 1.4.2 RC2 Running XAMPP on Windows 7.

 
Magento Community Magento Community
Magento Community
Magento Community
 
sunjir
Jr. Member
 
Total Posts:  2
Joined:  2010-03-24
 

new install Magento 1.4.2 rc2 have same err

Warning: require_once(lib/Mage/Autoload/Simple.php) [function.require-once]: failed to open stream: No such file or directory in/magento/downloader/index.php on line 32

Fatal error: require_once() [function.require]: Failed opening required ‘lib/Mage/Autoload/Simple.php’ (include_path=’.:/usr/lib64/php:/usr/lib/php’) in /magento/downloader/index.php on line 32

Bluehost all file 755

 
Magento Community Magento Community
Magento Community
Magento Community
 
Florian Moker
Jr. Member
 
Total Posts:  4
Joined:  2010-05-22
 

just replace line 32 in

C:\\www\\domain.net\\wwwroot\\downloader\\index.php

\"lib/Mage/Autoload/Simple.php\"

with
\"../lib/Mage/Autoload/Simple.php\"

 
Magento Community Magento Community
Magento Community
Magento Community
 
gfxguru
Sr. Member
 
Total Posts:  186
Joined:  2008-11-20
 

are you serious? ok that worked but now I get

Fatal error: Class ‘Maged_Model_Connect’ not found in C:\www\domain.net\wwwroot\downloader\Maged\Controller.php on line 572

after I login.

 
Magento Community Magento Community
Magento Community
Magento Community
 
gfxguru
Sr. Member
 
Total Posts:  186
Joined:  2008-11-20
 
Florian Moker - 04 December 2010 11:05 AM

just replace line 32 in

C:\\www\\domain.net\\wwwroot\\downloader\\index.php

\"lib/Mage/Autoload/Simple.php\"

with
\"../lib/Mage/Autoload/Simple.php\”

This is not a fix, Its runs fine on the server with out change.

 
Magento Community Magento Community
Magento Community
Magento Community
 
gfxguru
Sr. Member
 
Total Posts:  186
Joined:  2008-11-20
 

Does anyone have any idea why this is going on? I transferred the app to server, get same error. Now this is getting too me because I have the Magento Connect working fine on RC1 plus a few other sites running on same machine.... :0

 
Magento Community Magento Community
Magento Community
Magento Community
 
gfxguru
Sr. Member
 
Total Posts:  186
Joined:  2008-11-20
 

ok I can see there are files missing from the downloader directory.

 
Magento Community Magento Community
Magento Community
Magento Community
 
gfxguru
Sr. Member
 
Total Posts:  186
Joined:  2008-11-20
 

WOW looking into some of these changes to Magento Connect and using Magento’s PEAR / Registry is looking wild.

 
Magento Community Magento Community
Magento Community
Magento Community
 
SteveBerrill
Member
 
Avatar
Total Posts:  36
Joined:  2010-09-21
Preston
 

Hi, I had the same problem. All i did to fix it was upload the downloader directory again and ovewrte all and was fixed pronto, just thought id share with you incase this problem still exists wink

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top