Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

PHP error while installing
 
Rastem
Jr. Member
 
Total Posts:  5
Joined:  2007-11-28
 

While installing I hit a PHP error:

Fatal error: Call to a member function getClassName() on a non-object in /home/testing/web/public/magento/app/code/core/Mage/Core/Model/Resource.php on line 92

The only thing different in this install than normal is the use of pdo_mysql instead of mysqli (thread found at http://www.magentocommerce.com/boards/viewthread/1834/)

Anyone else run into this problem? Any ideas on how to solve it?

*EDIT*

For some reason I cannot post to this topic (bug in forum software?) so I’m editing this post to include the answer to your question.

Version installed: Beta 0.6.14100

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michae1
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 

Hi Rastem,

Which Magento version do you try to install ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Rastem
Jr. Member
 
Total Posts:  5
Joined:  2007-11-28
 

Version installed: Beta 0.6.14100

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top