Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Onepage Checkout Failure. Redirecting to Failure URL. 
 
mahesh
Jr. Member
 
Total Posts:  1
Joined:  2010-04-29
 

Hi All,

In my Onepage Checkout process, after the final step of Place Order, it keeps loading for 30~40 seconds, after which it redirects to the Failure URL, i.e., the Shopping cart page.
I am able to pass through all the steps,
billing address >> shipping address >> shipping method >> Order Review >> Place Order
but after final Place Order, it keeps Loading… for 30~40 seconds and redirects back to Shopping cart page.

On Close inspection, i saw that, when Place Order is clicked, it keeps loading..., and after 30~40 seconds, it is returning 500 Internal Server Error, which makes the redirection to Failure URL,

Below are the php.ini settings.

max_execution_time 360
max_input _time 60
memory_limit 320M,

We have installed magento on IIS7, and we have access to web.config only.
is it a problem of Connection Timeout or Request Timeout ? if yes, how to extend those settings?

To check if Connection timeout a problem, we placed a test script on the server as shown below.

<?php
$str
=20;
sleep(60);
echo 
$str;
?>
But the above script also, fails and returns 500 Internal Server Error, after 30~40 seconds.

Any suggestions or help?, thanks in advance.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Jose M Moreno
Member
 
Total Posts:  58
Joined:  2008-09-01
 

Hello, we have the same problem in 1.4.1.1 installation, place order spend about 60 seconds and mostly redirect to cart (sometimes the order finish ok),

Please, it’s very important to fix this problem, it’s in a production enviroment.

BR

 
Magento Community Magento Community
Magento Community
Magento Community
 
HectorPN
Member
 
Total Posts:  74
Joined:  2010-03-21
Adelaide, Australia
 

We’re experiencing the same error in a production server. It has been massively frustrating since it cannot be replicated easily. In fact, customers who attempt twice, usually succeed (not always, we had one who attempted FIVE times and gave up and called.

PLEEEEEEEZE do share your findings. I have disabled all security validations (HTTP_VIA, Browser agent, etc)… have 300 PHP execution time and it continues to happen.

Any pointers will earn you a religious following around the world.

smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
HectorPN
Member
 
Total Posts:  74
Joined:  2010-03-21
Adelaide, Australia
 

By the way, this is happening with Virtual Products with Custom Options. Haven’t tried other types but apparently it has something to do with the problem:  http://www.magentocommerce.com/boards/viewthread/195453

Maybe joining the array / EAV for product/custom options is crashing the query?

 
Magento Community Magento Community
Magento Community
Magento Community
 
ryan_shuhart
Jr. Member
 
Total Posts:  2
Joined:  2009-11-30
 

I searched for hours with the same problem. After I upgraded from 1.4.1 to 1.6.1 the end of the check out process would redirect back to the cart.

The order would go through the credit card process and even charge the card but nothing showed up in the admin and no confirmation emails were sent out. All I new was there was an error.

Undefined offset: 1 in app/code/core/Mage/Paygate/Model/Authorizenet.php on line 1251

John from Tranquilblue was an enormous help. He tracked down the error and found out what was causing it. Something about an array. Anyway, he said all he had to do was fix 1 character. I hope this helps. If not I suggest giving John a call. He could not have been more of a life saver.

 
Magento Community Magento Community
Magento Community
Magento Community
 
HectorPN
Member
 
Total Posts:  74
Joined:  2010-03-21
Adelaide, Australia
 

In our case it was fixed by changing the MY.CNF (MySQL settings) like this:

connect_timeout = 120
wait_timeout = 1800

Apparently creating the order in the database may be a bit complex SQL query so it takes long and may sometimes timeout. Making the timeout thresholds really has worked like magic.

You’ll need root access (VPS or dedicated server) to change this, though.

Linux: /etc/my.cnf
Win: C:\Program Files\MySQL\MySQL Server 5.1\my.ini

 
Magento Community Magento Community
Magento Community
Magento Community
 
WEBPAL
Jr. Member
 
Total Posts:  18
Joined:  2009-05-28
Arad
 
HectorPN - 26 October 2011 08:36 PM

In our case it was fixed by changing the MY.CNF (MySQL settings) like this:

connect_timeout = 120
wait_timeout = 1800

Apparently creating the order in the database may be a bit complex SQL query so it takes long and may sometimes timeout. Making the timeout thresholds really has worked like magic.

You’ll need root access (VPS or dedicated server) to change this, though.

Linux: /etc/my.cnf
Win: C:\Program Files\MySQL\MySQL Server 5.1\my.ini

This soltion also work for us.
Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top