Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Magento Problem, Frontend and Admin. PLEASE HELP
 
fastboxgaming
Sr. Member
 
Avatar
Total Posts:  101
Joined:  2008-10-11
 

I have no idea what has happened to my site. All of a sudden, My product menus dont drop down when you mouseover the main categories. Even worst, when I login to the backend, non of the menu’s drop down, and you can’t click on anything. I was hoping it was a problem with my computer or IE, but nope, it does the same thing on my friends computer, and on firefox.

I havent made any updates or anything. This just happened overnight and I noticed it earlier today. The only thing I did yesterday was install the blank template via magento connect. But I didnt even turn on the template or anything. All I did was install it.

ahhhhhhhhhhhhhhhhhhhhhh

oh yeah, heres the page:
http://www.fastboxgaming.com

 
Magento Community Magento Community
Magento Community
Magento Community
 
TomC
Sr. Member
 
Total Posts:  191
Joined:  2007-12-01
 

I’m having the same stupid problem - what the heck ???

 
Magento Community Magento Community
Magento Community
Magento Community
 
Aspiration Host
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

What are you “js” folder’s file permissions?
Try to CHMOD all files there to 644 and directories to 755.

 
Magento Community Magento Community
Magento Community
Magento Community
 
fastboxgaming
Sr. Member
 
Avatar
Total Posts:  101
Joined:  2008-10-11
 

Well, I guess i figured out the problem, though I dont know why it all of a sudden happened since I’ve been using Magento for a month now. But anyways, if you read this post, and use the included file attached, it should work(it solved my problem)

http://www.magentocommerce.com/boards/viewthread/4679/P15/

 
Magento Community Magento Community
Magento Community
Magento Community
 
TomC
Sr. Member
 
Total Posts:  191
Joined:  2007-12-01
 
JLHC - 25 October 2008 07:50 PM

What are you “js” folder’s file permissions?
Try to CHMOD all files there to 644 and directories to 755.

Why should this even be an issue?  Should not the backend admin work out of the box for users?

And what’s the difference between the “files” and “directories?” Are you saying that I need to set permissions for each and every file within my js directory - one by one?

I can’t understand why the Magento Development Team seems to think that everyone on the planet must be quantum physics experts to work with Magento.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Aspiration Host
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

The issue is not caused by Magento but by some of the server which your site is hosted. Magento is working fine on our servers.

If you have SSH access you can use the following command. Otherwise you can just ask your hosting provider to do it for you.

find . -type d -print0 | xargs -0 chmod 0755 && find . -type f -print0 | xargs -0 chmod 0644

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top