Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Remove Currency selector
 
lbeetles
Member
 
Total Posts:  66
Joined:  2009-02-04
 

Hi, I am using the Free classic theme (10 colors) and I would like to remove the currency drop down selector from the left side panel.

I have tried looking in the catalog.xml as well as the phtml’s for the theme but to no avail.

How can i do this?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Jummy
Jr. Member
 
Total Posts:  10
Joined:  2010-11-09
 

hi lads, i have same problem, my currency selector is not showing on the home page, can some “magento gurus” help me on this please, other things are working fine, great software but needed some help on this issue. many thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
sherrie
Moderator
 
Avatar
Total Posts:  1655
Joined:  2007-12-14
Waterloo, ON
 

You can disable/enable it in app/design/frontend/base/default/layout/directory.xml, look for the following around line 42:

<block type="directory/currency" name="currency" before="catalog.leftnav" template="directory/currency.phtml"/>

This may be different depending on your template, but it’s the default location in 1.4.1.1.

You will have to refresh your layout cache to see the changes.

 
Magento Community Magento Community
Magento Community
Magento Community
 
brunomarshall
Guru
 
Avatar
Total Posts:  367
Joined:  2009-08-04
 

Hi,
Go to directory.xml there in left you can see block named as currency comment it this will remove currency

<catalog_category_default>
        <
reference name="left">
        <!--      <
block type="directory/currency" name="currency" before="catalog.leftnav" template="directory/currency.phtml"/> -->
        </
reference>
    </
catalog_category_default>
 
Magento Community Magento Community
Magento Community
Magento Community
 
lbeetles
Member
 
Total Posts:  66
Joined:  2009-02-04
 
sherrie - 01 December 2010 01:31 PM

You can disable/enable it in app/design/frontend/base/default/layout/directory.xml, look for the following around line 42:

<block type="directory/currency" name="currency" before="catalog.leftnav" template="directory/currency.phtml"/>

This may be different depending on your template, but it’s the default location in 1.4.1.1.

You will have to refresh your layout cache to see the changes.

Thanks that worked a treat grin

 
Magento Community Magento Community
Magento Community
Magento Community
 
sherrie
Moderator
 
Avatar
Total Posts:  1655
Joined:  2007-12-14
Waterloo, ON
 

Perfect smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
MagePsycho
Mentor
 
Avatar
Total Posts:  1702
Joined:  2009-06-23
 

Instead of going to individual xml files i would love to use: local.xml in custom layout folder as:

<catalog_category_default>
    <
remove name="currency" />
</
catalog_category_default>

Hope this helps too smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
ketaki
Jr. Member
 
Total Posts:  8
Joined:  2012-02-28
 

try this one.....!!! grin

<catalog_category_view>
</reference>
<reference name="left"> <remove name="currency" />
</reference>
</catalog_category_view>

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top