Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

500 Error after upgrade attempt
 
dkdesig
Jr. Member
 
Total Posts:  19
Joined:  2008-10-23
 

Hi all i’m a noob, i’ve been using 1.1.4 and never tried upgrading until just now.

I followed this post to do it via Magento Connect Manager. As suggested in thread I initiated the downloader, much code ran and then stopped. I’m attaching a txt file of the code.

Nothing happened after that, seemed to freeze. I didn’t complete any steps after that.

Now I have a 500 internal server error when trying to access admin and store front.

Huh??

File Attachments
downloadmanager.txt  (File Size: 4KB - Downloads: 134)
 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

If you have met with an Internal Server Error page, change all your file permissions to 644 and 755 as before and it should be working again.
Magento Connect Manager is known to reset the file permissions to the default (wrong) values.

 
Magento Community Magento Community
Magento Community
Magento Community
 
dkdesig
Jr. Member
 
Total Posts:  19
Joined:  2008-10-23
 

Thanks. I changed what I thought were the right folders:

* magento/app/etc
* magento/media (and all sub-folders within media)
* magento/var
* magento/var/.htaccess

to 777

Still have the error, I bet I missed some others. Could you pass along the ones I missed? Or do I need to do this to all files and folders?

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

The folders you stated need to be CHMOD to 777 (assuming your server is not suPHP enabled).
All other files need to be CHMOD to 644 while all other folders to 755.

 
Magento Community Magento Community
Magento Community
Magento Community
 
dkdesig
Jr. Member
 
Total Posts:  19
Joined:  2008-10-23
 

Awesome. I wasn’t aware that magento had a habit of resetting perms. (what a noob)

Do these CHMOD’s need to happen down through the zillions of directories, sub-directories and files? or just off the main magento/ directory? (actually mine’s named shop/ )

Sorry for these basic questions, I’m a beginning student of programming and want to make sure I have sound fundamentals.

Thanks for the help!

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

Yes it needs to done for every file and directory. If you have SSH access try running the following command:-

find . -type d -print0 | xargs -0 chmod 0755 && find . -type f -print0 | xargs -0 chmod 0644

Otherwise you can ask your hosting provider to do this for you.

 
Magento Community Magento Community
Magento Community
Magento Community
 
dkdesig
Jr. Member
 
Total Posts:  19
Joined:  2008-10-23
 

Thanks for the help, everything is back to normal!

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

No problem. Be sure to showcase your store here when it is ready. wink

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top