Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

There has been an error processing your request (After server failure and restore)
 
mcflause
Jr. Member
 
Total Posts:  10
Joined:  2010-10-29
 

My host’s server crashed, lost data. But then they restored it.

After the crash, and subsequent data restore, when I try to enter the front-end I see

“There has been an error processing your request
Exception printing is disabled by default for security reasons.

Error log record number: 362449665553”

and when I try to enter the back-end I see

“There has been an error processing your request
Exception printing is disabled by default for security reasons.

Error log record number: 593334012552”

And my host is pretty much ignoring me now. Any idea what the problem is guys?

Thanks in advance.

 
Magento Community Magento Community
Magento Community
Magento Community
 
chiefair
Mentor
 
Avatar
Total Posts:  1848
Joined:  2009-06-04
 

FTP in to your server, go to your var/report folder and start reading the files with the pertinent numbers. These will be stack traces that give you an idea of what’s wrong. With a complete server meltdown it could be anything from incomplete install of software to simple failure to set file permissions.

Post them here so we can see what it’s complaining about.

 
Magento Community Magento Community
Magento Community
Magento Community
 
mcflause
Jr. Member
 
Total Posts:  10
Joined:  2010-10-29
 

I looked at one of error files and this is what I saw. I tried to find the user it is saying that the access is denied for, but no luck. And then I tried to find the database but I’m pretty sure that it was deleted and not replaced. Is their anyway to get magento to rebuild the mysql database?

Also I have the backup (used cpanel to backup then downloaded the zip file). Should their be a mysql backup in their?

Or am I totally wrong with my assumptions?

Thanks for the quick response though! I was amazed smile

Heres the data from one of the error files (With user and web address [*Removed*] )

a:4:{i:0;s:98:"SQLSTATE[28000] [1045] Access denied for user '[*Removed*]'@'localhost' (using password: YES)"[*Removed*]"#0 [*Removed*]/html/lib/Zend/Db/Adapter/Pdo/Mysql.php(96): Zend_Db_Adapter_Pdo_Abstract->_connect()
#1 [*Removed*]/html/lib/Varien/Db/Adapter/Pdo/Mysql.php(251): Zend_Db_Adapter_Pdo_Mysql->_connect()
#2 [*Removed*]/html/lib/Zend/Db/Adapter/Abstract.php(448): Varien_Db_Adapter_Pdo_Mysql->_connect()
#3 [*Removed*]/html/lib/Zend/Db/Adapter/Pdo/Abstract.php(238): Zend_Db_Adapter_Abstract->query('SET NAMES utf8', Array)
#4 /[*Removed*]html/lib/Varien/Db/Adapter/Pdo/Mysql.php(333): Zend_Db_Adapter_Pdo_Abstract->query('SET NAMES utf8', Array)
#5 [*Removed*]/html/app/code/core/Mage/Core/Model/Resource/Type/Db/Pdo/Mysql.php(45): Varien_Db_Adapter_Pdo_Mysql->query('SET NAMES utf8')
#6 [*Removed*]/html/app/code/core/Mage/Core/Model/Resource.php(93): Mage_Core_Model_Resource_Type_Db_Pdo_Mysql->getConnection(Object(Mage_Core_Model_Config_Element))
#7 [*Removed*]/html/app/code/core/Mage/Core/Model/Mysql4/Abstract.php(297): Mage_Core_Model_Resource->getConnection('core_read')
#8 [*Removed*]/html/app/code/core/Mage/Core/Model/Mysql4/Abstract.php(312): Mage_Core_Model_Mysql4_Abstract->_getConnection('read')
#9[*Removed*]/html/app/code/core/Mage/Core/Model/Mysql4/Abstract.php(332): Mage_Core_Model_Mysql4_Abstract->_getReadAdapter()
#10 [*Removed*]/html/app/code/core/Mage/Core/Model/Mysql4/Collection/Abstract.php(97): Mage_Core_Model_Mysql4_Abstract->getReadConnection()
#11 [*Removed*]/html/app/code/core/Mage/Core/Model/Config.php(1206): Mage_Core_Model_Mysql4_Collection_Abstract->__construct(Object(Mage_Core_Model_Mysql4_Website))
#12[*Removed*]/html/app/code/core/Mage/Core/Model/Config.php(1239): Mage_Core_Model_Config->getModelInstance('core_mysql4/web...', Object(Mage_Core_Model_Mysql4_Website))
#13 [*Removed*]html/app/Mage.php(460): Mage_Core_Model_Config->getResourceModelInstance('core/website_co...', Object(Mage_Core_Model_Mysql4_Website))
#14 [*Removed*]/html/app/code/core/Mage/Core/Model/Abstract.php(208): Mage::getResourceModel('core/website_co...', Object(Mage_Core_Model_Mysql4_Website))
#15 [*Removed*]/html/app/code/core/Mage/Core/Model/Abstract.php(213): Mage_Core_Model_Abstract->getResourceCollection()
#16 [*Removed*]/html/app/code/core/Mage/Core/Model/App.php(532): Mage_Core_Model_Abstract->getCollection()
#17 [*Removed*]/html/app/code/core/Mage/Core/Model/App.php(393): Mage_Core_Model_App->_initStores()
#18 [*Removed*]/html/app/code/core/Mage/Core/Model/App.php(299): Mage_Core_Model_App->_initCurrentStore('', 'store')
#19 [*Removed*]/html/app/Mage.php(596): Mage_Core_Model_App->run(Array)
#20 [*Removed*]/html/index.php(80): Mage::run('', 'store')
#21 {main}"
;s:3:"url";s:1:"/";s:11:"script_name";s:10:"/index.php";}

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
chiefair
Mentor
 
Avatar
Total Posts:  1848
Joined:  2009-06-04
 

Given the security on mysql, you would probably have to be root user to create a database. They need to recreate your database for Magento, and then you need them to do a database restore.

You either backup Magento through the Administrator tools or through the phpMyAdmin panel. You should be able to do the restore through the phpMyAdmin panel once they have created your database.

 
Magento Community Magento Community
Magento Community
Magento Community
 
mcflause
Jr. Member
 
Total Posts:  10
Joined:  2010-10-29
 

I was just coming in to close the topic. When they restored the server they somehow missed my magento database and user for mysql. Thanks for pointing me in the right direction though.

I found the .sql file in my backup and restored the database and re-created the user.

So all is well.

Thanks so much for the help chiefair.

Please close this thread

 
Magento Community Magento Community
Magento Community
Magento Community
 
jicksonkoottala
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2012-03-06
Aluva
 

There has been an error processing your request SQLSTATE[28000] [1045] Access denied for user \\\\\\’demo\\\\\\’@\\\\\\’localhost\\\\\\’ (using password: YES)

This error will occur if there is no database connection .. First you need to check your local.xml file ... then check the url path in core_config_data in your database .... clear your cache session and locks ....  if the error still appear after doing all these things \\\\\\\"YOU JUST LOOK IN YOUR app/etc folder ...... if there is any extra xml file just delete that particular file ...... i got the same issue .. found a local_org.xml file in etc folder ....... JUST DELETE THAT FILE IT WILL WORK PROPERLY ..........  grin

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top