Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 2 of 2
IE9 one payment method - fields disabled - shoppers can’t checkout :(
 
viditech
Jr. Member
 
Total Posts:  7
Joined:  2008-08-27
 

IE 9 is no longer in Beta on the Microsoft website and the only browser you can now download.  Users of IE 9 are unable use the drop down on the one page checkout to select State or Country unless they are in compatibility mode.  This applies for two of my magento websites 1.3.2.3 and 1.4.2

Thank you so much for your suggestions thus far, but it seems like these are just temporary (forcing compatibility mode, forcing IE8, etc).  Does anyone have a more permanent solution to this IE/Magento problem?

 
Magento Community Magento Community
Magento Community
Magento Community
 
chiefair
Mentor
 
Avatar
Total Posts:  1848
Joined:  2009-06-04
 

Adding

<meta http-equiv="X-UA-Compatible" content="IE=8" />
to the page headers will be the fix for 1.4.x.x and later until someone figures out what’s incompatible in the Prototype framework.

Set it to IE=7 if you have earlier.

The usual cause is that Magento is using a earlier version of these than what’s available and always is a few steps behind on every upgrade.

The main culprit probably starts with opcheckout.js and you need to do some debugging on it in the browser where it’s failing. As long as the error is in this piece of javascript, it can be fixed. If it’s a Prototype function call, then the framework has to be upgraded.

Since the meta tag is working for me, I’ll stick with it until 1.6 is stable.

If you want to really fix the problem and be able to remove the meta tag, you go over to the Prototype website, download the latest version of the framework, overwrite your current framework files in /js/prototype, cross your fingers and pray there are no problems running Magento with it.

 
Magento Community Magento Community
Magento Community
Magento Community
 
maiconrcf
Jr. Member
 
Avatar
Total Posts:  10
Joined:  2011-04-04
 

Hi.

the quickest solution for me was:
go: skin/frontend/base/default/js/opcheckout.js and comment the line(aprox. 643) :
// elements.disabled = true;

remmenbering that i onlyi have one payment method.

 
Magento Community Magento Community
Magento Community
Magento Community
 
rshuhart@frattoys
Jr. Member
 
Total Posts:  5
Joined:  2010-08-19
 

I have an online store called www.frattoys.com.
The problem is when your customer tries to check out they cannot access the drop down box that has the credit card selections. Everything is greyed out. The issue is with IE9 not being compatible with Magento. The solution is to trick IE9 into thinking it is IE8.

This is a two step process:

First, add the below line to your head.phtml file right below your title tag - (app/design/frontend/Your Template(usually default)/Your Template/template/page/html/head.phtml).

<meta http-equiv=\"X-UA-Compatible\" content=\"IE=8\" />

Second, find your .htaccess file and add the below two lines of code -

BrowserMatch MSIE best-standards-support
Header set X-UA-Compatible IE=8 env=best-standards-support

This should work. It did for me.
If you need any help with this you can call Johnny from www.tranquilblue.com

 
Magento Community Magento Community
Magento Community
Magento Community
 
Turnkeye
Enthusiast
 
Avatar
Total Posts:  908
Joined:  2008-12-20
URL: turnkeye.com
 

The solution is to add meta tag OR add commands to .htaccess.
Both solutions are equal, it will make IE9 to view your website in IE8 mode.

If you don’t like theme modification solution, just add these commands to the end of your .htaccess file:

BrowserMatch MSIE best-standards-support
Header set X
-UA-Compatible IE=8 env=best-standards-support
 
Magento Community Magento Community
Magento Community
Magento Community
 
chiefair
Mentor
 
Avatar
Total Posts:  1848
Joined:  2009-06-04
 

The easy answer, set the user agent compatible meta tag or as in the previous entry, your .htaccess UA detect

For 1.4.1.1

<meta http-equiv="X-UA-Compatible" content="IE=8" />
for earlier versions
<meta http-equiv="X-UA-Compatible" content="IE=7" />

The hard and correct answer, upgrade to a newer version of Magento that has a Prototype library compatible with IE 9 and then rework your template to function properly.

Some have tried to upgrade Prototype itself, but that leads to other issues as incompatibilities of older Magento code start showing.

 
Magento Community Magento Community
Magento Community
Magento Community
 
rvass
Jr. Member
 
Total Posts:  25
Joined:  2010-02-20
 

We also had this issue and got around it with ht access

add this and it should work

BrowserMatch MSIE best-standards-support
Header set X-UA-Compatible IE=8 env=best-standards-support

 
Magento Community Magento Community
Magento Community
Magento Community
 
bbatten
Jr. Member
 
Total Posts:  18
Joined:  2010-03-17
 

I took a different approach here, I was only having the problem on the checkout page but I wanted the users to continue to see the rest of the site in IE9.  So the code below only forces IE9 users into compatibility mode on the checkout page:

<?php 
    $controller_name 
$this->getRequest()->getControllerName(); 
    if(isset(
$_SESSION)){$_SESSION['controller_name'$controller_name;}
    
    
if($controller_name == 'onepage'{
        
echo '<meta http-equiv="X-UA-Compatible" content="IE=8" />';
    
}

?>
 
Magento Community Magento Community
Magento Community
Magento Community
 
silverpenhouse
Member
 
Avatar
Total Posts:  72
Joined:  2008-02-16
Virginia
 

Hi 14ner,

What file did you insert that code into?

 
Magento Community Magento Community
Magento Community
Magento Community
 
bbatten
Jr. Member
 
Total Posts:  18
Joined:  2010-03-17
 

Hi Silverpenhouse,

Paste the code in the head.phtml file towards the top with the other <meta> tags.

-14ner

 
Magento Community Magento Community
Magento Community
Magento Community
 
vicch
Jr. Member
 
Total Posts:  1
Joined:  2011-03-04
 
maiconrcf - 20 June 2011 06:45 AM

Hi.

the quickest solution for me was:
go: skin/frontend/base/default/js/opcheckout.js and comment the line(aprox. 643) :
// elements.disabled = true;


remmenbering that i onlyi have one payment method.

This one works in the end. Thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ikkes
Jr. Member
 
Total Posts:  3
Joined:  2010-04-21
 

Hi guys,

We had the same issue and switching on the compatibility mode just is not a option for us....
Have done the following to solve this (bit dirty):

Create a local version of the:

\skin\frontend\default\default\js\opcheckout.js

and put in the following in the payment init : function () last line (around line 657), right after this.afterInit():

jQuery(’#checkout-payment-method-load input[name=”HEREYOUROPTIONNAME”]’).removeAttr(’disabled’);

This solved the issue for us. It removes the disabled attribute with jQuery after the init.

Succes!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
SimonLindner
Member
 
Avatar
Total Posts:  31
Joined:  2011-09-08
Bremen
 

Hey ikkes,

this fix doesn’t seem to work in 1.5.
Which version are you on?

Regards
Simon

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 2 of 2