Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Mauvaise configuration multi site. 
 
neuro
Sr. Member
 
Avatar
Total Posts:  104
Joined:  2008-09-29
France
 

Bonjour.
Je n’arrive pas à accéder aux catégories des autres site que le default.
J’ai pourtant réussit à afficher une page d’accueil différente pour chacun de mes sous sites.

Voici dans le sous dossier racine pour mon nouveau site l’index.php

<?php
if (version_compare(phpversion(), '5.2.0''<')===true{
    
echo  '<div style="font:12px/1.35em arial, helvetica, sans-serif;"><div style="margin:0 0 25px 0; border-bottom:1px solid #ccc;"><h3 style="margin:0; font-size:1.7em; font-weight:normal; text-transform:none; text-align:left; color:#2f2f2f;">Whoops, it looks like you have an invalid PHP version.</h3></div><p>Magento supports PHP 5.2.0 or newer. <a href="http://www.magentocommerce.com/install" target="">Find out</a> how to install</a> Magento using PHP-CGI as a work-around.</p></div>';
    exit;
}

$mageFilename 
'../app/Mage.php';

if (!
file_exists($mageFilename)) {
    
if (is_dir('downloader')) {
        header
("Location: downloader");
    
else {
        
echo $mageFilename." was not found";
    
}
    
exit;
}

require_once $mageFilename;

Varien_Profiler::enable();

Mage::setIsDeveloperMode(true);

ini_set('display_errors'1);

umask(0);
////////////////////////////////////////
Mage::run('mon_sous_site');
////////////////////////////////////////

J’ai créé une catégorie root, une home page parsonalisée et des sous et sous-sous catégories mais lorsque je tombe sur la homepage, ca tourne nickel, puis quand je clique sur la catégorie, j’ai le message d’erreur suivant:
“The requested URL localhost/mon_autre_site/mon_autre_site/index.php/catégorie was not found on this server.”
J’ai une erreur aussi sur la page d’acceuil de ce site : les sous catégories ne saffichent pas, il n’y a que la prinipale (sous la root) qui s’affiche.

Image Attachments
back-office.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
SeL_
Magento Team
 
Avatar
Total Posts:  1140
Joined:  2007-10-10
Paris, France
 

Bonjour,

Peux-tu poster ta configuration stp ? website (site web), store (magasin), store view (vue magasin)
J’ai l’impression que tu détournes l’utilisation des site multiples de Magento.
As-tu regardé la doc ici ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
neuro
Sr. Member
 
Avatar
Total Posts:  104
Joined:  2008-09-29
France
 

Je m’étais trompé dans la config qui apparait dans mon screen :/
Ça fonctionne mieux maintenant wink
Merci SEL

Image Attachments
magerreur.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top